libreadonly-perl_2.050-1_all.deb


Advertisement

Description

libreadonly-perl - facility for creating read-only scalars, arrays and hashes

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libreadonly-perl_2.050-1_all.deb
Package name libreadonly-perl
Package version 2.050
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Readonly
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 22.12 KB
Installed size 55.00 KB
Readonly is a facility for creating non-modifiable variables.
This is useful for configuration files, headers, etc.
It can also be useful as a development and debugging tool, for catching
updates to variables that should not be changed.

Alternatives

Package Version Architecture Repository
libreadonly-perl_2.050-1_all.deb 2.050 all Debian Main
libreadonly-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libreadonly-perl_2.050-1_all.deb
Source Package libreadonly-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libreadonly-perl deb package:
    # sudo apt-get install libreadonly-perl

Files

Path
/usr/share/doc/libreadonly-perl/changelog.Debian.gz
/usr/share/doc/libreadonly-perl/changelog.gz
/usr/share/doc/libreadonly-perl/copyright
/usr/share/doc/libreadonly-perl/examples/benchmark.pl
/usr/share/man/man3/Readonly.3pm.gz
/usr/share/perl5/Readonly.pm

Changelog

2016-07-23 - gregor herrmann <gregoa@debian.org>
libreadonly-perl (2.050-1) unstable; urgency=medium
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
* Import upstream version 2.050.
2016-05-07 - gregor herrmann <gregoa@debian.org>
libreadonly-perl (2.040-1) unstable; urgency=medium
* Import upstream versions 2.030, 2.040.
* Drop spelling.patch, merged upstream.
* Update years of upstream copyright.
2016-05-06 - gregor herrmann <gregoa@debian.org>
libreadonly-perl (2.010-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* Import upstream version 2.010.
* Update years of packaging copyright.
* Update build dependencies.
* autopkgtest: enable test in subdirectories.
* Add a patch to fix a spelling mistake in the POD.
* Declare compliance with Debian Policy 3.9.8.
2015-05-29 - gregor herrmann <gregoa@debian.org>
libreadonly-perl (2.000-2) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* debian/control: update Module::Build dependency.
* Add debian/upstream/metadata
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.6.
* Mark package as autopkgtest-able.
2014-07-04 - Salvatore Bonaccorso <carnil@debian.org>
libreadonly-perl (2.000-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 2.000
2014-06-28 - Salvatore Bonaccorso <carnil@debian.org>
libreadonly-perl (1.610-1) unstable; urgency=medium
* Team upload.
* Add uversionmangle as upstream has changed versioning scheme
* Imported Upstream version 1.600 and 1.610
* Drop spelling.patch patch (applied upstream)
2014-06-26 - gregor herrmann <gregoa@debian.org>
libreadonly-perl (1.500.0-1) unstable; urgency=medium
* New upstream release.
* Strip trailing slash from metacpan URLs.
* Update years of upstream and packaging copyright.
* Drop Recommends: on libreadonly-xs-perl.
Readonly now uses perl's formerly private functions directly, so
Readonly::XS is no longer needed or useful.
For details see the "Internals" section in Readonly(3pm).
* Add a patch to fix a spelling mistake in the documentation.
2013-12-25 - gregor herrmann <gregoa@debian.org>
libreadonly-perl (1.04-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Update installation of example script.
* Don't install README anymore.
This is only a text version of the POD/manpage.
* Drop remove-pgp-signature.patch, not needed anymore.
* Update Upstream-Contact and copyright holders.
* Update Build-Depends and Recommends.
* Declare compliance with Debian Policy 3.9.5.
2012-06-11 - Alessandro Ghedini <ghedo@debian.org>
libreadonly-perl (1.03-4) unstable; urgency=low
* Team upload
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Alessandro Ghedini ]
* Recommends libreadonly-xs-perl as per documentation (Closes: #677105)
* Add remove-pgp-signature.patch (Closes: #677103)
* Bump Standards-Version to 3.9.3 (no changes needed)
* Update copyright to Copyright-Format 1.0
2011-06-11 - Fabrizio Regalli <fabreg@fabreg.it>
libreadonly-perl (1.03-3) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
[ Rene Mayorga ]
* Email change: Rene Mayorga -> rmayorga@debian.org
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ gregor herrmann ]
* Email change: gregor herrmann -> gregoa@debian.org
[ Fabrizio Regalli ]
* Bump to 3.9.2 Standard-Version.
* Switch to DEP5 license format.
* Add myself to Uploaders.
* Switch d/compat to 8.
* Build-Depends: switch to debhelper (>= 8).
* Bump to 3.0 quilt format.

See Also

Package Description
libreadonly-xs-perl_1.05-1+b6_i386.deb faster Readonly implementation
libreadosm-dev_1.1.0+dfsg-3_i386.deb simple library to parse OpenStreetMap files - headers
libreadosm-doc_1.1.0+dfsg-3_all.deb simple library to parse OpenStreetMap files - documentation
libreadosm1_1.1.0+dfsg-3_i386.deb simple library to parse OpenStreetMap files
librec-dev_1.7-3_i386.deb recutils development files
librec1_1.7-3_i386.deb library for accessing recfiles programmatically
librecad-data_2.1.3-1.2_all.deb Computer-aided design (CAD) system -- shared files
librecad_2.1.3-1.2_i386.deb Computer-aided design (CAD) system
librecode-dev_3.6-23_i386.deb Development package for librecode0
librecode0_3.6-23_i386.deb Shared library on which recode is based
librecommended-perl_0.003-1_all.deb Load recommended Perl modules on demand when available
libredberry-pipe-java_1.0.0~alpha0-2_all.deb implementation of concurrent pipelines
libredis-fast-perl_0.22+dfsg-1+b2_i386.deb Perl binding for Redis database
libredis-perl_1.9910-2_all.deb persistent key-value database with network interface (Perl client library)
libref-array-dev_0.6.1-2_i386.deb Development files for refcounted array for C
Advertisement
Advertisement