libquazip-headers_0.7.6-2_i386.deb


Advertisement

Description

libquazip-headers - C++ wrapper for ZIP/UNZIP (development header files)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libquazip-headers_0.7.6-2_i386.deb
Package name libquazip-headers
Package version 0.7.6
Package release 2
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://github.com/stachenov/quazip
License -
Maintainer Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Download size 35.55 KB
Installed size 161.00 KB
QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package that
can be used to access ZIP archives. It uses Trolltech's Qt toolkit.
QuaZIP allows you to access files inside ZIP archives using QIODevice API,
and that means that you can also use QTextStream, QDataStream or
whatever you would like to use on your zipped files.
QuaZIP provides complete abstraction of the ZIP/UNZIP API, for both reading
from and writing to ZIP archives.
This package contains the headers of the library.

Alternatives

Package Version Architecture Repository
libquazip-headers_0.7.6-2_amd64.deb 0.7.6 amd64 Debian Main
libquazip-headers - - -

Conflicts

Name Value
libquazip0-dev -
libquazip1-headers -

Replaces

Name Value
libquazip1-headers -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libquazip-headers_0.7.6-2_i386.deb
Source Package libquazip

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libquazip-headers deb package:
    # sudo apt-get install libquazip-headers

Files

Path
/usr/include/quazip/JlCompress.h
/usr/include/quazip/ioapi.h
/usr/include/quazip/minizip_crypt.h
/usr/include/quazip/quaadler32.h
/usr/include/quazip/quachecksum32.h
/usr/include/quazip/quacrc32.h
/usr/include/quazip/quagzipfile.h
/usr/include/quazip/quaziodevice.h
/usr/include/quazip/quazip.h
/usr/include/quazip/quazip_global.h
/usr/include/quazip/quazipdir.h
/usr/include/quazip/quazipfile.h
/usr/include/quazip/quazipfileinfo.h
/usr/include/quazip/quazipnewinfo.h
/usr/include/quazip/unzip.h
/usr/include/quazip/zip.h
/usr/share/doc/libquazip-headers/NEWS.gz
/usr/share/doc/libquazip-headers/changelog.Debian.gz
/usr/share/doc/libquazip-headers/changelog.gz
/usr/share/doc/libquazip-headers/copyright

Changelog

2018-12-20 - Andreas Tille <tille@debian.org>
libquazip (0.7.6-2) unstable; urgency=medium
* Versioned Breaks: libquazip-qt5-1 (<= 0.7-2)
Closes: #898957
* Standards-Version: 4.2.1
* Secure URI in copyright format
* Remove trailing whitespace in debian/rules
2018-07-01 - Andreas Tille <tille@debian.org>
libquazip (0.7.6-1) unstable; urgency=medium
* Project moved to Github
* New upstream version
Closes: #902786
* Build-Depends: doxygen, graphviz
* Some optional symbols were removed
* Switch to d-shlibs
2018-05-06 - Andreas Tille <tille@debian.org>
libquazip (0.7.3-7) unstable; urgency=medium
[ Alf Gaida ]
* Marked some symbols optional and described them as gcc8
Closes: #897794
[ Andreas Tille ]
* Point Vcs fields to salsa.debian.org
* Standards-Version: 4.1.4
2018-03-29 - Andreas Tille <tille@debian.org>
libquazip (0.7.3-6) unstable; urgency=medium
[ Steve Langasek ]
* symbols adjustments to support build with -O3
Closes: #893808
2018-03-04 - Andreas Tille <tille@debian.org>
libquazip (0.7.3-5) unstable; urgency=medium
* Enable arch build only
Closes: #891242
2018-02-23 - Andreas Tille <tille@debian.org>
libquazip (0.7.3-4) unstable; urgency=medium
* Do not specify cmake version explicitly in debhelper install (Thanks for
the patch to Adrian Bunk <bunk@debian.org>)
Closes: #891222
* debhelper 11
* Standards-Version: 4.1.3
* Fix installation of docs
2017-12-20 - Andreas Tille <tille@debian.org>
libquazip (0.7.3-3) unstable; urgency=medium
[ Alf Gaida <agaida@siduction.org> ]
* libquazip5-1 depends on libquazip5-headers instead of libquazip-headers
Closes: #884800
* Install cmake files
Closes: #778768
* debhelper with --fail-missing
2017-12-17 - Andreas Tille <tille@debian.org>
libquazip (0.7.3-2) unstable; urgency=medium
* Add symbols files
Closes: #758011
* Standards-Version: 4.1.2
2017-09-26 - Andreas Tille <tille@debian.org>
libquazip (0.7.3-1) unstable; urgency=medium
* New upstream version
* debhelper 10
* Fix dh_installchangelogs
Closes: #876886
* Remove unused lintian-override
* Standards-Version: 4.1.0 (no changes needed)
2016-06-18 - Stefan Ahlers <stef.ahlers@t-online.de>
libquazip (0.7.2-1) unstable; urgency=medium
[ Stefan Ahlers ]
* New upstream version
* debian/patches:
- remove cmake-fix.patch because its applied upstream
[ Andreas Tille ]
* cme fix dpkg-control
* hardening=+bindnow

See Also

Package Description
libquazip1_0.7.6-2_i386.deb C++ wrapper for ZIP/UNZIP (Qt4 build)
libquazip5-1_0.7.6-2_i386.deb C++ wrapper for ZIP/UNZIP (Qt5 build)
libquazip5-dev_0.7.6-2_i386.deb C++ wrapper for ZIP/UNZIP (development files, Qt5 build)
libquazip5-headers_0.7.6-2_i386.deb C++ wrapper for ZIP/UNZIP (development header files, Qt5 build)
libquicktime-dev_1.2.4-12+b2_i386.deb library for reading and writing Quicktime files (development)
libquicktime-doc_1.2.4-12_all.deb library for reading and writing Quicktime files (documentation)
libquicktime2_1.2.4-12+b2_i386.deb library for reading and writing Quicktime files
libquoin-clojure_0.1.2-3_all.deb Clojure utilities for writing template engines
libquorum-dev_3.0.1-2_i386.deb cluster engine Quorum library development
libquorum5_3.0.1-2_i386.deb cluster engine Quorum library
libquota-perl_1.7.2+dfsg-1+b5_i386.deb Perl interface to file system quotas
libquvi-0.9-0.9.3_0.9.3-1.3_i386.deb library for parsing video download links (runtime libraries)
libquvi-0.9-dev_0.9.3-1.3_i386.deb library for parsing video download links (development package)
libquvi-0.9-doc_0.9.3-1.3_all.deb library for parsing video download links (documentation package)
libquvi-scripts-0.9_0.9.20131130-1.1_all.deb library for parsing video download links (Lua scripts)
Advertisement
Advertisement