libquadmath0_8.3.0-6_i386.deb


Advertisement

Description

libquadmath0 - GCC Quad-Precision Math Library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libquadmath0_8.3.0-6_i386.deb
Package name libquadmath0
Package version 8.3.0
Package release 6
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://gcc.gnu.org/
License -
Maintainer Debian GCC Maintainers <debian-gcc@lists.debian.org>
Download size 199.89 KB
Installed size 612.00 KB
A library, which provides quad-precision mathematical functions on targets
supporting the __float128 datatype. The library is used to provide on such
targets the REAL(16) type in the GNU Fortran compiler.

Alternatives

Package Version Architecture Repository
libquadmath0_8.3.0-6_amd64.deb 8.3.0 amd64 Debian Main
libquadmath0 - - -

Requires

Name Value
gcc-8-base = 8.3.0-6
libc6 >= 2.23

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libquadmath0_8.3.0-6_i386.deb
Source Package gcc-8

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libquadmath0 deb package:
    # sudo apt-get install libquadmath0

Files

Path
/usr/lib/i386-linux-gnu/libquadmath.so.0
/usr/lib/i386-linux-gnu/libquadmath.so.0.0.0
/usr/share/doc/libquadmath0

Changelog

2019-04-06 - Matthias Klose <doko@debian.org>
gcc-8 (8.3.0-6) unstable; urgency=medium
* Update to SVN 20190406 (r270182) from the gcc-8-branch.
- Fix PR middle-end/89934, PR lto/89896.
* Fix PR fortran/89981, taken from the trunk.
2019-04-03 - Matthias Klose <doko@debian.org>
gcc-8 (8.3.0-5) unstable; urgency=medium
* Update to SVN 20190403 (r270110) from the gcc-8-branch.
- Fix PR target/89902 (x86), PR target/89903 (x86),
PR rtl-optimization/89862, PR target/89848 (x86), PR web/87829,
PR target/89827 (x86), PR fortran/83515, PR fortran/85797,
PR fortran/78865.
* Revert the fix for PC c++/88419, causing PR c++/89906. Closes: #926234.
* Mark gcc-8-source as M-A: foreign.
2019-03-26 - Matthias Klose <doko@debian.org>
gcc-8 (8.3.0-4) unstable; urgency=medium
* Update to SVN 20190326 (r269936) from the gcc-8-branch.
- Fix PR tree-optimization/89546, PR target/89523 (x86), PR fortran/84394,
PR fortran/66089, PR fortran/66695, PR fortran/77746, PR fortran/79485,
PR libgcc/60790, PR target/89775 (S390), PR debug/88389,
PR rtl-optimization/89753, PR middle-end/88273, PR fortran/71861,
PR fortran/68009.
* gcc-8-base: Breaks gnat-6 (<< 6.4) to ease upgrades. Closes: #924911.
* Fix cross building gdc (Helmut Grohne). Closes: #925040.
* Fix package descriptions for cross packages.
* Fix PR jit/87808: Don't rely on the gcc driver. Let libgccjit0
depend on binutils and libgcc-dev. Closes: #911668.
* Fix stripping the gcc-hppa64 package.
2019-03-16 - Matthias Klose <doko@debian.org>
gcc-8 (8.3.0-3) unstable; urgency=medium
* Update to SVN 20190316 (r269720) from the gcc-8-branch.
- Fix PR tree-optimization/89505, PR target/89517 (AArch64),
PR bootstrap/89539, PR debug/88878, PR debug/89514,
PR tree-optimization/89536, PR target/88100 (PPC), PR target/89397 (x86),
PR target/89361 (S390), PR c++/89212, PR fortran/89077,
PR fortran/77583, PR fortran/89174, PR fortran/87689, PR fortran/84387,
PR fortran/89516, PR fortran/89492, PR fortran/89266, PR fortran/88326,
PR libfortran/89020, PR target/88530 (AArch64), PR target/88530 (AArch64),
PR ipa/88235, PR c++/88820, PR c++/88869, PR c++/88419, PR c++/88690,
PR c++/87921, PR c++/89381, PR c++/89576, PR c++/89422, PR c++/87513,
PR c++/88183, PR c++/89585, PR fortran/71544, PR fortran/87734,
PR fortran/71203, PR fortran/72714, PR middle-end/89572, PR target/85860,
PR middle-end/89677, PR middle-end/89497, PR tree-optimization/89296,
PR tree-optimization/89664, PR rtl-optimization/89588, PR lto/88147,
PR target/86952 (x86), PR lto/88147, PR fortran/87673, PR c++/89383,
PR lto/87525, PR other/89712, PR testsuite/85368.
* Backport libgo patches for the Hurd from the trunk (Svante Signell).
* Add some more breaks to libstdc++6. Closes: #866354.
2019-02-26 - Matthias Klose <doko@debian.org>
gcc-8 (8.3.0-2) unstable; urgency=medium
* Fix the nvptx build.
2019-02-25 - Matthias Klose <doko@debian.org>
gcc-8 (8.3.0-1) unstable; urgency=medium
* GCC 8.3.0 release.
* Update newlib to newlib-3.1.0.20181231.
* Refresh patches.
* Fix PR middle-end/89412, patch taken from the trunk. Closes: #922683.

See Also

Package Description
libquadrule-dev_0~20121001-2+b1_i386.deb Development files for quadrule
libquadrule1_0~20121001-2+b1_i386.deb Quadrature rules and numerical integration routines
libquantlib0-dev_1.15-1_i386.deb Quantitative Finance Library -- development package
libquantlib0v5_1.15-1_i386.deb Quantitative Finance Library -- library package
libquantum-dev_1.1.1-5_i386.deb library for the simulation of a quantum computer (development files)
libquantum-entanglement-perl_0.32-3_all.deb Quantum Mechanic entanglement of variables in perl
libquantum-superpositions-perl_2.03-1_all.deb Quantum Mechanic-like superpositions for Perl
libquantum8_1.1.1-5_i386.deb library for the simulation of a quantum computer
libquartz-java_1.8.6-6_all.deb open source job scheduling system
libquartz2-java_2.3.0-2_all.deb open source job scheduling system
libquazip-dev_0.7.6-2_i386.deb C++ wrapper for ZIP/UNZIP (development files, Qt4 build)
libquazip-doc_0.7.6-2_all.deb C++ wrapper for ZIP/UNZIP (documentation)
libquazip-headers_0.7.6-2_i386.deb C++ wrapper for ZIP/UNZIP (development header files)
libquazip1_0.7.6-2_i386.deb C++ wrapper for ZIP/UNZIP (Qt4 build)
libquazip5-1_0.7.6-2_i386.deb C++ wrapper for ZIP/UNZIP (Qt5 build)
Advertisement
Advertisement