libqtpropertybrowser4_4.1.2-3_i386.deb


Advertisement

Description

libqtpropertybrowser4 - Qt Property Browser Library - runtime

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libqtpropertybrowser4_4.1.2-3_i386.deb
Package name libqtpropertybrowser4
Package version 4.1.2
Package release 3
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://camitk.imag.fr/
License -
Maintainer Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Download size 262.96 KB
Installed size 1.19 MB
A framework providing a set of graphical editors for
Qt properties similar to the one used in Qt Designer.
This package contains the shared libraries needed to run applications
linked against libqtpropertybrowser4.

Alternatives

Package Version Architecture Repository
libqtpropertybrowser4_4.1.2-3_amd64.deb 4.1.2 amd64 Debian Main
libqtpropertybrowser4 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libqt5core5a >= 5.11.0~rc1
libqt5gui5 >= 5.0.2
libqt5widgets5 >= 5.11.0~rc1
libstdc++6 >= 4.1.1

Replaces

Name Value
libqtpropertybrowser3 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libqtpropertybrowser4_4.1.2-3_i386.deb
Source Package camitk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqtpropertybrowser4 deb package:
    # sudo apt-get install libqtpropertybrowser4

Files

Path
/usr/lib/libqtpropertybrowser.so.4
/usr/lib/libqtpropertybrowser.so.4.1.2
/usr/share/doc/libqtpropertybrowser4/changelog.Debian.gz
/usr/share/doc/libqtpropertybrowser4/copyright

Changelog

2019-04-05 - Andreas Tille <tille@debian.org>
camitk (4.1.2-3) unstable; urgency=medium
[ Andreas Beckmann ]
* libcamitk-dev: Add Breaks against several vtk6 packages to force switching
from libvtk6-dev to libvtk7-dev.  (Closes: #926430)
[ Andreas Tille ]
* Standards-Version: 4.3.0
2018-10-23 - Emmanuel Promayon <Emmanuel.Promayon@univ-grenoble-alpes.fr>
camitk (4.1.2-2) unstable; urgency=medium
* VTK7 compatibility. Closes: #909120
* Avoid double delete (patch from Bernhard √úbelacker)
* update d/control: multiarch, debphelper and compat
2018-07-18 - Emmanuel Promayon <Emmanuel.Promayon@univ-grenoble-alpes.fr>
camitk (4.1.2-1) unstable; urgency=medium
* New upstream version 4.1.2
* control, rules, and autopkgtest updated for new release
* watch checks tag on upstream gilab
* fixed mispelling detected by lintian
* fixed config test and lib core dependencies
2017-01-20 - Emmanuel Promayon <Emmanuel.Promayon@univ-grenoble-alpes.fr>
camitk (4.0.4-2) unstable; urgency=medium
* Updated email address
* wizard tests gained verbosity
* Start Xvfb server first + update test dependencies
2016-12-02 - Emmanuel Promayon <Emmanuel.Promayon@imag.fr>
camitk (4.0.4-1) unstable; urgency=medium
[ Emmanuel Promayon ]
* New upstream version 4.0.4
* libdevel needs most of the build depends (needed for ci)
[ Andreas Tille ]
* debhelper 10 (drop --parallel from d/rules)
* d/watch: version=4
* hardening=+all
2016-10-08 - Emmanuel Promayon <Emmanuel.Promayon@imag.fr>
camitk (4.0.3-1) unstable; urgency=medium
* Imported Upstream version 4.0.3
* Removed SONAME number in the dev package name
* Create a new camitk-config package for the camitk-config binary, and have
set appropriate Breaks+Replaces.  Closes: #836990
* Improved autopkgtest test scripts
* Fix debug-file-with-no-debug-symbols (CXX flags were overridden)
2016-04-30 - Mattia Rizzolo <mattia@debian.org>
camitk (4.0.0~beta-2) unstable; urgency=medium
* Team upload.
* Add missing Breaks/Replaces to the -dev packages.  Closes: #823025
* Re-enable parallel build.  Now that slow architectures are not a
problem anymore this should be safe to do.  Closes: #747421
2016-04-27 - Emmanuel Promayon <Emmanuel.Promayon@imag.fr>
camitk (4.0.0~beta-1) unstable; urgency=low
[ Emmanuel Promayon ]
* New upstream beta release. Thanks to Gianfranco Costamagna
for the help.
* New upstream beta release now depends on Qt5
Closes: #816805
* New upstream beta check for SOURCE_DATE_EPOCH
Closes: #794740
* Run test only for architecture Any. Thanks to Andreas Tille
for the help. Closes: #817163
* Removed Nicolas Saubat from maintainer list. Many thanks
to Nicolas for his work on CamiTK during the last 4 years.
[ Andreas Tille ]
* Moved packaging from SVN to Git
[ Gianfranco Costamagna ]
* New upstream beta release (Closes: #798167)
* Bump soname.
* Fix packaging by following new libraries and removed libraries
in rules file.
* Remove all patches, upstream.
* Switch to vtk6, itk4 and qt5
* Bump std-version to 3.9.8
* Update copyright file.
[ Mattia Rizzolo ]
* Remove trailing whitespaces from all over debian/.
* debian/rules:
+ Remove useless override in dh_builddeb: xz is the default now.
+ Semplify dpkg-parsechangelog invocation using -S instead of sed(1).
2015-06-15 - Emmanuel Promayon <Emmanuel.Promayon@imag.fr>
camitk (3.4.0-2) unstable; urgency=low
* Fix cmake missing path to ITKConfig (patch force-path-to-itkconfig)
Closes: #787753
* Increase test timeout for slower arch
* fix timestamps_in_documentation_generated_by_doxygen
(improve building reproducibility, patch remove-doxygen-timestamp)
2014-10-28 - Emmanuel Promayon <Emmanuel.Promayon@imag.fr>
camitk (3.4.0-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
libqtshadowsocks-dev_2.1.0-2+b1_i386.deb Development files of libQtShadowsocks
libqtshadowsocks2_2.1.0-2+b1_i386.deb Lightweight and ultra-fast shadowsocks library written in C++/Qt
libqtspell-qt5-0_0.8.5-1_i386.deb Spell checking for Qt5 text widgets
libqtspell-qt5-dev_0.8.5-1_i386.deb Development files for libqtspell-qt5
libqtspell-qt5-html_0.8.5-1_all.deb Spell checking for Qt5 text widgets
libqtwebkit-dev_2.3.4.dfsg-10_i386.deb Web content engine library for Qt - development files
libqtwebkit-qmlwebkitplugin_2.3.4.dfsg-10_i386.deb Qt WebKit QML plugin
libqtwebkit4_2.3.4.dfsg-10_i386.deb Web content engine library for Qt
libquadmath0-amd64-cross_8.3.0-2cross1_all.deb GCC Quad-Precision Math Library
libquadmath0-i386-cross_8.3.0-2cross1_all.deb GCC Quad-Precision Math Library
libquadmath0-ppc64el-cross_8.3.0-2cross1_all.deb GCC Quad-Precision Math Library
libquadmath0-x32-cross_8.3.0-2cross2_all.deb GCC Quad-Precision Math Library
libquadmath0_8.3.0-6_i386.deb GCC Quad-Precision Math Library
libquadrule-dev_0~20121001-2+b1_i386.deb Development files for quadrule
libquadrule1_0~20121001-2+b1_i386.deb Quadrature rules and numerical integration routines
Advertisement
Advertisement