libqapt3-runtime_3.0.4-1_i386.deb


Advertisement

Description

libqapt3-runtime - Runtime components for the QApt library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libqapt3-runtime_3.0.4-1_i386.deb
Package name libqapt3-runtime
Package version 3.0.4
Package release 1
Package architecture i386
Package type deb
Category kde uitoolkit::qt
Homepage https://cgit.kde.org/libqapt.git/
License -
Maintainer Debian/Kubuntu KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Download size 86.77 KB
Installed size 264.00 KB
LibQApt is a Qt wrapper around the libapt-pkg library as well as an APT
implementation using libapt-pkg. The aim is to provide a sane API for
package management to ease the development of package managers written in Qt
and C++
This package contains the runtime components necessary for applications using
the QApt library to run.

Alternatives

Package Version Architecture Repository
libqapt3-runtime_3.0.4-1_amd64.deb 3.0.4 amd64 Debian Main
libqapt3-runtime - - -

Requires

Name Value
libapt-pkg5.0 >= 1.1~exp9
libc6 >= 2.4
libgcc1 >= 1:4.2
libpolkit-qt5-1-1 >= 0.112.0
libqapt3 >= 3.0.0
libqt5core5a >= 5.10.0
libqt5dbus5 >= 5.2.0
libstdc++6 >= 5.2
policykit-1-gnome -
polkit-kde-agent-1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libqapt3-runtime_3.0.4-1_i386.deb
Source Package libqapt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqapt3-runtime deb package:
    # sudo apt-get install libqapt3-runtime

Files

Path
/etc/dbus-1/system.d/org.kubuntu.qaptworker3.conf
/usr/bin/qaptworker3
/usr/share/dbus-1/system-services/org.kubuntu.qaptworker3.service
/usr/share/doc/libqapt3-runtime/changelog.Debian.gz
/usr/share/doc/libqapt3-runtime/changelog.gz
/usr/share/doc/libqapt3-runtime/copyright
/usr/share/lintian/overrides/libqapt3-runtime
/usr/share/polkit-1/actions/org.kubuntu.qaptworker3.policy

Changelog

2018-04-27 - Pino Toscano <pino@debian.org>
libqapt (3.0.4-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Switch Vcs-* fields to salsa.debian.org.
* Bump the debhelper compatibility to 11:
- bump the debhelper build dependency to 11~
- bump compat to 11
- remove --parallel for dh, as now done by default
* Bump Standards-Version to 4.1.4, no changes required.
* Switch from dh_install to dh_missing for --fail-missing.
* Update install files.
* Use https for Format in copyright.
2017-12-23 - Pino Toscano <pino@debian.org>
libqapt (3.0.3-2) unstable; urgency=medium
* Team upload.
* Bump Standards-Version to 4.1.2, no changes required.
* Bump Priority of transitional gstreamer0.10-qapt to optional.
* Switch libqapt3 to section libs.
* Update symbols file.
* Switch the transitional plasma-framework-dev build dependency to
libkf5plasma-dev.
* Use also the dh pkgkde_symbolshelper addon to handle symbols file with
substitutions.
* Update lintian overrides.
* Use https in the watch file.
2017-06-18 - Pino Toscano <pino@debian.org>
libqapt (3.0.3-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Change the priority of the transitional gstreamer0.10-qapt to extra.
* Mark libqapt3 and libqapt-dev as "Multi-Arch: same".
* Remove debian/TODO, obsolete now.
* Fix path to qapt-gst-helper passed to update-alternatives in postinst
and prerm of gstreamer-qapt.
* Replace the deprecated kio-dev build dependency with libkf5kio-dev.
* Remove unused meta/upstream_scm.json file.
* Remove qapt-dbg in favour of the -dbgsym packages.
* Update the patches:
- upstream_include-random-for-std-default_random_engine.patch: drop,
backported from upstream
* Switch Homepage to the upstream VCS, since projects.kde.org is dead.
2016-05-15 - Pino Toscano <pino@debian.org>
libqapt (3.0.2-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update Vcs-* fields.
* Small update to copyright.
* Update symbols file.
* Backport upstream commit a58eab74ee9881d10e0f24a3ed216ed71ba03bf5 to fix
build; patch upstream_include-random-for-std-default_random_engine.patch.
(Closes: #822497)
* Link in as-needed mode.
* Bump Standards-Version to 3.9.8, no changes required.
2015-09-26 - Maximiliano Curia <maxy@debian.org>
libqapt (3.0.1-1) unstable; urgency=medium
* New upstream release (3.0.1).
* Drop upstream applied patches.
* Update symbols files.
2015-09-14 - Maximiliano Curia <maxy@debian.org>
libqapt (3.0.0-6) unstable; urgency=medium
* Add support for APT 1.1. (Closes: #798705) Thanks to Julian Andres Klode
2015-09-01 - Maximiliano Curia <maxy@debian.org>
libqapt (3.0.0-5) unstable; urgency=medium
* Update symbols file.
2015-07-23 - Scott Kitterman <scott@kitterman.com>
libqapt (3.0.0-4) unstable; urgency=medium
* Team upload.
* Add gstreamer-qapt Breaks/Replaces for gstreamer1.0-qapt (Closes: #791833)
again, Thanks to Andreas Beckman for the corrected solution
2015-07-20 - Maximiliano Curia <maxy@debian.org>
libqapt (3.0.0-3) unstable; urgency=medium
* Update copyright information.
* Add Breaks/Replaces for gstreamer0.10-qapt. (Closes: #791833) Thanks to
Andreas Beckman.
2015-06-30 - Maximiliano Curia <maxy@debian.org>
libqapt (3.0.0-2) unstable; urgency=medium
[ Debian/Kubuntu KDE Extras Team ]
* Prepare release to unstable.
[ Maximiliano Curia ]
* New patch: add_kf5iconthemes

See Also

Package Description
libqapt3_3.0.4-1_i386.deb QApt library package
libqb-dev_1.0.5-1_i386.deb high performance client server features library (devel files)
libqb-doc_1.0.5-1_all.deb high performance client server features library (API docs)
libqb0_1.0.5-1_i386.deb high performance client server features library
libqbscore1.12_1.12.2+dfsg-2_i386.deb Qbs core library
libqbsqtprofilesetup1.12_1.12.2+dfsg-2_i386.deb Qbs profile setup library
libqca-qt5-2-dev_2.1.3-2_i386.deb development files for the Qt Cryptographic Architecture
libqca-qt5-2-plugins_2.1.3-2_i386.deb QCA plugins for libqca2
libqca-qt5-2_2.1.3-2_i386.deb libraries for the Qt Cryptographic Architecture
libqca2-dev_2.1.3-2_i386.deb development files for the Qt Cryptographic Architecture
libqca2-doc_2.1.3-2_all.deb API documentation for the Qt Cryptographic Architecture
libqca2-plugins_2.1.3-2_i386.deb QCA plugins for libqca2
libqca2_2.1.3-2_i386.deb libraries for the Qt Cryptographic Architecture
libqcheck-ocaml-dev_0.8-1_i386.deb QuickCheck inspired property-based testing for OCaml (Development package)
libqcheck-ocaml-doc_0.8-1_all.deb Documentation for ocaml-qcheck
Advertisement
Advertisement