libproxy1-plugin-networkmanager_0.4.15-5_i386.deb


Advertisement

Description

libproxy1-plugin-networkmanager - automatic proxy configuration management library (Network Manager plugin)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libproxy1-plugin-networkmanager_0.4.15-5_i386.deb
Package name libproxy1-plugin-networkmanager
Package version 0.4.15
Package release 5
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://libproxy.github.io/libproxy/
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 13.78 KB
Installed size 37.00 KB
libproxy is a lightweight library which makes it easy to develop
applications proxy-aware with a simple and stable API.
This package contains the plugin to allow libproxy to read information from
Network Manager.

Alternatives

Package Version Architecture Repository
libproxy1-plugin-networkmanager_0.4.15-5_amd64.deb 0.4.15 amd64 Debian Main
libproxy1-plugin-networkmanager - - -

Requires

Name Value
libc6 >= 2.4
libdbus-1-3 >= 1.9.14
libproxy1v5 = 0.4.15-5
libstdc++6 >= 5

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libproxy1-plugin-networkmanager_0.4.15-5_i386.deb
Source Package libproxy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libproxy1-plugin-networkmanager deb package:
    # sudo apt-get install libproxy1-plugin-networkmanager

Files

Path
/usr/lib/i386-linux-gnu/libproxy/0.4.15/modules/network_networkmanager.so
/usr/share/doc/libproxy1-plugin-networkmanager/changelog.Debian.gz
/usr/share/doc/libproxy1-plugin-networkmanager/changelog.gz
/usr/share/doc/libproxy1-plugin-networkmanager/copyright

Changelog

2018-12-28 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.15-5) unstable; urgency=medium
* Add -Wl,-O1 to our LDFLAGS
* Bump Standards-Version to 4.3.0
2018-12-24 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.15-4) unstable; urgency=medium
* Build the mozjs plugin against mozjs 60 and limit the architectures where
the package is built as mozjs 60 FTBFS on several architectures (Closes:
#912940)
2018-10-06 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.15-3) unstable; urgency=medium
* Reintroduce libproxy1-plugin-mozjs, the module now builds with mozjs 52
* debian/control.in: Drop X-Python(3)-Version to please lintian
* debian/control.in: Bump Standards-Version to 4.2.1 (no further changes)
* debian/rules: Use DEB_VERSION_UPSTREAM instead of SHLIBVER for the helpers
2018-09-19 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.15-2) unstable; urgency=medium
[ Helmut Grohne ]
* Demote python Build-Depends to Build-Depends-Indep (Closes: #909211)
2018-03-28 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.15-1) unstable; urgency=medium
* New upstream release
* Update Vcs fields for migration to https://salsa.debian.org/
* Drop libproxy1-plugin-mozjs since it depends on an outdated version
of mozjs. Use libproxy1-plugin-webkit instead. (Closes: #863783)
* Drop fix-clean-reload-cache.patch: Applied in new release
2017-12-18 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.14-4) unstable; urgency=medium
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
* Update Maintainer
* Bump debhelper compat to 11
* Bump Standards-Version to 4.1.2
2017-05-27 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.14-3) unstable; urgency=medium
[ Alexander Volkov ]
* Don't build depend on libkf5config-bin on stage1 (Closes: #847365)
2017-02-08 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.14-2) unstable; urgency=medium
* debian/patches/fix-clean-reload-cache.patch: Make sure that the PAC/WPAD
cache is cleanup when network topology changes and prevent a segfault in
the process, patches merged upstream.
2017-01-22 - Michael Biebl <biebl@debian.org>
libproxy (0.4.14-1) unstable; urgency=medium
* New upstream release.
* Switch Build-Depends from network-manager-dev to the newer libnm-dev.
While the code has a fallback for the older header files, the new ones
provided by libnm are preferred by upstream.
* Use DEB_LDFLAGS_MAINT_APPEND to pass additional flags to the linker.
* Bump SHVER to 0.4.14.
2016-11-20 - Andrey Rahmatullin <wrar@debian.org>
libproxy (0.4.13-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS (Closes: #844956).

See Also

Package Description
libproxy1-plugin-webkit_0.4.15-5_i386.deb automatic proxy configuration management library (Webkit plugin)
libproxy1v5_0.4.15-5_i386.deb automatic proxy configuration management library (shared)
libproxychains-dev_3.1-8.1_i386.deb proxy chains -- shared library (development)
libproxychains3_3.1-8.1_i386.deb proxy chains -- shared library (runtime)
libproxychains4_4.13-4_i386.deb runtime shared library for proxychains-ng
libprpc-perl_0.1005-22_all.deb Perl extensions for writing pRPC servers and clients
libpseudo_1.9.0+git20180920-1_i386.deb advanced tool for simulating superuser privileges
libpsi3-dev_3.4.0-6+b3_i386.deb Quantum Chemical Program Suite (Development Libraries)
libpsl-dev_0.20.2-2_i386.deb Library for Public Suffix List (development headers)
libpsl5_0.20.2-2_i386.deb Library for Public Suffix List (shared libraries)
libpsm-infinipath1-dev_3.3+20.604758e7-6_i386.deb Development files for libpsm-infinipath1
libpsm-infinipath1_3.3+20.604758e7-6_i386.deb PSM Messaging library for Intel Truescale adapters
libpsocksxx-dev_1.1.1-1_i386.deb psocksxx is a C++ wrapper for POSIX sockets (development files)
libpsocksxx-doc_1.1.1-1_all.deb psocksxx is a C++ wrapper for POSIX sockets (documentation)
libpsocksxx0_1.1.1-1_i386.deb psocksxx is a C++ wrapper for POSIX sockets
Advertisement
Advertisement