libpostgresql-jdbc-java_42.2.5-2_all.deb


Advertisement

Description

libpostgresql-jdbc-java - Java database (JDBC) driver for PostgreSQL

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpostgresql-jdbc-java_42.2.5-2_all.deb
Package name libpostgresql-jdbc-java
Package version 42.2.5
Package release 2
Package architecture all
Package type deb
Category java
Homepage https://jdbc.postgresql.org/
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 759.84 KB
Installed size 850.00 KB
PostgreSQL JDBC Driver allows Java programs to connect to a PostgreSQL
database (8.4 or later) using standard, database independent Java code.
It is an open source JDBC driver written in Pure Java (Type 4), and
communicates in the PostgreSQL native network protocol.

Alternatives

Package Version Architecture Repository
libpostgresql-jdbc-java_42.2.5-2_all.deb 42.2.5 all Debian Main
libpostgresql-jdbc-java - - -

Provides

Name Value
libpg-java -
libpgjava -

Conflicts

Name Value
libpg-java <= 9.1-901-1
libpgjava <= 7.4.7-3

Replaces

Name Value
libpg-java <= 9.1-901-1
libpgjava -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpostgresql-jdbc-java_42.2.5-2_all.deb
Source Package libpgjava

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpostgresql-jdbc-java deb package:
    # sudo apt-get install libpostgresql-jdbc-java

Files

Path
/usr/share/doc/libpostgresql-jdbc-java/README.md.gz
/usr/share/doc/libpostgresql-jdbc-java/changelog.Debian.gz
/usr/share/doc/libpostgresql-jdbc-java/changelog.gz
/usr/share/doc/libpostgresql-jdbc-java/copyright
/usr/share/java/postgresql-42.2.5.jar
/usr/share/java/postgresql-jdbc3.jar
/usr/share/java/postgresql-jdbc4.jar
/usr/share/java/postgresql.jar
/usr/share/maven-repo/org/postgresql/pgjdbc-aggregate/42.2.5/pgjdbc-aggregate-42.2.5.pom
/usr/share/maven-repo/org/postgresql/pgjdbc-aggregate/debian/pgjdbc-aggregate-debian.pom
/usr/share/maven-repo/org/postgresql/postgresql/42.2.5/postgresql-42.2.5.jar
/usr/share/maven-repo/org/postgresql/postgresql/42.2.5/postgresql-42.2.5.pom
/usr/share/maven-repo/org/postgresql/postgresql/debian/postgresql-debian.jar
/usr/share/maven-repo/org/postgresql/postgresql/debian/postgresql-debian.pom
/usr/share/maven-repo/postgresql/postgresql/debian/postgresql-debian.pom

Changelog

2019-02-07 - Christoph Berg <myon@debian.org>
libpgjava (42.2.5-2) unstable; urgency=medium
* Update PostgreSQL Maintainers address.
2018-08-27 - Christoph Berg <myon@debian.org>
libpgjava (42.2.5-1) unstable; urgency=medium
* New upstream security release: added server hostname verification for
non-default SSL factories in `sslmode=verify-full` (CVE-2018-10936)
https://github.com/pgjdbc/pgjdbc/commit/cdeeaca47dc3bc6f727c79a582c9e4123099526e
2018-08-27 - Christoph Berg <christoph.berg@credativ.de>
libpgjava (42.2.4-2) unstable; urgency=medium
* Ignore javadoc warnings, they are for unused files anyway. (Closes: #906377)
2018-07-18 - Christoph Berg <christoph.berg@credativ.de>
libpgjava (42.2.4-1) unstable; urgency=medium
* New upstream version.
* debian/libpostgresql-jdbc-java.poms: Remove ubenchmark, gone from source.
* debian/watch: Fetch upstream tarball from github.
2018-06-06 - Christoph Berg <christoph.berg@credativ.de>
libpgjava (42.2.2-4) unstable; urgency=medium
* pgjdbc/pom.xml: "provided" made the shade plugin also remove the bundled
scram dependency. Revert that change, and declare the dependency to be
"optional" instead. That way, we bundle scram, and do not require
reverse-dependencies to install libscram-java. Again thanks Emmanuel Bourg!
2018-06-05 - Christoph Berg <christoph.berg@credativ.de>
libpgjava (42.2.2-3) unstable; urgency=medium
* pgjdbc/pom.xml: Manually patch scram dependency scope to be "provided"
instead of relying on maven.rules. (Closes: #900615, induced by #900763,
thanks Emmanuel Bourg.)
2018-05-29 - Christoph Berg <myon@debian.org>
libpgjava (42.2.2-2) unstable; urgency=medium
* debian/maven.rules: Set scram scope to "provided" to properly remove the
runtime dependency on libscram-java. Thanks Kai-Chung Yan!
* Mark as Multi-Arch: foreign.
* libpostgresql-jdbc-java embeds classes from libscram-java. Note the
version used in Built-Using.
2018-04-30 - Christoph Berg <myon@debian.org>
libpgjava (42.2.2-1) unstable; urgency=medium
* New upstream version.
+ Fixes test problen in pgpool2: WARNING: An illegal reflective access
operation has occurred (Closes: #894327)
* Add myself and pkg-postgresql to Uploaders.
* Refresh debian/patches/01-missing-pom-configuration.patch.
* Add B-D libmaven-shade-plugin-java and libscram-java.
* libjdbc-postgresql-java: remove ${maven:Depends}, it would resolve to
libscram-java (>> $ver) which is bundled in postgresql.jar anyway.
* debian/maven.properties: Switch to source 8 to enable lambda expressions.
* debian/tests/: Test scram-sha-256 authentication using sqlline.
* Update Vcs URLs and Standards-Version.
2017-01-09 - Emmanuel Bourg <ebourg@apache.org>
libpgjava (9.4.1212-1) unstable; urgency=medium
* Team upload.
* New upstream release (Closes: #813365)
- Refreshed the patches
- Build with Maven instead of Ant
* No longer build the JDBC 3 jar, default to JDBC 4 (Closes: #820943, #820942)
* Updated the package description (Closes: #783456)
* Removed the dummy libpg-java package
* Removed the suggested dependency on postgresql
* Standards-Version updated to 3.9.8
* Switch to debhelper level 10
* Use secure Vcs-* URLs
* Converted debian/copyright to the Copyright Format 1.0
* Rewrote debian/watch to fetch the new releases directly from Git
2013-05-12 - Andrew Ross <ubuntu@rossfamily.co.uk>
libpgjava (9.2-1002-1) unstable; urgency=low
* New upstream release.
* Bump standards version to 3.9.4 (no changes).

See Also

Package Description
libpostgresql-ocaml-dev_2.0.5-3+b1_i386.deb OCaml bindings to PostgreSQL's libpq
libpostgresql-ocaml_2.0.5-3+b1_i386.deb OCaml bindings to PostgreSQL's libpq (runtime)
libpostproc-dev_4.1.4-1~deb10u1_i386.deb FFmpeg library for post processing - development files
libpostproc55_4.1.4-1~deb10u1_i386.deb FFmpeg library for post processing - runtime files
libpostscript-file-perl_2.23+dfsg-1_all.deb module for creating Adobe PostScript files
libpostscript-perl_0.06-3_all.deb Perl module to generate PostScript code
libpostscript-simple-perl_0.09-1_all.deb Perl library for generating postscript files
libpostscriptbarcode_20140312-2_all.deb Barcode Writer in Pure PostScript
libpotemkin-clojure_0.4.3-2_all.deb collection of facades and workarounds for Clojure
libpotrace-dev_1.15-1_i386.deb development files for potrace library
libpotrace0_1.15-1_i386.deb library for tracing bitmaps
libpowercap-dev_0.1.1-1_i386.deb Development files for libpowercap
libpowercap0_0.1.1-1_i386.deb Shared library for accessing the powercap Linux kernel feature
libpowerdevilcore2_5.14.5-1_i386.deb Global power saver settings ui library
libpowerdevilui5_5.14.5-1_i386.deb Global power saver settings ui library
Advertisement
Advertisement