libpolkit-gobject-1-0_0.105-25_i386.deb


Advertisement

Description

libpolkit-gobject-1-0 - PolicyKit Authorization API

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpolkit-gobject-1-0_0.105-25_i386.deb
Package name libpolkit-gobject-1-0
Package version 0.105
Package release 25
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.freedesktop.org/wiki/Software/polkit/
License -
Maintainer Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>
Download size 46.62 KB
Installed size 162.00 KB
PolicyKit is a toolkit for defining and handling the policy that
allows unprivileged processes to speak to privileged processes.
This package contains a library for accessing PolicyKit.

Alternatives

Package Version Architecture Repository
libpolkit-gobject-1-0_0.105-25_amd64.deb 0.105 amd64 Debian Main
libpolkit-gobject-1-0 - - -

Requires

Name Value
libc6 >= 2.7
libglib2.0-0 >= 2.37.3
libsystemd0 >= 213

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpolkit-gobject-1-0_0.105-25_i386.deb
Source Package policykit-1

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpolkit-gobject-1-0 deb package:
    # sudo apt-get install libpolkit-gobject-1-0

Files

Path
/usr/lib/i386-linux-gnu/libpolkit-gobject-1.so.0
/usr/lib/i386-linux-gnu/libpolkit-gobject-1.so.0.0.0
/usr/share/doc/libpolkit-gobject-1-0/changelog.Debian.gz
/usr/share/doc/libpolkit-gobject-1-0/copyright

Changelog

2019-01-15 - Jeremy Bicha <jbicha@debian.org>
policykit-1 (0.105-25) unstable; urgency=medium
* Team upload
* Add tests-add-tests-for-high-uids.patch
- Patch from upstream modified by Ubuntu to test high UID fix
* Compare PolkitUnixProcess uids for temporary authorizations.
- Fix temporary auth hijacking via PID reuse and non-atomic fork
(CVE-2019-6133) (Closes: #918985)
2019-01-15 - Martin Pitt <mpitt@debian.org>
policykit-1 (0.105-24) unstable; urgency=medium
* Allow uid of -1 for a PolkitUnixProcess.
Revert an overzealous change from the previous security fix that caused
a critical to be logged when trying to set the uid property to -1 (the
default value).
2018-12-07 - Michael Biebl <biebl@debian.org>
policykit-1 (0.105-23) unstable; urgency=high
* Allow negative uids/gids in PolkitUnixUser and Group objects.
Fixes a vulnerability in PolicyKit that allows a user with a uid greater
than INT_MAX to successfully execute arbitrary polkit actions.
(CVE-2018-19788, Closes: #915332)
2018-11-27 - Michael Biebl <biebl@debian.org>
policykit-1 (0.105-22) unstable; urgency=medium
* Move D-Bus policy file to /usr/share/dbus-1/system.d/
To better support stateless systems with an empty /etc, the old location
in /etc/dbus-1/system.d/ should only be used for local admin changes.
Package provided D-Bus policy files are supposed to be installed in
/usr/share/dbus-1/system.d/.
This is supported since dbus 1.9.18.
* Remove obsolete conffile
/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf on upgrades
* Bump Standards-Version to 4.2.1
* Remove Breaks for versions older than oldstable
* Stop masking polkit.service during the upgrade process.
This is no longer necessary with the D-Bus policy file being installed
in /usr/share/dbus-1/system.d/. (Closes: #902474)
* Use dh_installsystemd to restart polkit.service after an upgrade.
This replaces a good deal of hand-written maintscript code.
2018-07-11 - Simon McVittie <smcv@debian.org>
policykit-1 (0.105-21) unstable; urgency=medium
* Remove --no-parallel now that parallel builds (hopefully) work.
Thanks to Adrian Bunk for spotting this.
* Refresh patches via gbp pq
* Use one patch per upstream commit for easier metadata round-trips
* Sync up src/polkitagent/polkitagenthelper-pam.c with 0.114
- d/p/0.111/Fix-a-memory-leak.patch:
Fix a memory leak when PAM authentication fails
- d/p/0.113/Remove-a-redundant-assignment.patch:
Fix a potential compiler warning
- d/p/master/Fix-multi-line-pam-text-info.patch:
Split into d/p/0.106/agenthelper-pam-Fix-newline-trimming-code.patch,
d/p/0.114/Fix-multi-line-pam-text-info.patch,
d/p/0.114/Refactor-send_to_helper-usage.patch
* d/p/03_polkitunixsession_sessionid_from_display.patch:
Replace with functionally identical
d/p/0.114/Support-polkit-session-agent-running-outside-user-session.patch
as applied upstream
* d/watch: Use https
* d/watch: Download upstream PGP signatures
* debian/upstream/signing-key.asc: Add public keys for Ray Strode,
Miloslav Trmac, David Zeuthen
* d/gbp.conf: Merge upstream tags into the upstream branch
* Add myself to Uploaders
* d/gbp.conf: Set patch-numbers to false to match current practice
* d/p/0.115/Fix-CVE-2018-1116-Trusting-client-supplied-UID.patch:
Backport the security-significant part of 0.115 (CVE-2018-1116)
(Closes: #903563)
* d/libpolkit-gobject-1-0.symbols: Update for new semi-private ABI
* d/rules: Skip build-time tests if DEB_BUILD_OPTIONS=nocheck
* Standards-Version: 4.1.5 (no changes required)
* Set Rules-Requires-Root to no
2018-03-27 - Simon McVittie <smcv@debian.org>
policykit-1 (0.105-20) unstable; urgency=medium
* Team upload
* d/p/0.108/build-Fix-.gir-generation-for-parallel-make.patch:
Add patch from upstream to fix parallel builds (Closes: #894205)

See Also

Package Description
libpolkit-gobject-1-dev_0.105-25_i386.deb PolicyKit Authorization API - development files
libpolkit-qt-1-1_0.112.0-6_i386.deb PolicyKit-qt-1 library
libpolkit-qt-1-dev_0.112.0-6_i386.deb PolicyKit-qt-1 development files
libpolkit-qt5-1-1_0.112.0-6_i386.deb PolicyKit-qt5-1 library
libpolkit-qt5-1-dev_0.112.0-6_i386.deb PolicyKit-qt5-1 development files
libpolled-camera-dev_1.11.13-3+b1_i386.deb Robot OS polled_camera package - development
libpolled-camera0d_1.11.13-3+b1_i386.deb Robot OS polled_camera package
libpolyclipping-dev_6.4.2-6_i386.deb Polygon and line clipping and offsetting library (development files)
libpolyclipping22_6.4.2-6_i386.deb Polygon and line clipping and offsetting library (shared library)
libpolyglot-maven-java-doc_0.8~tobrien+git20120905-9_all.deb modules to enable Maven usage in others JVM languages - docs
libpolyglot-maven-java_0.8~tobrien+git20120905-9_all.deb modules to enable Maven usage in others JVM languages
libpolylib64-8_5.22.5-4+dfsg_i386.deb Polyhedral library - long int version
libpolylib64-dev_5.22.5-4+dfsg_i386.deb Development files for the long int version of PolyLib
libpolymake-dev-common_3.2r4-4_all.deb Tool for algorithmic discrete geometry -- common dev package
libpolymake-dev_3.2r4-4_i386.deb Tool for algorithmic discrete geometry -- development package
Advertisement
Advertisement