libpoe-component-server-soap-perl_1.14-2_all.deb


Advertisement

Description

libpoe-component-server-soap-perl - POE component to publish event handlers via SOAP over HTTP

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpoe-component-server-soap-perl_1.14-2_all.deb
Package name libpoe-component-server-soap-perl
Package version 1.14
Package release 2
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/POE-Component-Server-SOAP
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 24.63 KB
Installed size 72.00 KB
POE::Component::Server::SOAP is a component that can publish event handlers
via SOAP over HTTP. Currently, this module only supports SOAP/1.1 requests,
though support for SOAP/1.2 is planned. A simple HTTP server is provided by
POE::Component::Server::SimpleHTTP (libpoe-component-server-simplehttp-perl).

Alternatives

Package Version Architecture Repository
libpoe-component-server-soap-perl_1.14-2_all.deb 1.14 all Debian Main
libpoe-component-server-soap-perl - - -

Requires

Name Value
libpoe-component-server-simplehttp-perl -
libpoe-perl -
libsoap-lite-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpoe-component-server-soap-perl_1.14-2_all.deb
Source Package libpoe-component-server-soap-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpoe-component-server-soap-perl deb package:
    # sudo apt-get install libpoe-component-server-soap-perl

Files

Path
/usr/share/doc/libpoe-component-server-soap-perl/changelog.Debian.gz
/usr/share/doc/libpoe-component-server-soap-perl/changelog.gz
/usr/share/doc/libpoe-component-server-soap-perl/copyright
/usr/share/doc/libpoe-component-server-soap-perl/examples/test-client.perl
/usr/share/doc/libpoe-component-server-soap-perl/examples/test-server.perl
/usr/share/man/man3/POE::Component::Server::SOAP.3pm.gz
/usr/share/man/man3/POE::Component::Server::SOAP::Response.3pm.gz
/usr/share/perl5/POE/Component/Server/SOAP.pm
/usr/share/perl5/POE/Component/Server/SOAP/Response.pm

Changelog

2015-06-08 - Damyan Ivanov <dmn@debian.org>
libpoe-component-server-soap-perl (1.14-2) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Damyan Ivanov ]
* Mark package as autopkgtest-able
* Declare compliance with Debian Policy 3.9.6
* Switch to source format "3.0 (quilt)"
* Add explicit build dependency on libmodule-build-perl
* bump debhelper compatibility level to 8
* copyright: point to GPL-1
2010-03-12 - Jonathan Yu <jawnsy@cpan.org>
libpoe-component-server-soap-perl (1.14-1) unstable; urgency=low
[ Jonathan Yu ]
* Standards-Version 3.8.4 (drop perl version dep)
* Add myself to Uploaders and Copyright
* Rewrite control description
* Use new short debhelper rules format
* Update copyright to new DEP5 format
* Drop author tests, remove requirements from B-D-I
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* Make (build) dependency on libpoe-component-server-simplehttp-perl
versioned.
[ Rene Mayorga ]
* New upstream release
* debian/control
+ change debhelper version B-D to >= 7
+ add myself to uploaders
* debian/copyright:
+ update copyright proposal format
+ separate debian/* copyright stanzas based on debian/changelog
+ update upstream copyright years
* debian/rules
+ update to dh 7 format
+ do not include anymore PERL_TEST_CRITIC and PERL_TEST_POD
variables
+ re-add TEST_AUTHOR variable
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ryan Niebur ]
* Update ryan52's email address
2008-08-09 - Damyan Ivanov <dmn@debian.org>
libpoe-component-server-soap-perl (1.13-1) unstable; urgency=low
* New upstream release
* add a bunch of PERL_TEST_* variables to $(MAKE) test invokation and add
several libtest-*-perl packages to b-d-i to enable additional tests.
* debian/copyright:
- refresh year of copyright
- correct mis-indented License: item
* add myself to Uploaders
* do not ship README (POD copy)
2008-06-12 - Martín Ferrari <tincho@debian.org>
libpoe-component-server-soap-perl (1.12-1) unstable; urgency=low
* Initial Release (Closes: #465742).
* debian/control:Updating my email address. Set Standards-Version to 3.8.0
(no changes).
* debian/copyright: complete the new format headers.

See Also

Package Description
libpoe-component-sslify-perl_1.012-1_all.deb module for SSL connection handling in POE Components
libpoe-component-syndicator-perl_0.06-1_all.deb POE component base class which implements the Observer pattern
libpoe-filter-http-parser-perl_1.08-1_all.deb POE filter for HTTP clients or servers
libpoe-filter-ircd-perl_2.44-2_all.deb parser for the IRC protocol
libpoe-filter-ssl-perl_0.41-1+b1_i386.deb module to make SSL in POE easy and flexible
libpoe-filter-stomp-perl_0.04-2_all.deb Perl extension for the POE Environment to provide a Stomp filter
libpoe-filter-xml-perl_1.140700-1_all.deb POE Filter for parsing XML
libpoe-loop-tk-perl_1.305-1_all.deb POE event loop implementation using Tk
libpoe-perl_1.3670-2_all.deb event-driven component architecture for Perl
libpoe-test-loops-perl_1.360-1_all.deb test framework for POE event loops
libpoet-perl_0.16-1_all.deb modern Perl web framework for Mason developers
libpolkit-agent-1-0_0.105-25_i386.deb PolicyKit Authentication Agent API
libpolkit-agent-1-dev_0.105-25_i386.deb PolicyKit Authentication Agent API - development files
libpolkit-backend-1-0_0.105-25_i386.deb PolicyKit backend API
libpolkit-backend-1-dev_0.105-25_i386.deb PolicyKit backend API - development files
Advertisement
Advertisement