libplplotfortran0_5.14.0+dfsg-3_i386.deb


Advertisement

Description

libplplotfortran0 - Scientific plotting library (fortran bindings)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libplplotfortran0_5.14.0+dfsg-3_i386.deb
Package name libplplotfortran0
Package version 5.14.0+dfsg
Package release 3
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.plplot.org
License -
Maintainer Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Download size 176.64 KB
Installed size 479.00 KB
PLplot is relatively small, portable, freely distributable, and is rich
enough to satisfy most users.  It has a wide range of plot types including
line (linear, log), contour, 3D, fill, and almost 1000 characters
(including Greek and mathematical) in its extended font set.  The package
is designed to make it easy to quickly get graphical output; only a
handful of function calls is typically required.  For more advanced use,
virtually all aspects of plotting are configurable.
This package contains the Fortran 95 bindings for PLplot. Note: the Fortran
77 bindings have been deprecated upstream for some time and have now been
dropped from the Debian packages.

Alternatives

Package Version Architecture Repository
libplplotfortran0_5.14.0+dfsg-3_amd64.deb 5.14.0+dfsg amd64 Debian Main
libplplotfortran0 - - -

Requires

Name Value
libc6 >= 2.4
libgfortran5 >= 8
libplplot16 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libplplotfortran0_5.14.0+dfsg-3_i386.deb
Source Package plplot

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libplplotfortran0 deb package:
    # sudo apt-get install libplplotfortran0

Files

Path
/usr/lib/i386-linux-gnu/libplplotfortran.so.0
/usr/lib/i386-linux-gnu/libplplotfortran.so.0.1.0
/usr/share/doc/libplplotfortran0/changelog.Debian.gz
/usr/share/doc/libplplotfortran0/changelog.gz
/usr/share/doc/libplplotfortran0/copyright
/usr/share/lintian/overrides/libplplotfortran0

Changelog

2019-01-06 - Ole Streicher <olebole@debian.org>
plplot (5.14.0+dfsg-3) unstable; urgency=medium
* Fix Breaks of libplplotada1-dev (Closes: #917990)
2019-01-02 - Ole Streicher <olebole@debian.org>
plplot (5.14.0+dfsg-2) unstable; urgency=medium
* Add Breaks+Replaces for old libplplotada-dev. Closes: #917990
2018-12-25 - Ole Streicher <olebole@debian.org>
plplot (5.14.0+dfsg-1) unstable; urgency=medium
* Temporariliy disable built time and CI tests
* Push Standards-Version to 4.3.0. No changes needed
* Switch back to unstable to start transition
2018-12-23 - Ole Streicher <olebole@debian.org>
plplot (5.14.0+dfsg-1~exp2) experimental; urgency=medium
* Remove failing Qt tests
2018-12-21 - Ole Streicher <olebole@debian.org>
plplot (5.14.0+dfsg-1~exp1) experimental; urgency=medium
[ Ole Streicher ]
* Add upstream PGP signature
* New upstream version 5.14.0+dfsg. Rediff patches. Closes: #916714
* SONAME changes. Change to experimental to prepare transition.
Closes: #914680
* Move all examples into the doc package
* Remove Python 2 packages
* Fix lua install dir
* Whitespace cleanup and untabify in d/changelog
* Remove -fPIC from plplot-qt.pc
* Remove unused TRY_OCTAVE4 config option
[ Nicolas Boulenguez ]
* Improve readability of watch file thanks to version 4 of uscan format.
* Complete the link step of the Ada project. Closes: #821278.
* Delegate selection of default build flags to dpkg-buildflags.
2018-11-09 - Ole Streicher <olebole@debian.org>
plplot (5.13.0+dfsg-10) unstable; urgency=low
* Rebuild with gnat-8.
[ Nicolas Boulenguez <nicolas@debian.org> ]
* Rename -dev and library packages as per Debian Policy for Ada.
* Explicitly Build-Depend on both gnat and gnat-8.
* Install a GNAT project. Closes: #821278. Remove Multi-Arch: same.
* Install a README.Debian into the -dev package.
2018-10-03 - Ole Streicher <olebole@debian.org>
plplot (5.13.0+dfsg-9) unstable; urgency=medium
[ Sergei Golovan ]
* Switch to Itcl/Itk 4 (Closes: #893413)
[ Michael Cree ]
* Don't misdetect compiler on Alpha as not supporting NaN (Closes: #901920)
[ Adrian Bunk ]
* python-plplot-qt lost its generated python dependencies (Closes: #906050)
[ Ole Streicher ]
* Push Standards-Version to 4.2.1. No changes needed.
* Push compat to 11
2018-06-20 - S├ębastien Villemot <sebastien@debian.org>
plplot (5.13.0+dfsg-8) unstable; urgency=medium
* Team upload.
[ Ole Streicher ]
* Update VCS fields to use salsa.d.o
* Remove Python3 dependency from python-plplot-qt
[ Andreas Tille ]
* Field Mailing list is not defined in
https://wiki.debian.org/UpstreamMetadata
[ S├ębastien Villemot ]
* i386-mieee-fp.patch: new patch, fixes FTBFS on i386
2017-11-21 - Ole Streicher <olebole@debian.org>
plplot (5.13.0+dfsg-7) unstable; urgency=low
* Fix build with OCaml 4.06
2017-10-05 - Ole Streicher <olebole@debian.org>
plplot (5.13.0+dfsg-6) unstable; urgency=medium
* Convert remaining symlinks (Closes: #875911)
* Push Standards-Version to 4.1.1. No changes required.

See Also

Package Description
libplplotqt2_5.14.0+dfsg-3_i386.deb Scientific plotting library (Qt bindings)
libplplotwxwidgets1_5.14.0+dfsg-3_i386.deb Scientific plotting library (wxWidgets bindings)
libplucene-perl_1.25-4_all.deb Perl port of the Lucene search engine
libplumb2-dev_1.0.12-12_i386.deb Reusable cluster development files -- libplumb2
libplumb2_1.0.12-12_i386.deb Reusable cluster libraries -- libplumb2
libplumbgpl2-dev_1.0.12-12_i386.deb Reusable cluster development files -- libplumbgpl2
libplumbgpl2_1.0.12-12_i386.deb Reusable cluster libraries -- libplumbgpl2
libpluto-jpl-eph-dev_0.0~git20180228-1.1_i386.deb development files to interact with JPL ephemeres data
libpluto-lunar-dev_0.0~git20180825.e34c1d1-1_i386.deb development files for astronomical Lunar library
libplymouth-dev_0.9.4-1.1_i386.deb graphical boot animation and logger - development files
libplymouth4_0.9.4-1.1_i386.deb graphical boot animation and logger - shared libraries
libpmemobj-cpp-doc_1.5.1-1_all.deb C++ bindings to libpmemobj
libpmi-pmix-dev_3.1.2-3_i386.deb Development files for the PMI library (OpenMPI )
libpmi0-dev_18.08.5.2-1_i386.deb SLURM PMI library implementation development files
libpmi0_18.08.5.2-1_i386.deb SLURM PMI library implementation
Advertisement
Advertisement