libpipeline1_1.5.1-2_i386.deb


Advertisement

Description

libpipeline1 - pipeline manipulation library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpipeline1_1.5.1-2_i386.deb
Package name libpipeline1
Package version 1.5.1
Package release 2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://nongnu.org/libpipeline/
License -
Maintainer Colin Watson <cjwatson@debian.org>
Download size 32.55 KB
Installed size 89.00 KB
This is a C library for setting up and running pipelines of processes,
without needing to involve shell command-line parsing which is often
error-prone and insecure.

Alternatives

Package Version Architecture Repository
libpipeline1_1.5.1-2_amd64.deb 1.5.1 amd64 Debian Main
libpipeline1 - - -

Requires

Name Value
libc6 >= 2.28

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpipeline1_1.5.1-2_i386.deb
Source Package libpipeline

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpipeline1 deb package:
    # sudo apt-get install libpipeline1

Files

Path
/usr/lib/i386-linux-gnu/libpipeline.so.1
/usr/lib/i386-linux-gnu/libpipeline.so.1.5.1
/usr/share/doc/libpipeline1/changelog.Debian.gz
/usr/share/doc/libpipeline1/changelog.gz
/usr/share/doc/libpipeline1/copyright

Changelog

2019-02-10 - Colin Watson <cjwatson@debian.org>
libpipeline (1.5.1-2) unstable; urgency=medium
* Update Homepage and debian/copyright Source to use HTTPS.
2019-01-27 - Colin Watson <cjwatson@debian.org>
libpipeline (1.5.1-1) unstable; urgency=medium
* New upstream release.
2018-10-27 - Colin Watson <cjwatson@debian.org>
libpipeline (1.5.0-2) unstable; urgency=medium
* Move VCS to salsa.debian.org.
* Adjust git-dpm tagging configuration.
* Upgrade to debhelper v10.
* Set Rules-Requires-Root: no.
* Simplify debian/rules using /usr/share/dpkg/architecture.mk and
/usr/share/dpkg/pkg-info.mk.
* Drop priority to optional, per Lintian's
excessive-priority-for-library-package tag; a higher priority can be
handled using overrides if necessary.
* Stop building with V=1; debhelper configures with --disable-silent-rules
as of 9.20150501.
2017-11-14 - Colin Watson <cjwatson@debian.org>
libpipeline (1.5.0-1) unstable; urgency=medium
* New upstream release.
* Switch debian/watch to HTTPS.
2017-07-10 - Colin Watson <cjwatson@debian.org>
libpipeline (1.4.2-1) unstable; urgency=medium
* New upstream release.
* Use HTTPS for Vcs-* URLs.
* Policy version 4.0.0: use HTTPS form of copyright-format URL.
2016-01-04 - Colin Watson <cjwatson@debian.org>
libpipeline (1.4.1-2) unstable; urgency=medium
* Remove explicit "XS-Testsuite: autopkgtest" from debian/control;
dpkg-source now figures that out automatically based on the existence of
debian/tests/control.
* Use dpkg-maintscript-helper dir_to_symlink rather than equivalent manual
code.
2015-08-17 - Colin Watson <cjwatson@debian.org>
libpipeline (1.4.1-1) unstable; urgency=medium
[ Colin Watson ]
* New upstream release.
[ Helmut Grohne ]
* Mark check Build-Dependency with <!nocheck> build profile (closes:
#793055).
2014-10-26 - Colin Watson <cjwatson@debian.org>
libpipeline (1.4.0-1) unstable; urgency=medium
* New upstream release.
* Policy version 3.9.6: no changes required.
2014-09-22 - Colin Watson <cjwatson@debian.org>
libpipeline (1.3.1-1) unstable; urgency=medium
* New upstream release.
* Update Vcs-Browser URL for alioth cgit.
2014-03-26 - Colin Watson <cjwatson@debian.org>
libpipeline (1.3.0-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
libpipewire-0.2-1_0.2.5-1_i386.deb libraries for the PipeWire multimedia server
libpipewire-0.2-dev_0.2.5-1_i386.deb libraries for the PipeWire multimedia server - development
libpipewire-0.2-doc_0.2.5-1_all.deb libraries for the PipeWire multimedia server - documentation
libpisock-dev_0.12.5-dfsg-2+b3_i386.deb development files for communicating with a PalmOS PDA
libpisock9_0.12.5-dfsg-2+b3_i386.deb library for communicating with a PalmOS PDA
libpisync1_0.12.5-dfsg-2+b3_i386.deb synchronization library for PalmOS devices
libpithub-perl_0.01034-1_all.deb Github v3 API
libpixelif-common_0.8.4-3_all.deb Provides localization and font data for libpixelif
libpixelif-dev_0.8.4-3_i386.deb Interface translating fizmo output into pixel data
libpixelmed-codec-java_20170512-2_all.deb some imaging codecs for pixelmed DICOM image and ECG viewer
libpixelmed-java-doc_20150917+git20151209.36f3174+dfsg-1_all.deb DICOM implementation containing Image Viewer and a ECG Viewer - doc
libpixelmed-java_20150917+git20151209.36f3174+dfsg-1_all.deb DICOM implementation containing Image Viewer and a ECG Viewer
libpixels-java_2.1.3+svn.42-2_all.deb manipulation and filtering of images in Java
libpixie-java_1.1.6-3_all.deb Java Vector Format Viewer Library
libpixman-1-0_0.36.0-1_i386.deb pixel-manipulation library for X and cairo
Advertisement
Advertisement