libpicocontainer-java_2.15+repack-1_all.deb


Advertisement

Description

libpicocontainer-java - Java library implementing the Dependency Injection pattern

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpicocontainer-java_2.15+repack-1_all.deb
Package name libpicocontainer-java
Package version 2.15+repack
Package release 1
Package architecture all
Package type deb
Category implemented-in::java java role::shared-lib
Homepage http://picocontainer.com
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 294.85 KB
Installed size 361.00 KB
PicoContainer is a highly embeddable full service Inversion of Control (IoC)
container for components that honour the Dependency Injection pattern. It can
be used as a lightweight alternative to Sun's J2EE patterns for web
applications or general solutions.
Despite it being very compact in size, PicoContainer supports different
dependency injection types (Constructor, Setter, Annotated Field and Method)
and offers multiple lifecycle and monitoring strategies.

Alternatives

Package Version Architecture Repository
libpicocontainer-java_2.15+repack-1_all.deb 2.15+repack all Debian Main
libpicocontainer-java - - -

Requires

Name Value
libparanamer-java >= 2.8

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpicocontainer-java_2.15+repack-1_all.deb
Source Package libpicocontainer-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpicocontainer-java deb package:
    # sudo apt-get install libpicocontainer-java

Files

Path
/usr/share/doc/libpicocontainer-java/changelog.Debian.gz
/usr/share/doc/libpicocontainer-java/copyright
/usr/share/java/picocontainer-2.15.1-SNAPSHOT.jar
/usr/share/java/picocontainer.jar
/usr/share/maven-repo/org/picocontainer/picocontainer/2.15.1-SNAPSHOT/picocontainer-2.15.1-SNAPSHOT.jar
/usr/share/maven-repo/org/picocontainer/picocontainer/2.15.1-SNAPSHOT/picocontainer-2.15.1-SNAPSHOT.pom
/usr/share/maven-repo/org/picocontainer/picocontainer/debian/picocontainer-debian.jar
/usr/share/maven-repo/org/picocontainer/picocontainer/debian/picocontainer-debian.pom

Changelog

2019-03-01 - Emmanuel Bourg <ebourg@apache.org>
libpicocontainer-java (2.15+repack-1) unstable; urgency=medium
* Team upload.
* Rebuilt the upstream tarball from the GitHub project
instead of the source artifact in Maven Central
* Build with maven-debian-helper instead of javahelper
* Standards-Version updated to 4.3.0
* Use salsa.debian.org Vcs-* URLs
2018-11-03 - Markus Koschany <apo@debian.org>
libpicocontainer-java (2.15-4) unstable; urgency=medium
* Remove build-dependency on libactivation-java again.
2018-11-02 - Markus Koschany <apo@debian.org>
libpicocontainer-java (2.15-3) unstable; urgency=medium
* Switch to compat level 11.
* Declare compliance with Debian Policy 4.2.1.
* Fix FTBFS with OpenJDK 11 by depending on libactivation-java and
libgeronimo-annotation-1.3-spec-java. (Closes: #912547)
2016-12-21 - Markus Koschany <apo@debian.org>
libpicocontainer-java (2.15-2) unstable; urgency=medium
* Vcs-fields: Use https.
* Update my e-mail address.
* Switch to compat level 10.
* Use only Build-Depends field.
* Declare compliance with Debian Policy 3.9.8.
* d/copyright: Update Source address. Codehaus was closed down.
2014-10-31 - Markus Koschany <apo@gambaru.de>
libpicocontainer-java (2.15-1) unstable; urgency=low
* Reintroduction of libpicocontainer-java. (Closes: #766253)
* Switch to dh sequencer, javahelper and maven_repo_helper.
* Declare compliance with Debian Policy 3.9.6.
* Use Git repository for packaging.
* Add libpicocontainer-java-doc binary package.
* Use compat level 9 and require debhelper >= 9.
2009-11-04 - Michael Koch <konqueror@gmx.de>
libpicocontainer-java (2.9-1) unstable; urgency=low
* New upstream release.
* Build-Depends on debhelper (>= 7).
* Moved default-jdk and ant to Build-Depends.
* Tighten Build-Depends on libparanamer-java.
* Added myseld to Uploaders.
2009-08-23 - Torsten Werner <twerner@debian.org>
libpicocontainer-java (2.8-2) unstable; urgency=low
* Switch to default-java. (Closes: #543060)
* Add missing ${misc:Depends}.
* Change Section: java.
* Update Standards-Version: 3.8.3.
2009-03-01 - Varun Hiremath <varun@debian.org>
libpicocontainer-java (2.8-1) unstable; urgency=low
* New upstream release
2009-02-17 - Torsten Werner <twerner@debian.org>
libpicocontainer-java (2.7-1) unstable; urgency=low
* New upstream release
* Disable compiler warnings.
2008-11-18 - Torsten Werner <twerner@debian.org>
libpicocontainer-java (2.6+dak1-1) unstable; urgency=low
* Move package to main.

See Also

Package Description
libpigpiod-if-dev_1.68-3_i386.deb Development headers for client libraries for Raspberry Pi GPIO control
libpigpiod-if1_1.68-3_i386.deb Client library for Raspberry Pi GPIO control (deprecated)
libpigpiod-if2-1_1.68-3_i386.deb Client library for Raspberry Pi GPIO control
libpillowfight-dev_0.2.4-2_i386.deb Various image processing algorithms library - development files
libpillowfight_0.2.4-2_i386.deb Various image processing algorithms library
libpils2-dev_1.0.12-12_i386.deb Reusable cluster development files -- libpils2
libpils2_1.0.12-12_i386.deb Reusable cluster libraries -- libpils2
libpinyin-common-dev_2.2.2-1_all.deb library to deal with PinYin / zhuyin - common development files
libpinyin-data_2.2.2-1_i386.deb Data for PinYin / zhuyin input method library
libpinyin-utils_2.2.2-1_i386.deb library to deal with PinYin - utilities
libpinyin13-dev_2.2.2-1_i386.deb library to deal with PinYin - development files
libpinyin13_2.2.2-1_i386.deb library to deal with PinYin
libpipebang-camlp4-dev_113.00.00-2+b1_i386.deb OCaml Syntax extension to transform pipe expressions
libpipeline-dev_1.5.1-2_i386.deb pipeline manipulation library (development files)
libpipeline1_1.5.1-2_i386.deb pipeline manipulation library
Advertisement
Advertisement