libphysfs-dev_3.0.1-3.1_i386.deb


Advertisement

Description

libphysfs-dev - filesystem abstraction library for game programmers (development headers)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libphysfs-dev_3.0.1-3.1_i386.deb
Package name libphysfs-dev
Package version 3.0.1
Package release 3.1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://www.icculus.org/physfs/
License -
Maintainer Patrick Matthäi <pmatthaei@debian.org>
Download size 109.23 KB
Installed size 382.00 KB
The PhysicsFS filesystem abstraction library provides a simple C
interface to aid game programmers in utilizing game assets packaged in
many different types of archive files.
This package contains the development libraries and headers.

Alternatives

Package Version Architecture Repository
libphysfs-dev_3.0.1-3.1_amd64.deb 3.0.1 amd64 Debian Main
libphysfs-dev - - -

Requires

Name Value
libc6 >= 2.4
libncurses6 >= 6
libphysfs1 = 3.0.1-3.1
libreadline7 >= 6.0
libtinfo6 >= 6

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libphysfs-dev_3.0.1-3.1_i386.deb
Source Package libphysfs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libphysfs-dev deb package:
    # sudo apt-get install libphysfs-dev

Files

Path
/usr/bin/test_physfs
/usr/include/physfs.h
/usr/lib/i386-linux-gnu/libphysfs.a
/usr/lib/i386-linux-gnu/libphysfs.so
/usr/share/doc/libphysfs-dev/changelog.Debian.gz
/usr/share/doc/libphysfs-dev/changelog.gz
/usr/share/doc/libphysfs-dev/copyright
/usr/share/lintian/overrides/libphysfs-dev
/usr/share/man/man1/test_physfs.1.gz

Changelog

2018-12-01 - Stephen Kitt <skitt@debian.org>
libphysfs (3.0.1-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix the fsync patch. Really closes: #907429.
2018-11-29 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (3.0.1-3) unstable; urgency=medium
* Bump Standards-Version to 4.2.1.
* Merge 3.0.1-2~bpo9+1 changelog.
* Fix renamed debian-watch lintian tag.
* Add upstream patch 02-fsync.
Closes: #907429
2018-10-22 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (3.0.1-2~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports.
2018-06-05 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (3.0.1-2) unstable; urgency=high
* Move package to my own repository.
* Bump Standards-Version to 4.1.4.
* Move source.lintian-overrides file to source directory.
* Add upstream patch 01-setwritedir to fix a bug in the setWriteDir function.
Much thanks Gianfranco Costamagna for taking care of this.
Closes: #898483
* Bump debian/compat to level 11.
* Adjust lintian overrides.
2017-11-07 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (3.0.1-1) unstable; urgency=medium
* New upstream release.
- Remove merged or not anymore required patches
01-do-not-link-against-curses, 02-zip-seek and 03-set-project-number.
* Bump Standards-Version to 4.1.1 (no changes required).
* Use secure URI for homepage and debian/watch.
* Remove trailing whitespace from debian/changelog.
* Adjust lintian overrides.
* doc base has been removed.
* Removed doxygen.
* Various docs has been removed.
* Remove now missing manpages and doc files.
* jquery is no longer a part of this package.
* Adjust debian/copyright.
2017-08-03 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.3-6) unstable; urgency=medium
* Bump Standards-Version to 4.0.0 (no changes required).
* Drop dbg package.
* Bump debian/compat to level 10.
- Drop build dependency on autotools-dev.
* Add patch 03-set-project-number to set the project number in the Doxyfile.
Closes: #795574
* Overwrite lintian warning vcs-field-uses-insecure-uri.
* Correctly remove jquery.js file.
2017-04-03 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.3-5) unstable; urgency=low
* Add patch 02-zip-seek to fix a buffer overflow in physfs with zlib version
>= 1.2.11.
2016-12-23 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.3-4) unstable; urgency=medium
* Enable full hardening.
* Use secure Vcs-Browser URL.
* Bump Standards-Version to 3.9.8 (no changes required).
2015-08-05 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.3-3) unstable; urgency=medium
[ Evgeni Golov ]
* Correct Vcs-* URLs to point to anonscm.debian.org
[ Patrick Matthäi ]
* Don't explicitly request xz compression - dpkg 1.17 does this by default.
* Bump Standards-Version to 3.9.6 (no changes needed).
* Remove deprecated hardening-wrapper.
* Update to DEP5 debian/copyright format.
* Fix lintian warning static-library-has-unneeded-section.
* Overwrite lintian warning debian-watch-may-check-gpg-signature, since there
are no signatures available
* Remove unused lintian overrides.
* Link and depend against system libjs-jquery version.
2013-05-06 - Patrick Matthäi <pmatthaei@debian.org>
libphysfs (2.0.3-2) unstable; urgency=low
* Adopt debian/watch from Bart Martens.
* Uploading to unstable.
* Migrate package to minimal debhelper.
* Remove unused lintian overrides.
* Adjust Vcs-Browser debian/control field.

See Also

Package Description
libphysfs1_3.0.1-3.1_i386.deb filesystem abstraction library for game programmers
libpiano-dev_2019.02.14-1_i386.deb library to interface with Pandora radio -- development
libpiano0_2019.02.14-1_i386.deb library to interface with Pandora radio -- runtime files
libpicard-java-doc_2.18.25+dfsg-2_all.deb Documentation for the java picard library
libpiccolo-java_1.2-1.1_all.deb toolkit for development of 2D structured graphics
libpicocli-java_3.9.2-1_all.deb Tiny command line interpreter library for Java applications
libpicocontainer-java-doc_2.15+repack-1_all.deb Java library implementing the Dependency Injection pattern -- docs
libpicocontainer-java_2.15+repack-1_all.deb Java library implementing the Dependency Injection pattern
libpigpiod-if-dev_1.68-3_i386.deb Development headers for client libraries for Raspberry Pi GPIO control
libpigpiod-if1_1.68-3_i386.deb Client library for Raspberry Pi GPIO control (deprecated)
libpigpiod-if2-1_1.68-3_i386.deb Client library for Raspberry Pi GPIO control
libpillowfight-dev_0.2.4-2_i386.deb Various image processing algorithms library - development files
libpillowfight_0.2.4-2_i386.deb Various image processing algorithms library
libpils2-dev_1.0.12-12_i386.deb Reusable cluster development files -- libpils2
libpils2_1.0.12-12_i386.deb Reusable cluster libraries -- libpils2
Advertisement
Advertisement