libperl6-export-attrs-perl_0.000006-1_all.deb


Advertisement

Description

libperl6-export-attrs-perl - Perl 6 'is export(...)' trait as a Perl 5 attribute

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libperl6-export-attrs-perl_0.000006-1_all.deb
Package name libperl6-export-attrs-perl
Package version 0.000006
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Perl6-Export-Attrs
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 12.59 KB
Installed size 34.00 KB
Perl6::Export::Attrs implements a Perl 5 native version
of what the Perl 6 symbol export mechanism will look like.

Alternatives

Package Version Architecture Repository
libperl6-export-attrs-perl_0.000006-1_all.deb 0.000006 all Debian Main
libperl6-export-attrs-perl - - -

Requires

Name Value
libpadwalker-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libperl6-export-attrs-perl_0.000006-1_all.deb
Source Package libperl6-export-attrs-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperl6-export-attrs-perl deb package:
    # sudo apt-get install libperl6-export-attrs-perl

Files

Path
/usr/share/doc/libperl6-export-attrs-perl/changelog.Debian.gz
/usr/share/doc/libperl6-export-attrs-perl/changelog.gz
/usr/share/doc/libperl6-export-attrs-perl/copyright
/usr/share/man/man3/Perl6::Export::Attrs.3pm.gz
/usr/share/perl5/Perl6/Export/Attrs.pm

Changelog

2019-02-20 - Jonas Smedegaard <dr@jones.dk>
libperl6-export-attrs-perl (0.000006-1) unstable; urgency=medium
[ upstream ]
* New release.
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org.
[ gregor herrmann ]
* Update URLs from {search,www}.cpan.org to MetaCPAN.
[ Jonas Smedegaard ]
* Simplify rules.
Stop build-depend on devscripts cdbs.
* Update git-buildpackage config: Filter any .git* file.
* Stop build-depend on dh-buildinfo.
* Mark build-dependencies needed only for testsuite as such.
* Declare compliance with Debian Policy 4.3.0.
* Set Rules-Requires-Root: no.
* Wrap and sort control file.
* Drop obsolete lintian override regarding debhelper 9.
* Tighten lintian overrides regarding License-Reference.
* Update copyright info: Extend coverage of packaging.
* Update watch file:
+ Bump to file format 4.
+ Rewrite usage comment.
+ Use substitution strings.
* Drop patch 1001 applied upstream.
2015-12-28 - Jonas Smedegaard <dr@jones.dk>
libperl6-export-attrs-perl (0.000005-1) unstable; urgency=medium
[ upstream ]
* New release.
2015-11-22 - Jonas Smedegaard <dr@jones.dk>
libperl6-export-attrs-perl (0.000004-3) unstable; urgency=medium
* Add patch 1001 to fix regression in exporting subroutines.
Closes: Bug#805105. Thanks to Miko Tyni.
2015-10-28 - Jonas Smedegaard <dr@jones.dk>
libperl6-export-attrs-perl (0.000004-2) unstable; urgency=medium
* Sort and newline-delimit dependencies.
* Fix depend (not only build-depend) on libpadwalker-perl.
Closes: Bug#803326. Thanks to Niko Tyni.
2015-10-26 - Jonas Smedegaard <dr@jones.dk>
libperl6-export-attrs-perl (0.000004-1) unstable; urgency=medium
[ upstream ]
* New release.
[ Jonas Smedegaard ]
* Revert wrong fix for lintian missing-license-text-in-dep5-copyright
warning
* Update copyright info:
+ Use License-Grant and License-Reference fields.
Thanks to Ben Finney.
+ Extend copyright of packaging to cover recent years.
+ Tighten license of packaging to GPL-3+.
* Add lintian override regarding license in License-Reference field.
See bug#786450.
* Bump debhelper compatibility level to 9.
* Add lintian override regarding debhelper 9.
2015-06-11 - Damyan Ivanov <dmn@debian.org>
libperl6-export-attrs-perl (0.0.3-2) unstable; urgency=low
* Team upload
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Damyan Ivanov ]
* Mark package as autopkgtest-able
* Declare compliance with Debian Policy 3.9.6
* Use canonical Vcs-* URLs
* Remove versioned perl-modules alternative from libmodule-build-perl buil
dependency (Closes: #788146)
2011-04-22 - Jonas Smedegaard <dr@jones.dk>
libperl6-export-attrs-perl (0.0.3-1) unstable; urgency=low
* Initial packaging release.
Closes: bug#623715.

See Also

Package Description
libperl6-export-perl_0.009-1_all.deb implementation of the Perl 6 'is export(...)' trait
libperl6-form-perl_0.090-1_all.deb Perl 5 implementation of the Perl 6 'form' built-in
libperl6-junction-perl_1.60000-1_all.deb module providing Perl6-style Junction operators in Perl5
libperl6-say-perl_0.16-1_all.deb module to print without newline needed
libperl6-slurp-perl_0.051005-1_all.deb module implementing the Perl 6 'slurp' built-in
libperlanet-perl_1.1.3-1_all.deb program for creating programs that aggregate web feeds
libperlbal-perl_1.80-3_all.deb Perlbal libraries; embed perlbal into another app
libperlbal-xs-httpheaders-perl_0.20-2+b8_i386.deb Perlbal extension for processing HTTP headers faster
libperldoc-search-perl_0.01-3_all.deb Index and Search local Perl Documentation
libperlio-eol-perl_0.17-1+b1_i386.deb PerlIO layer for normalizing line endings
libperlio-gzip-perl_0.19-1+b5_i386.deb module providing a PerlIO layer to gzip/gunzip
libperlio-layers-perl_0.011-2+b1_i386.deb Perl module to query a filehandle's capabilities
libperlio-utf8-strict-perl_0.007-2+b1_i386.deb fast and correct UTF-8 Perl IO module
libperlio-via-dynamic-perl_0.14-1_all.deb module to create dynamic PerlIO layers
libperlio-via-symlink-perl_0.05-3_all.deb PerlIO layer for creating symlinks
Advertisement
Advertisement