libperl-destruct-level-perl_0.02-2+b6_i386.deb


Advertisement

Description

libperl-destruct-level-perl - Perl module to change Perl's destruction level

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libperl-destruct-level-perl_0.02-2+b6_i386.deb
Package name libperl-destruct-level-perl
Package version 0.02
Package release 2+b6
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib role::shared-lib
Homepage https://metacpan.org/release/Perl-Destruct-Level/
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 8.13 KB
Installed size 40.00 KB
Perl::Destruct::Level is an interface allowing one to change Perl's internal
destruction level. While this functionality is available through the
PERL_DESTRUCT_LEVEL environment variable when perl is compiled with debug
support, this module provides it for perls without -DDEBUGGING.
The default value of the destruct level is 0; it means that perl won't bother
destroying all its internal data structures, but let the OS do the cleanup
for it at exit.
Relevant values recognized by perl are 1 and 2. Consult your source code to
know exactly what they mean. Note that some embedded environments might
extend the meaning of the destruction level for their own purposes: mod_perl
does that, for example.

Alternatives

Package Version Architecture Repository
libperl-destruct-level-perl_0.02-2+b6_amd64.deb 0.02 amd64 Debian Main
libperl-destruct-level-perl - - -

Requires

Name Value
libc6 >= 2.1.3
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libperl-destruct-level-perl_0.02-2+b6_i386.deb
Source Package libperl-destruct-level-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperl-destruct-level-perl deb package:
    # sudo apt-get install libperl-destruct-level-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/Perl/Destruct/Level.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/Perl/Destruct/Level/Level.so
/usr/share/doc/libperl-destruct-level-perl/changelog.Debian.gz
/usr/share/doc/libperl-destruct-level-perl/changelog.Debian.i386.gz
/usr/share/doc/libperl-destruct-level-perl/copyright
/usr/share/man/man3/Perl::Destruct::Level.3pm.gz

Changelog

2014-02-22 - gregor herrmann <gregoa@debian.org>
libperl-destruct-level-perl (0.02-2) unstable; urgency=low
* Team upload.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ryan Niebur ]
* Update jawnsy's email address
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Switch to "3.0 (quilt)" source format.
* debian/rules: three lines are enough with dh(1).
* Refresh license stanzas in debian/copyright.
* Use debhelper 9.20120312 to get all hardening flags.
* Add patch to fix grammar problem discovered by lintian.
* Declare compliance with Debian Policy 3.9.5.
2009-04-30 - Jonathan Yu <frequency@cpan.org>
libperl-destruct-level-perl (0.02-1) unstable; urgency=low
* Initial Release. (Closes: #526385)

See Also

Package Description
libperl-dev_5.28.1-6_i386.deb Perl library: development files
libperl-metrics-simple-perl_0.18-1_all.deb module to provide metrics of Perl code
libperl-minimumversion-perl_1.38-2_all.deb module to determine minimum required version of perl required
libperl-osnames-perl_0.11-1_all.deb Perl module to list possible $^O ($OSNAME) values with description
libperl-prereqscanner-perl_1.023-1_all.deb module for extracting prerequisites from Perl code
libperl-version-perl_1.013-2_all.deb module to parse and manipulate Perl version strings
libperl4-corelibs-perl_0.004-1_all.deb libraries historically supplied with Perl 4
libperl4caml-ocaml-dev_0.9.5-5+b4_i386.deb Use Perl code in OCaml programs, development files
libperl4caml-ocaml-doc_0.9.5-5_all.deb Use Perl code in OCaml programs, documentation
libperl4caml-ocaml_0.9.5-5+b4_i386.deb Use Perl code in OCaml programs, runtime library
libperl5.28_5.28.1-6_i386.deb shared Perl library
libperl5i-perl_2.13.2-1_i386.deb pragma to fix as much of Perl 5 as possible
libperl6-caller-perl_0.100-3_all.deb Perl6-like OO caller() interface for Perl 5
libperl6-export-attrs-perl_0.000006-1_all.deb Perl 6 'is export(...)' trait as a Perl 5 attribute
libperl6-export-perl_0.009-1_all.deb implementation of the Perl 6 'is export(...)' trait
Advertisement
Advertisement