libpdl-linearalgebra-perl_0.12-3+b1_i386.deb


Advertisement

Description

libpdl-linearalgebra-perl - Linear Algebra utils for PDL

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpdl-linearalgebra-perl_0.12-3+b1_i386.deb
Package name libpdl-linearalgebra-perl
Package version 0.12
Package release 3+b1
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib
Homepage https://metacpan.org/release/PDL-LinearAlgebra
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 575.17 KB
Installed size 3.71 MB
PDL::LinearAlgebra provides PDL bindings to LAPACK and BLAS. The package
contains both the slower-but-more-flexible PDL::LinearAlgebra module and
faster-but-more-specific PDL::LinearAlgebra::Real and
PDL::LinearAlgebra::Complex modules.

Alternatives

Package Version Architecture Repository
libpdl-linearalgebra-perl_0.12-3+b1_amd64.deb 0.12 amd64 Debian Main
libpdl-linearalgebra-perl - - -

Requires

Name Value
libatlas3-base -
libblas.so.3 -
libblas3 -
libc6 >= 2.4
liblapack.so.3 -
liblapack3 -
libquadmath0 >= 4.6
pdl >= 1:2.019-5+b1
pdlapi-12 -
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpdl-linearalgebra-perl_0.12-3+b1_i386.deb
Source Package libpdl-linearalgebra-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpdl-linearalgebra-perl deb package:
    # sudo apt-get install libpdl-linearalgebra-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/PDL/LinearAlgebra.pm
/usr/lib/i386-linux-gnu/perl5/5.28/PDL/LinearAlgebra/Complex.pm
/usr/lib/i386-linux-gnu/perl5/5.28/PDL/LinearAlgebra/Real.pm
/usr/lib/i386-linux-gnu/perl5/5.28/PDL/LinearAlgebra/Special.pm
/usr/lib/i386-linux-gnu/perl5/5.28/PDL/LinearAlgebra/Trans.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/PDL/LinearAlgebra/Complex/Complex.so
/usr/lib/i386-linux-gnu/perl5/5.28/auto/PDL/LinearAlgebra/Real/Real.so
/usr/lib/i386-linux-gnu/perl5/5.28/auto/PDL/LinearAlgebra/Trans/Trans.so
/usr/share/doc/libpdl-linearalgebra-perl/changelog.Debian.gz
/usr/share/doc/libpdl-linearalgebra-perl/changelog.Debian.i386.gz
/usr/share/doc/libpdl-linearalgebra-perl/changelog.gz
/usr/share/doc/libpdl-linearalgebra-perl/copyright
/usr/share/man/man3/PDL::LinearAlgebra.3pm.gz
/usr/share/man/man3/PDL::LinearAlgebra::Complex.3pm.gz
/usr/share/man/man3/PDL::LinearAlgebra::Real.3pm.gz
/usr/share/man/man3/PDL::LinearAlgebra::Special.3pm.gz
/usr/share/man/man3/PDL::LinearAlgebra::Trans.3pm.gz

Changelog

2018-07-22 - Bas Couwenberg <sebastic@debian.org>
libpdl-linearalgebra-perl (0.12-3) unstable; urgency=medium
* Team upload.
[ Bas Couwenberg ]
* Update spelling-errors.patch to fix 'with' typo.
* Bump Standards-Version to 4.1.5, no changes.
* Update Vcs-* URLs for Salsa.
* Add 'Testsuite: autopkgtest-pkg-perl' to control file.
* Skip use.t, fails with unwhitelistable warnings.
[ Damyan Ivanov ]
* declare conformance with Policy 4.1.3 (no changes needed)
2016-06-24 - Bas Couwenberg <sebastic@debian.org>
libpdl-linearalgebra-perl (0.12-2) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Bas Couwenberg ]
* Enable all hardening buildflags.
* Add patch to fix spelling errors.
* Add upstream metadata.
* Bump Standards-Version to 3.9.8, no changes.
* Require at least pdl 2.016 for pdl transition.
2015-08-25 - Dima Kogan <dima@secretsauce.net>
libpdl-linearalgebra-perl (0.12-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Dima Kogan ]
* Imported Upstream version 0.12
* Patch: don't link with gfortran explicitly. Not needed on sid
[ gregor herrmann ]
* Declare compliance with Debian Policy 3.9.6.
* Add a patch to fix a spelling mistake in the POD.
2013-12-04 - Damyan Ivanov <dmn@debian.org>
libpdl-linearalgebra-perl (0.08-1) unstable; urgency=low
* Team upload
[ Dima Kogan ]
* New upstream release. (Closes: #730909 -- FTBFS - test failures)
Main changes:
- license updated to Artistic 2.0
- Added support for the new 64-bit-index-enabled PDL ( >= 2.007 ).
This is a non-backwards-compatible change so this package now requires
this newer PDL.
- msyminv() works correctly
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Damyan Ivanov ]
* drop trailing slash from metacpan URLs
2012-11-17 - Dima Kogan <dima@secretsauce.net>
libpdl-linearalgebra-perl (0.06-4) unstable; urgency=low
* Initial Release. (Closes: #692094)

See Also

Package Description
libpdl-netcdf-perl_4.20-6+b1_i386.deb Netcdf-IO for PDL
libpdl-stats-perl_0.75-2+b1_i386.deb collection of statistics modules in Perl Data Language
libpdl-vectorvalued-perl_1.0.9-1+b1_i386.deb module to provide some utilities for vector-valued PDLs
libpe-rules26_2.0.1-5_i386.deb cluster resource manager Policy Engine rules library
libpe-status28_2.0.1-5_i386.deb cluster resource manager Policy Engine status library
libpeas-1.0-0_1.22.0-4_i386.deb Application plugin library
libpeas-1.0-python2loader_1.22.0-4_i386.deb Application plugin library (Python 2 support)
libpeas-common_1.22.0-4_all.deb Application plugin library (common files)
libpeas-dev_1.22.0-4_i386.deb Application plugin library (development files)
libpeas-doc_1.22.0-4_i386.deb Application plugin library (documentation)
libpegdown-java_1.6.0-1_all.deb Lightweight Markdown processing library
libpegex-perl_0.70-1_all.deb Acmeist PEG Parser Framework
libpengine-dev_2.0.1-5_all.deb transitional package
libpengine27_2.0.1-5_i386.deb cluster resource manager Policy Engine library
libpentaho-reporting-flow-engine-java-doc_0.9.4-5_all.deb report library for java documentation
Advertisement
Advertisement