libpcap0.8_1.8.1-6_i386.deb


Advertisement

Description

libpcap0.8 - system interface for user-level packet capture

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpcap0.8_1.8.1-6_i386.deb
Package name libpcap0.8
Package version 1.8.1
Package release 6
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.tcpdump.org/
License -
Maintainer Romain Francoise <rfrancoise@debian.org>
Download size 141.46 KB
Installed size 338.00 KB
libpcap (Packet CAPture) provides a portable framework for low-level
network monitoring.  Applications include network statistics collection,
security monitoring, network debugging, etc.
Since almost every system vendor provides a different interface for
packet capture, and since there are several tools that require this
functionality, the libpcap authors created this system-independent API
to ease in porting and to alleviate the need for several
system-dependent packet capture modules in each application.

Alternatives

Package Version Architecture Repository
libpcap0.8_1.8.1-6_amd64.deb 1.8.1 amd64 Debian Main
libpcap0.8 - - -

Requires

Name Value
libc6 >= 2.11

Replaces

Name Value
libpcap0.8-dev << 1.0.0-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpcap0.8_1.8.1-6_i386.deb
Source Package libpcap

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpcap0.8 deb package:
    # sudo apt-get install libpcap0.8

Files

Path
/usr/lib/i386-linux-gnu/libpcap.so.0.8
/usr/lib/i386-linux-gnu/libpcap.so.1.8.1
/usr/share/doc/libpcap0.8/CREDITS.gz
/usr/share/doc/libpcap0.8/README
/usr/share/doc/libpcap0.8/README.Debian
/usr/share/doc/libpcap0.8/changelog.Debian.gz
/usr/share/doc/libpcap0.8/changelog.gz
/usr/share/doc/libpcap0.8/copyright
/usr/share/man/man7/pcap-filter.7.gz

Changelog

2017-12-31 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.8.1-6) unstable; urgency=medium
* debian/watch: add pgpsigurlmangle option.
* Add upstream signing key in debian/upstream.
* Make transitional package libpcap-dev 'Multi-Arch: same'.
* Use new URLs on salsa.debian.org for Vcs-* fields.
* Lintian cleanups:
+ Make libpcap0.8-dbg 'Priority: optional'.
+ Use /usr/share/dpkg/architecture.mk instead of setting DEB_HOST_ARCH_OS.
+ Bump Standards-Version to 4.1.2.
2017-09-30 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.8.1-5) unstable; urgency=medium
* Remove unused RPATH handling from pcap-config: now that we no longer
output the -L option in front, it causes --libs output to begin with a
space, which displeases cmake (closes: #876123).
* Make libpcap-dev arch:any to allow cross-building, as suggested by
Helmut Grohne (closes: #820829).
2017-09-02 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.8.1-4) unstable; urgency=medium
* Don't include arch-dependent paths in pcap-config --libs output.
* Make libpcap0.8-dev Multi-Arch: same, with thanks to Francois Gouget
(closes: #760370).
* Set Standards-Version to 4.1.0.
2016-11-06 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.8.1-3) unstable; urgency=medium
* Disable bits of remote capture support inherited from the WinPCAP
merge which cause applications to FTBFS if they define HAVE_REMOTE
(closes: #843384).
* Fix warning in pcap-tstamp(7) pointed out by lintian.
* Use cgit URL in Vcs-Browser.
2016-10-30 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.8.1-2) unstable; urgency=medium
* Update Debian-specific Hurd packet interface to use the new internal API,
fixes FTBFS.
* Include <sys/kern/time.h> in BPF packet interface to get access to
`struct bintime' and friends on kFreeBSD, fixes FTBFS.
2016-10-29 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.8.1-1) unstable; urgency=medium
* New upstream release.
2016-09-17 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.7.4-3) unstable; urgency=medium
* Drop unnecessary build-depends on perl (closes: #816187).
* Hardcode packet interface type in debian/rules to make cross-building
easier, patch by Samuel Thibault (closes: #816188).
* Stop patching config.{guess,sub}, dh_update_autotool_config now
handles that automatically for us.
* Set Standards-Version to 3.9.8.
2015-11-28 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.7.4-2) unstable; urgency=medium
* Only override arch-dependent dh targets (closes: #806061).
* Update versioned build-depends on debhelper accordingly.
2015-07-04 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.7.4-1) unstable; urgency=medium
* New upstream bugfix release.
2015-05-24 - Romain Francoise <rfrancoise@debian.org>
libpcap (1.7.3-1) unstable; urgency=medium
* New upstream release, API addition: pcap_dump_open_append().

See Also

Package Description
libpcaudio-dev_1.1-3_i386.deb C API to different audio devices - development files
libpcaudio0_1.1-3_i386.deb C API to different audio devices - shared library
libpcc-dev_1.2.0~DEVEL+20180604-2.1_i386.deb Portable C Compiler (development files)
libpcg-cpp-dev_0.98.1-2_all.deb compile-time library for PCG random number generation
libpci-dev_3.5.2-1_i386.deb Linux PCI Utilities (development files)
libpci3_3.5.2-1_i386.deb Linux PCI Utilities (shared library)
libpciaccess-dev_0.14-1_i386.deb Generic PCI access library for X - development files
libpciaccess0_0.14-1_i386.deb Generic PCI access library for X
libpcl-apps1.9_1.9.1+dfsg1-10_i386.deb Point Cloud Library - apps library
libpcl-common1.9_1.9.1+dfsg1-10_i386.deb Point Cloud Library - common library
libpcl-conversions-dev_0.2.1-4_i386.deb Robot OS library to convert from/to PCL data types
libpcl-dev_1.9.1+dfsg1-10_i386.deb Point Cloud Library - development files
libpcl-doc_1.9.1+dfsg1-10_all.deb Point Cloud Library - documentation
libpcl-features1.9_1.9.1+dfsg1-10_i386.deb Point Cloud Library - features library
libpcl-filters1.9_1.9.1+dfsg1-10_i386.deb Point Cloud Library - filters library
Advertisement
Advertisement