libparanoid-perl_2.06-1_all.deb


Advertisement

Description

libparanoid-perl - module for safer, more secure programming

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libparanoid-perl_2.06-1_all.deb
Package name libparanoid-perl
Package version 2.06
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/Paranoid
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 128.86 KB
Installed size 393.00 KB
Paranoid is a collection of Perl modules that began as simple utilities which
perform things in a (debatably) safer and taint-safe manner. Since then it's
also grown to include functionality that fit into the same framework and
conventions of the original modules.

Alternatives

Package Version Architecture Repository
libparanoid-perl_2.06-1_all.deb 2.06 all Debian Main
libparanoid-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libparanoid-perl_2.06-1_all.deb
Source Package libparanoid-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libparanoid-perl deb package:
    # sudo apt-get install libparanoid-perl

Files

Path
/usr/share/doc/libparanoid-perl/changelog.Debian.gz
/usr/share/doc/libparanoid-perl/changelog.gz
/usr/share/doc/libparanoid-perl/copyright
/usr/share/man/man3/Paranoid.3pm.gz
/usr/share/man/man3/Paranoid::Args.3pm.gz
/usr/share/man/man3/Paranoid::Data.3pm.gz
/usr/share/man/man3/Paranoid::Debug.3pm.gz
/usr/share/man/man3/Paranoid::Filesystem.3pm.gz
/usr/share/man/man3/Paranoid::Glob.3pm.gz
/usr/share/man/man3/Paranoid::IO.3pm.gz
/usr/share/man/man3/Paranoid::IO::Line.3pm.gz
/usr/share/man/man3/Paranoid::IO::Lockfile.3pm.gz
/usr/share/man/man3/Paranoid::Input.3pm.gz
/usr/share/man/man3/Paranoid::Log.3pm.gz
/usr/share/man/man3/Paranoid::Log::Buffer.3pm.gz
/usr/share/man/man3/Paranoid::Log::File.3pm.gz
/usr/share/man/man3/Paranoid::Module.3pm.gz
/usr/share/man/man3/Paranoid::Network.3pm.gz
/usr/share/man/man3/Paranoid::Network::IPv4.3pm.gz
/usr/share/man/man3/Paranoid::Network::IPv6.3pm.gz
/usr/share/man/man3/Paranoid::Network::Socket.3pm.gz
/usr/share/man/man3/Paranoid::Process.3pm.gz
/usr/share/perl5/Paranoid.pm
/usr/share/perl5/Paranoid/Args.pm
/usr/share/perl5/Paranoid/Data.pm
/usr/share/perl5/Paranoid/Debug.pm
/usr/share/perl5/Paranoid/Filesystem.pm
/usr/share/perl5/Paranoid/Glob.pm
/usr/share/perl5/Paranoid/IO.pm
/usr/share/perl5/Paranoid/Input.pm
/usr/share/perl5/Paranoid/Log.pm
/usr/share/perl5/Paranoid/Module.pm
/usr/share/perl5/Paranoid/Network.pm
/usr/share/perl5/Paranoid/Process.pm
/usr/share/perl5/Paranoid/IO/Line.pm
/usr/share/perl5/Paranoid/IO/Lockfile.pm
/usr/share/perl5/Paranoid/Log/Buffer.pm
/usr/share/perl5/Paranoid/Log/File.pm
/usr/share/perl5/Paranoid/Network/IPv4.pm
/usr/share/perl5/Paranoid/Network/IPv6.pm
/usr/share/perl5/Paranoid/Network/Socket.pm

Changelog

2018-11-09 - gregor herrmann <gregoa@debian.org>
libparanoid-perl (2.06-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* New upstream release.
* Drop fix-typo-in-manpage.patch, applied upstream.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.2.1.
2017-06-23 - gregor herrmann <gregoa@debian.org>
libparanoid-perl (2.05-2) unstable; urgency=medium
* Revert "Skip t/50_process.t during build and autopkgtest."
The issue is supposed to be fixed in the 2.05 release, according to
https://rt.cpan.org/Public/Bug/Display.html?id=119462 .
* Update years of packaging copyright.
2017-06-20 - Lucas Kanashiro <kanashiro@debian.org>
libparanoid-perl (2.05-1) unstable; urgency=medium
* Team upload.
* Import upstream version 2.05
* Update years of upstream copyright
* Update years of Debian packaging copyright
* Bump debhelper compatibility level to 10
* Declare compliance with Debian Policy 4.0.0
2016-12-25 - gregor herrmann <gregoa@debian.org>
libparanoid-perl (2.04-2) unstable; urgency=medium
* Skip t/50_process.t during build and autopkgtest. (Closes: #848266)
2016-10-31 - gregor herrmann <gregoa@debian.org>
libparanoid-perl (2.04-1) unstable; urgency=medium
* New upstream release.
* Update years of upstream and packaging copyright.
* Add more fixes to fix-typo-in-manpage.patch.
2016-08-27 - Lucas Kanashiro <kanashiro@debian.org>
libparanoid-perl (2.03-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Remove Jonathan Yu from Uploaders. Thanks for your work!
* Remove Ryan Niebur from Uploaders. Thanks for your work!
[ Lucas Kanashiro ]
* Import upstream version 2.03
* Remove patch fixing typo in manpages, applied by upstream
* Create a new patch fixing new typos in manpage
2016-06-29 - Lucas Kanashiro <kanashiro@debian.org>
libparanoid-perl (2.01-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Rename autopkgtest configuration file(s) as per new pkg-perl-
autopkgtest schema.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Lucas Kanashiro ]
* Add debian/upstream/metadata
* Import upstream version 2.01
* Remove patches, the patched files does not exist in latest release
* debian/tests: remove unexistent files from syntax-skip
* Update years of upstream copyright
* Update Debian packaging copyright
* Bump debhelper compatibility level to 9
* Declare compliance with Debian policy 3.9.8
* debian/control: update build and runtime dependencies, thanks cme
* Create patch to fix typo in manpage
2015-06-26 - gregor herrmann <gregoa@debian.org>
libparanoid-perl (0.36-3) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add build dependency on CGI.pm. Used in a test.
(Closes: #789848)
* Update years of packaging copyright.
* Mark package as autopkgtest-able.
* Declase compliance with Debian Policy 3.9.6.
* Update {versioned,alternative} (build) dependencies.
2014-06-13 - Axel Beckert <abe@debian.org>
libparanoid-perl (0.36-2) unstable; urgency=low
* Team upload
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Axel Beckert ]
* Add patch to no more use DB_CDB_ALLDB inside Paranoid::BerkeleyDB
+ Fixes FTBFS due to test-suite failures. (Closes: #743123)
* Bump Standards-Version to 3.9.5 (no changes)
2013-10-20 - Damyan Ivanov <dmn@debian.org>
libparanoid-perl (0.36-1) unstable; urgency=low
* Team upload
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Damyan Ivanov ]
* Imported Upstream version 0.36
* Claim conformance with Policy 3.9.4

See Also

Package Description
libparboiled-java_1.1.7-2_all.deb Parser library based on Parsing Expression Grammars (PEGs)
libpari-dev_2.11.1-2_i386.deb PARI/GP Computer Algebra System development files
libpari-gmp-tls6_2.11.1-2_i386.deb PARI/GP Computer Algebra System shared library
libparistraceroute-dev_0.93+git20160927-1_i386.deb network measurement tool library (development files)
libparistraceroute1_0.93+git20160927-1_i386.deb network measurement tool library
libparlatype-dev_1.5.6-1_i386.deb Library for Parlatype - development version
libparlatype-doc_1.5.6-1_all.deb Documentation files for the Parlatype library
libparlatype1_1.5.6-1_i386.deb Library for Parlatype - runtime version
libparmap-ocaml-dev_1.0~rc10-1_i386.deb small OCaml library allowing to exploit multicore architectures
libparmap-ocaml_1.0~rc10-1_i386.deb small OCaml library allowing to exploit multicore architectures
libparpack2-dev_3.7.0-2_i386.deb Parallel subroutines to solve large scale eigenvalue problems (development)
libparpack2_3.7.0-2_i386.deb Parallel subroutines to solve large scale eigenvalue problems
libparse-bbcode-perl_0.15-1_all.deb Perl module to parse BBCode and render it as HTML or text
libparse-binary-perl_0.11-1_all.deb Binary data structure parser
libparse-cpan-packages-perl_2.40-1_all.deb module to parse the CPAN Packages file
Advertisement
Advertisement