libpam-mount_2.16-9_i386.deb


Advertisement

Description

libpam-mount - PAM module that can mount volumes for a user session

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpam-mount_2.16-9_i386.deb
Package name libpam-mount
Package version 2.16
Package release 9
Package architecture i386
Package type deb
Category admin admin::filesystem implemented-in::c protocol::nfs protocol::smb role::shared-lib security::authentication
Homepage http://pam-mount.sourceforge.net/
License -
Maintainer Jochen Sprickerhof <jspricke@debian.org>
Download size 86.96 KB
Installed size 203.00 KB
This module is aimed at environments with central file servers that a
user wishes to mount on login and unmount on logout, such as
(semi-)diskless stations where many users can login.
The module also supports mounting local filesystems of any kind the
normal mount utility supports, with extra code to make sure certain
volumes are set up properly because often they need more than just a
mount call, such as encrypted volumes. This includes SMB/CIFS, FUSE,
dm-crypt and LUKS.

Alternatives

Package Version Architecture Repository
libpam-mount_2.16-9_amd64.deb 2.16 amd64 Debian Main
libpam-mount - - -

Requires

Name Value
libc6 >= 2.7
libcryptsetup12 >= 2:1.4
libhx28 >= 3.22
libmount1 >= 2.19.1
libpam-runtime -
libpam0g >= 0.99.7.1
libpcre2-8-0 >= 10.31
libssl1.1 >= 1.1.0
libxml2 >= 2.7.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpam-mount_2.16-9_i386.deb
Source Package libpam-mount

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpam-mount deb package:
    # sudo apt-get install libpam-mount

Files

Path
/etc/security/pam_mount.conf.xml
/etc/selinux/strict/src/policy/macros/pam_mount_macros.te
/lib/i386-linux-gnu/libcryptmount.so.0
/lib/i386-linux-gnu/libcryptmount.so.0.0.0
/lib/i386-linux-gnu/security/pam_mount.so
/usr/share/doc/libpam-mount/NEWS.Debian.gz
/usr/share/doc/libpam-mount/README.Debian
/usr/share/doc/libpam-mount/bugs.txt.gz
/usr/share/doc/libpam-mount/changelog.Debian.gz
/usr/share/doc/libpam-mount/changelog.gz
/usr/share/doc/libpam-mount/copyright
/usr/share/doc/libpam-mount/faq.txt.gz
/usr/share/doc/libpam-mount/options.txt
/usr/share/doc/libpam-mount/todo.txt
/usr/share/lintian/overrides/libpam-mount
/usr/share/man/man5/pam_mount.conf.5.gz
/usr/share/man/man8/pam_mount.8.gz
/usr/share/pam-configs/libpam-mount
/usr/share/xml/pam_mount/dtd/pam_mount.conf.xml.dtd

Changelog

2018-10-17 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-9) unstable; urgency=medium
* Add patch for pcr2 support (Closes: #911029) (LP: 1792544)
* Guard rmdir in postinst
2018-10-14 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-8) unstable; urgency=medium
* Move to libpcre2-dev (LP: 1792544)
2018-10-13 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-7) unstable; urgency=medium
[ Ondřej Nový ]
* d/changelog: Remove trailing whitespaces
[ Jochen Sprickerhof ]
* Update copyright and some cleanup
* Split package to make it multi arch friendly (Closes: #696012)
2018-09-30 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-6) unstable; urgency=medium
* Remove old pmt-ofl manpage
* Add patch for CRYPT_LUKS2
* Bump policy version (no changes)
* Rework packaging (Closes: #696012)
2018-04-12 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-5) unstable; urgency=medium
* Upload to unstable.
2018-04-01 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-4) experimental; urgency=medium
* Fix priority and dependencies (Fix lintian warnings)
* Update Vcs URLs to salsa.d.o
* Add R³
* http -> https
* Update policy and debhelper versions
* Remove .dirs, not needed
* Add patch for mount point comparison (Closes: #799752)
2017-06-26 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-3) unstable; urgency=medium
[ Jochen Sprickerhof ]
* Remove ancient config changes (not even needed for old-stable)
* Replace fd0ssh and ofl by new versions in hxtools
* Add patch to fix doc target.
Thanks to Felix Lechner (Closes: #856992)
* Add patch for luserconf outside home.
Thanks to Felix Lechner (Closes: #857244)
* Bump standards version and remove autogen
* Update NEWS file
* Really enable hardening
[ Trent W. Buck ]
* mount with NEW password after expired-password reset (Closes: #862225)
2016-12-25 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-2) unstable; urgency=medium
* Remove old and unavailable suggested packages (Closes: #774246)
* Fix xmllint call (Closes: #780378)
* Update standards version (no changes needed)
* Remove ancient dependency versions and conflicts
* Really set DEB_BUILD_MAINT_OPTIONS.
Thanks to Matthias Klose, Jeremy Bicha (Closes: #849306)
2016-11-18 - Jochen Sprickerhof <jspricke@debian.org>
libpam-mount (2.16-1) unstable; urgency=medium
* Update watch file
* New upstream version 2.16 (Closes: #828404, #768495)
* Update patches
* Add patch for array declaration
* New maintainer (Closes: #774991)
2016-09-27 - Mattia Rizzolo <mattia@debian.org>
libpam-mount (2.14-2) unstable; urgency=medium
* QA upload.
* Orphan the package, see #774991.
* Run wrap-and-sort -ast.
* d/rules: remove override_dh_builddeb, xz compression is now default.
* Bump debhelper compat level to 10.
* Stop using hardening-wrapper, make use of dpkg-buildflags with
DEB_BUILD_MAINT_OPTIONS=hardening=+all
instead.  Closes: #836635
* Add Vcs-* fields pointing to a collab-maint git repository-
* Remove obsolete lintian override to patch-system-but-direct-changes-in-diff.

See Also

Package Description
libpam-mysql_0.8.1-1+b1_i386.deb PAM module interfacing with MySQL databases
libpam-oath_2.6.1-1.3_i386.deb OATH Toolkit libpam_oath PAM module
libpam-ocaml-dev_1.1-5+b1_i386.deb OCaml bindings for the PAM library (development files)
libpam-ocaml_1.1-5+b1_i386.deb OCaml bindings for the PAM library (runtime)
libpam-otpw_1.5-2_i386.deb Use OTPW for PAM authentication
libpam-p11_0.2.0-2_i386.deb PAM module for using PKCS#11 smart cards
libpam-passwdqc_1.3.0-1+b1_i386.deb PAM module for password strength policy enforcement
libpam-pkcs11_0.6.9-3+b1_i386.deb Fully featured PAM module for using PKCS#11 smart cards
libpam-poldi_0.4.2+git20161115.553060d-1_i386.deb PAM module allowing authentication using a OpenPGP smartcard
libpam-pwdfile_1.0-1+b1_i386.deb PAM module allowing authentication via an /etc/passwd-like file
libpam-pwquality_1.4.0-3_i386.deb PAM module to check password strength
libpam-python-doc_1.0.6-1.1_all.deb Documentation for the bindings provided by libpam-python
libpam-python_1.0.6-1.1_i386.deb Enables PAM modules to be written in Python
libpam-radius-auth_1.4.0-2_i386.deb PAM RADIUS authentication module
libpam-runtime_1.3.1-5_all.deb Runtime support for the PAM library
Advertisement
Advertisement