libpam-mklocaluser_0.14_all.deb


Advertisement

Description

libpam-mklocaluser - Configure PAM to create a local user if it do not exist already

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libpam-mklocaluser_0.14_all.deb
Package name libpam-mklocaluser
Package version 0.14
Package release -
Package architecture all
Package type deb
Category misc
Homepage http://www.skolelinux.org/
License -
Maintainer Debian Edu Developers <debian-edu@lists.debian.org>
Download size 6.84 KB
Installed size 27.00 KB
When the user log in for the first time, a local user is created in
/etc/passwd and primary group created in /etc/group, and a local home
directory is created in /home.  This is useful on roaming computers when
the password is set up to be cached by for example libpam-ccreds or sssd
to allow login without network connectivity using the password provided
by a network authentication service like Kerberos or LDAP.

Alternatives

Package Version Architecture Repository
libpam-mklocaluser_0.14_all.deb 0.14 all Debian Main
libpam-mklocaluser - - -

Requires

Name Value
libpam-python -
python:any -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpam-mklocaluser_0.14_all.deb
Source Package libpam-mklocaluser

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpam-mklocaluser deb package:
    # sudo apt-get install libpam-mklocaluser

Files

Path
/usr/lib/libpam-mklocaluser/pam-python.py
/usr/share/doc/libpam-mklocaluser/changelog.gz
/usr/share/doc/libpam-mklocaluser/copyright
/usr/share/pam-configs/mklocaluser
/usr/share/python/runtime.d/libpam-mklocaluser.rtupdate

Changelog

2019-01-16 - Holger Levsen <holger@debian.org>
libpam-mklocaluser (0.14) unstable; urgency=medium
* Team upload.
* d/control:
- bump Standards-Version to 4.3.0, no changes needed.
- use canonical URL for Vcs-Git, thanks lintian.
2018-10-15 - Holger Levsen <holger@debian.org>
libpam-mklocaluser (0.13) unstable; urgency=medium
* Team upload.
[ Holger Levsen ]
* d/control:
- Bump debian/compat from 9 to 11.
- Use the new debhelper-compat(=11) notation and drop d/compat.
- Add "Rules-Requires-Root: no" to support building as non-root.
* Bump Standards-Version to 4.2.1, no changes needed.
* Add d/source/format documenting the use of source format 1.0.
* d/postinst and prerm: use 'set -e' in the script body, thanks lintian.
* d/copyright: Use https for copyright format URI.
2018-05-31 - Holger Levsen <holger@debian.org>
libpam-mklocaluser (0.12) unstable; urgency=medium
* Team upload.
[ Holger Levsen ]
* d/control:
- switch packaging to salsa.debian.org. Thanks to the alioth admins for
providing such a nice service so long!
- bump Standards-Version to 4.1.4, no changes needed.
2016-12-22 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.11) unstable; urgency=low
* Corrected dh invocation in d/rules.
* Moved from debhelper 7 to 9.
* Changed Standards-Version from 3.9.5 to 3.9.8.
* Removed Morten Werner Forsbring as uploader.  Thank you for all
your good work.
* Added copyright info to python code.
* Converted d/copyright to machine readable format.
* Document git tag format in d/gpb.conf.
2014-08-14 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.10) unstable; urgency=high
* Using urgency high to fix RC bug quickly.
* Make sure to add trailing newline when updating /etc/passwd and
/etc/shadow.  This is an RC bug blocking the package from working.
* Change priority from extra to optional to match the archive override
file.
* Switch from python-support to dh-python.
2014-06-09 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.9) unstable; urgency=low
* Update standard-version from 3.9.2 to 3.9.5.  No changes needed.
* Make PAM module more robust:
* Add to /etc/passwd and /etc/shadow using python code instead of
calling "echo 'something' >> /etc/file" in a subshell.
* Do not try to syslog an exception, as a string is needed in newer
python versions.
* Do not call chown -R, implement it in python instead.
* Correct test pam_handler function arguments and make it output
more info during testing.
* Make sure syslog message make it clear that both passwd and shadow
is updated by the module.
* Change priority from optional to extra, as it depend on libpam-python
which is priority extra, to avoid priority inversion.
* Source is moved to git.  Update Vcs-* control file fields.
2013-05-04 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.8) unstable; urgency=low
* Rewrite runcmd() to work with Python on Wheezy (Closes: #706753).
2013-05-04 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.8~deb7u1) wheezy; urgency=low
* Rewrite runcmd() to work with Python on Wheezy (Closes: #706753).
2011-07-28 - Petter Reinholdtsen <pere@debian.org>
libpam-mklocaluser (0.7) unstable; urgency=low
* Rewrite how Popen() is used to ensure the script wait for the
subprocesses to start before looking for their status (Closes:
#634829).  Patch from Wolfgang Schulze-Zachau.
* Update standards-version from 3.9.1 to 3.9.2.  No changes needed.

See Also

Package Description
libpam-modules-bin_1.3.1-5_i386.deb Pluggable Authentication Modules for PAM - helper binaries
libpam-modules_1.3.1-5_i386.deb Pluggable Authentication Modules for PAM
libpam-mount-bin_2.16-9_i386.deb PAM module that can mount volumes for a user session - helper
libpam-mount_2.16-9_i386.deb PAM module that can mount volumes for a user session
libpam-mysql_0.8.1-1+b1_i386.deb PAM module interfacing with MySQL databases
libpam-oath_2.6.1-1.3_i386.deb OATH Toolkit libpam_oath PAM module
libpam-ocaml-dev_1.1-5+b1_i386.deb OCaml bindings for the PAM library (development files)
libpam-ocaml_1.1-5+b1_i386.deb OCaml bindings for the PAM library (runtime)
libpam-otpw_1.5-2_i386.deb Use OTPW for PAM authentication
libpam-p11_0.2.0-2_i386.deb PAM module for using PKCS#11 smart cards
libpam-passwdqc_1.3.0-1+b1_i386.deb PAM module for password strength policy enforcement
libpam-pkcs11_0.6.9-3+b1_i386.deb Fully featured PAM module for using PKCS#11 smart cards
libpam-poldi_0.4.2+git20161115.553060d-1_i386.deb PAM module allowing authentication using a OpenPGP smartcard
libpam-pwdfile_1.0-1+b1_i386.deb PAM module allowing authentication via an /etc/passwd-like file
libpam-pwquality_1.4.0-3_i386.deb PAM module to check password strength
Advertisement
Advertisement