libouch-perl_0.0501-1_all.deb


Advertisement

Description

libouch-perl - exception handling module

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libouch-perl_0.0501-1_all.deb
Package name libouch-perl
Package version 0.0501
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Ouch
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 12.59 KB
Installed size 32.00 KB
The Ouch module ("exceptions that don't hurt") provides a class for exception
handling that doesn't require a lot of boilerplate, nor any up front
definition.  It is fast, easy to use, requires few typing, and has no prereqs,
but still provides much of that same functionality as e.g. Exception::Class.

Alternatives

Package Version Architecture Repository
libouch-perl_0.0501-1_all.deb 0.0501 all Debian Main
libouch-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libouch-perl_0.0501-1_all.deb
Source Package libouch-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libouch-perl deb package:
    # sudo apt-get install libouch-perl

Files

Path
/usr/share/doc/libouch-perl/changelog.Debian.gz
/usr/share/doc/libouch-perl/changelog.gz
/usr/share/doc/libouch-perl/copyright
/usr/share/man/man3/Ouch.3pm.gz
/usr/share/perl5/Ouch.pm

Changelog

2019-02-06 - gregor herrmann <gregoa@debian.org>
libouch-perl (0.0501-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* Import upstream version 0.0501.
* Update debian/upstream/metadata.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.3.0.
* Bump debhelper compatibility level to 11.
2018-01-02 - gregor herrmann <gregoa@debian.org>
libouch-perl (0.0500-1) unstable; urgency=medium
* Import upstream version 0.0500.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.1.3.
* Bump debhelper compatibility level to 10.
2016-10-31 - gregor herrmann <gregoa@debian.org>
libouch-perl (0.0410-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
* Import upstream version 0.0410.
* Update years of packaging copyright.
* Update build dependencies.
* Declare compliance with Debian Policy 3.9.8.
2015-05-30 - gregor herrmann <gregoa@debian.org>
libouch-perl (0.0409-2) unstable; urgency=medium
* Unconditionally build depend on libmodule-build-perl.
* Add debian/upstream/metadata.
* Update years of packaging copyright.
2015-04-30 - Axel Beckert <abe@debian.org>
libouch-perl (0.0409-1) unstable; urgency=medium
* Team upload
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Axel Beckert ]
* Import new upstream release
+ Add build-dependency on "libmodule-build-perl | perl (<< 5.21)"
* Declare compliance with Debian Policy 3.9.6 (no changes needed)
* Add "Testsuite: autopkgtest-pkg-perl" header.
2013-09-26 - Axel Beckert <abe@debian.org>
libouch-perl (0.0408-1) unstable; urgency=low
* Team upload
* New upstream release
2013-09-12 - Axel Beckert <abe@debian.org>
libouch-perl (0.0405-1) unstable; urgency=low
* Team upload
* New upstream release
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
* Bump Standards-Version to 3.9.4 (no changes)
* Bump debhelper compatibility to 9
+ Update versioned debhelper build-dependency accordingly
+ Gets rid of dh_pysupport deprecation warning.
2011-05-06 - gregor herrmann <gregoa@debian.org>
libouch-perl (0.0401-1) unstable; urgency=low
* New upstream release.
* Add new build dependency libtest-trap-perl.
2011-04-21 - gregor herrmann <gregoa@debian.org>
libouch-perl (0.0300-1) unstable; urgency=low
* Initial release (closes: #623530).

See Also

Package Description
libounit-ocaml-dev_2.0.8-1_i386.deb Unit testing framework for OCaml
libout123-0_1.25.10-2_i386.deb MPEG layer 1/2/3 audio decoder (libout123 shared library)
libow-3.2-3_3.2p3+dfsg1-2+b1_i386.deb 1-Wire File System full library
libow-dev_3.2p3+dfsg1-2+b1_i386.deb 1-Wire File System (development files)
libow-perl_3.2p3+dfsg1-2+b1_i386.deb Dallas 1-wire support: Perl5 bindings
libow-php7_3.2p3+dfsg1-2+b1_i386.deb Dallas 1-wire support: PHP5 bindings
libow-tcl_3.2p3+dfsg1-2+b1_i386.deb Dallas 1-wire support: Tcl bindings
libowasp-antisamy-java-doc_1.5.3+dfsg-1_all.deb Documentation for OWASP AntiSamy
libowasp-antisamy-java_1.5.3+dfsg-1_all.deb OWASP AntiSamy
libowasp-esapi-java-doc_2.1.0-3_all.deb Documentation for ESAPI
libowasp-esapi-java_2.1.0-3_all.deb Enterprise Security API (ESAPI)
libowasp-java-html-sanitizer-java-doc_0.1+r88-2_all.deb Documentation for OWASP Java HTML Sanitizer
libowasp-java-html-sanitizer-java_0.1+r88-2_all.deb OWASP Java HTML Sanitizer
libowcapi-3.2-3_3.2p3+dfsg1-2+b1_i386.deb 1-Wire File System C library
libowfat-dev_0.30-2_i386.deb Reimplementation of libdjb, development files
Advertisement
Advertisement