libosmonetif6_0.3.0-1_i386.deb


Advertisement

Description

libosmonetif6 - Common/shared code regarding network interface for OpenBSC

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libosmonetif6_0.3.0-1_i386.deb
Package name libosmonetif6
Package version 0.3.0
Package release 1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://git.osmocom.org/libosmo-netif/
License -
Maintainer Debian Mobcom Maintainers <Debian-mobcom-maintainers@lists.alioth.debian.org>
Download size 28.03 KB
Installed size 90.00 KB
The libosmo-netif library is one of the libraries needed by the
OpenBSC GSM infrastructure software. This library in particular implements
the shared code for network interfaces.

Alternatives

Package Version Architecture Repository
libosmonetif6_0.3.0-1_amd64.deb 0.3.0 amd64 Debian Main
libosmonetif6 - - -

Requires

Name Value
libc6 >= 2.4
libosmocore11 >= 0.11.0
libsctp1 >= 1.0.10+dfsg
libtalloc2 >= 2.0.4~git20101213

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libosmonetif6_0.3.0-1_i386.deb
Source Package libosmo-netif

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libosmonetif6 deb package:
    # sudo apt-get install libosmonetif6

Files

Path
/usr/lib/i386-linux-gnu/libosmonetif.so.6
/usr/lib/i386-linux-gnu/libosmonetif.so.6.0.0
/usr/share/doc/libosmonetif6/changelog.Debian.gz
/usr/share/doc/libosmonetif6/copyright

Changelog

2018-11-05 - Ruben Undheim <ruben.undheim@gmail.com>
libosmo-netif (0.3.0-1) unstable; urgency=low
* Upload to unstable
2018-08-29 - Ruben Undheim <ruben.undheim@gmail.com>
libosmo-netif (0.3.0-1~exp1) experimental; urgency=medium
* New upstream release
* libosmonetif4 -> libosmonetif6
* Removed commented out sections related to libosmonetif4-dbg
* Added debian/gbp.conf
* debian/rules:
- Do not use dpkg-parsechangelog anymore
2018-05-17 - Thorsten Alteholz <debian@alteholz.de>
libosmo-netif (0.2.0-1) experimental; urgency=medium
* New upstream release
* debian/control: adjust minimal needed version of dependencies
* debian/*symbols: update symbols file
2018-04-10 - Thorsten Alteholz <debian@alteholz.de>
libosmo-netif (0.1.1-2) unstable; urgency=medium
* move to unstable
* debian/control: add salsa URLs
* debian/control: use dh11
* debian/control: bump standard to 4.1.4 (no changes)
2017-11-29 - Thorsten Alteholz <debian@alteholz.de>
libosmo-netif (0.1.1-1) experimental; urgency=medium
* New upstream release
* bump SONAME
2017-09-11 - Thorsten Alteholz <debian@alteholz.de>
libosmo-netif (0.0.6-2) unstable; urgency=low
* debian/control: add myself to uploaders
* debian/control: move package to debian-mobcom and change URLs
* debian/control: change maintainer to debian-mobcom-maintainers
* debian/control: use dh10
* debian/control: bump standard to 4.1.0 (no changes)
* debian/control: remove dbg package
* debian/control: remove redundant dependency of dh-autoreconf
2015-12-13 - Ruben Undheim <ruben.undheim@gmail.com>
libosmo-netif (0.0.6-1) unstable; urgency=low
* Initial release (Closes: #806585)

See Also

Package Description
libosmosccp0_0.10.0-4_i386.deb Library for Signalling Connection Control Part (SCCP)
libosmosdr-dev_0.1.8.effcaa7-7+b1_i386.deb Software defined radio support for OsmoSDR hardware (development files)
libosmosdr0_0.1.8.effcaa7-7+b1_i386.deb Software defined radio support for OsmoSDR hardware (library)
libosmosim0_0.12.1-2_i386.deb Osmo SIM library
libosmotrau2_0.5.1-1_i386.deb GSM trau handling
libosmovty-doc_0.12.1-2_all.deb Documentation for the Osmo VTY library
libosmovty4_0.12.1-2_i386.deb Osmo VTY library
libosmoxua0_0.10.0-4_i386.deb Osmocom SCCP support library for generating and parsing messages
libosmpbf-dev_1.3.3-11+deb10u1_i386.deb C headers for OpenStreetMap PBF file format
libosmpbf-java_1.3.3-11+deb10u1_all.deb Java access library for OpenStreetMap PBF file format
libosmvendor4_3.3.21-2_i386.deb InfiniBand subnet manager - vendor library
libosp-dev_1.5.2-13+b1_i386.deb OpenJade group's SP suite, developer support
libosp5_1.5.2-13+b1_i386.deb Runtime library for OpenJade group's SP suite
libosptk-dev_4.13.0-1_i386.deb OSP Toolkit development library and header files
libosptk4_4.13.0-1_i386.deb OSP Toolkit shared library
Advertisement
Advertisement