libosinfo-bin_1.2.0-1_i386.deb


Advertisement

Description

libosinfo-bin - Tools for querying the osinfo database via libosinfo

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libosinfo-bin_1.2.0-1_i386.deb
Package name libosinfo-bin
Package version 1.2.0
Package release 1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://libosinfo.org/
License -
Maintainer Guido Günther <agx@sigxcpu.org>
Download size 110.61 KB
Installed size 169.00 KB
libosinfo is a GObject based library API for managing information about
operating systems, hypervisors and the (virtual) hardware devices they
can support. It includes a database containing device metadata and
provides APIs to match/identify optimal devices for deploying an
operating system on a hypervisor.
This package contains the runtime files to detect operating systems and query
the database.

Alternatives

Package Version Architecture Repository
libosinfo-bin_1.2.0-1_amd64.deb 1.2.0 amd64 Debian Main
libosinfo-bin - - -

Requires

Name Value
libc6 >= 2.4
libglib2.0-0 >= 2.16.0
libosinfo-1.0-0 >= 0.2.12~
libxml2 >= 2.6.27
libxslt1.1 >= 1.1.25

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libosinfo-bin_1.2.0-1_i386.deb
Source Package libosinfo

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libosinfo-bin deb package:
    # sudo apt-get install libosinfo-bin

Files

Path
/usr/bin/osinfo-detect
/usr/bin/osinfo-install-script
/usr/bin/osinfo-query
/usr/share/doc/libosinfo-bin/changelog.Debian.gz
/usr/share/doc/libosinfo-bin/changelog.gz
/usr/share/doc/libosinfo-bin/copyright
/usr/share/man/man1/osinfo-detect.1.gz
/usr/share/man/man1/osinfo-install-script.1.gz
/usr/share/man/man1/osinfo-query.1.gz

Changelog

2018-09-17 - Guido Günther <agx@sigxcpu.org>
libosinfo (1.2.0-1) unstable; urgency=medium
* d/control: swith VCS-* URLs to salsa
* New upstream version (Closes: #908983)
* d/control: Drop build-dep libsoup-gnome-2.4.
Thanks to Jeremy Bicha
* d/control: Switch to priority optional
* d/copyright: Avoid duplicate license paragraph
* d/control: Bump standards version
* debian/copyright: Fix upstream URL.
Project moved to gitlab.
Thanks to Jeremy Bicha
* d/control: Move l10n package to localization section
2017-08-19 - Guido Günther <agx@sigxcpu.org>
libosinfo (1.1.0-1) unstable; urgency=medium
* [349b18f] Upstream moved from fedorahosted to pagure
* [0dfd210] Use vcs-upstream-tag
* [4921ed0] libtool is sufficient no need for libtool-bin.
Thanks to Helmut Grohne (Closes: #871703)
* [c501be8] Drop loader-Fix-typo-in-error-message.patch: applied upstream
* [911d9a3] Bump sumbols
* [764448c] Bump standards version
2016-11-05 - Guido Günther <agx@sigxcpu.org>
libosinfo (1.0.0-2) unstable; urgency=medium
* Upload to unstable
* [292a8ab] Fix Breaks/Replaces.
Thanks to Andreas Beckmann (Closes: #842060)
* [a979083] Re-enable test suite.  We have osinfo-db in the archive now. Add
necessary build-deps for that.
* [059a0b6] Turn on all hardening flags
* [1b3d04b] loader: Fix typo in error message
* [e5e2fb8] d/control: Improve description a bit
2016-10-20 - Guido Günther <agx@sigxcpu.org>
libosinfo (1.0.0-1) experimental; urgency=medium
* [ec1ceb9] New upstream version 1.0.0
* [49b298c] Update README.source
* [aa221ba] Drop libosinfo-db package and use the now split out osinfo-db
* [de23113] Disable internal test suite until we have osinfo-db in the
archive
2016-07-14 - Guido Günther <agx@sigxcpu.org>
libosinfo (0.3.1-5) unstable; urgency=medium
* [93359f7] Fix a typo in the replaces line.
Thanks to Andreas Beckmann (Closes: #829422)
2016-07-05 - Guido Günther <agx@sigxcpu.org>
libosinfo (0.3.1-4) unstable; urgency=medium
[ Jeremy Bicha ]
* [a9141ff] Have build-test autopkgtest depend on build-essential
* [d762ae0] Have libosinfo-dev depend on libglib2.0-dev (Closes: #829639)
* [2457cbb] Point Vcs-Browser to cgit
2016-07-03 - Guido Günther <agx@sigxcpu.org>
libosinfo (0.3.1-3) unstable; urgency=medium
* [070f0f7] Unbreak build on arch != amd64.
The hardcoded path is no good if we use dh_install --fail-missing
afterwards. (Closes: #829495)
2016-07-03 - Guido Günther <agx@sigxcpu.org>
libosinfo (0.3.1-2) unstable; urgency=medium
[ Michael Biebl ]
* [e95a02d] Move Breaks/Replaces to libosinfo-db (Closes: #829423)
[ Guido Günther ]
* [5418a86] programs and tests are GPLv2 licensed
* [5ea9df4] Bump debhelper dependency to 9 to multiarch
* [1448876] Make libosinfo-db arch any
2016-07-01 - Guido Günther <agx@sigxcpu.org>
libosinfo (0.3.1-1) unstable; urgency=medium
* [9abe446] New upstream version 0.3.1
* [871f311] watch: Add signature verifiation
* [1991a68] Switch back to tarballs
2016-05-27 - Guido Günther <agx@sigxcpu.org>
libosinfo (0.3.0-3) unstable; urgency=medium
* [a9a31e7] Move database files into separate package and install
translations (Closes: #825009)
* [a3c4034] Fail if we don't install all files

See Also

Package Description
libosinfo-l10n_1.2.0-1_all.deb Translations for libosinfo
libosip2-11_4.1.0-2.1_i386.deb Session Initiation Protocol (SIP) library
libosip2-dev_4.1.0-2.1_i386.deb development files for the SIP library
libosm-gary68-perl_0.0~svn26727-4_all.deb OpenStreetMap Perl modules by gary68
libosmcomp4_3.3.21-2_i386.deb InfiniBand subnet manager - component library
libosmesa6-dev_18.3.6-2_i386.deb Mesa Off-screen rendering extension -- development files
libosmesa6_18.3.6-2_i386.deb Mesa Off-screen rendering extension
libosmgpsmap-1.0-1_1.1.0-5_i386.deb GTK+ library to embed OpenStreetMap maps
libosmgpsmap-1.0-dev_1.1.0-5_i386.deb GTK+ library to embed OpenStreetMap maps - development files
libosmium2-dev_2.15.1-1_i386.deb C++ framework for working with OSM data files
libosmium2-doc_2.15.1-1_all.deb C++ framework for working with OSM data files - documentation
libosmo-abis-dev_0.5.1-1_i386.deb Development headers for A-bis interface
libosmo-fl2k-dev_0.1.0+20180423git9e79bde-2_i386.deb use a VGA USB adapter as DAC and SDR transmitter - development
libosmo-fl2k0_0.1.0+20180423git9e79bde-2_i386.deb use a VGA USB adapter as DAC and SDR transmitter - library
libosmo-legacy-mgcp-dev_1.4.0-1_i386.deb Osmocom's Legacy Media Gateway server library - development files
Advertisement
Advertisement