libopkele3v5_2.0.4+git20140305.9651b55-4_i386.deb


Advertisement

Description

libopkele3v5 - OpenID support library in C++ (runtime)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libopkele3v5_2.0.4+git20140305.9651b55-4_i386.deb
Package name libopkele3v5
Package version 2.0.4+git20140305.9651b55
Package release 4
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://kin.klever.net/libopkele/
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 104.74 KB
Installed size 322.00 KB
libopkele is a C++ implementation of an OpenID decentralized identity
system.  It provides OpenID protocol handling, leaving authentication
and user interaction to the implementor.
This package provides its shared library.

Alternatives

Package Version Architecture Repository
libopkele3v5_2.0.4+git20140305.9651b55-4_amd64.deb 2.0.4+git20140305.9651b55 amd64 Debian Main
libopkele3v5 - - -

Requires

Name Value
libc6 >= 2.4
libcurl3-gnutls >= 7.16.2
libexpat1 >= 2.0.1
libgcc1 >= 1:3.0
libssl1.1 >= 1.1.0
libstdc++6 >= 5.2
libtidy5deb1 >= 1:5.2.0

Conflicts

Name Value
libopkele3 -

Replaces

Name Value
libopkele3 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libopkele3v5_2.0.4+git20140305.9651b55-4_i386.deb
Source Package libopkele

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libopkele3v5 deb package:
    # sudo apt-get install libopkele3v5

Files

Path
/usr/lib/i386-linux-gnu/libopkele.so.3
/usr/lib/i386-linux-gnu/libopkele.so.3.0.0
/usr/share/doc/libopkele3v5/changelog.Debian.gz
/usr/share/doc/libopkele3v5/copyright

Changelog

2018-10-28 - Boyuan Yang <byang@debian.org>
libopkele (2.0.4+git20140305.9651b55-4) unstable; urgency=medium
* QA upload.
* Orhpan the package as requested by previous maintainer.
* Rebuild package against gcc 8.2.
* debian: Apply "wrap-and-sort -abst".
* debian/control:
+ Set maintainer to Debian QA group.
+ Set package priority to optional. (Closes: #910975)
+ Bump debhelper compat to v11.
+ Bump Standards-Version to 4.2.1.
+ Update Vcs-* fields and use repo under Salsa Debian Group.
+ Update description to fix lintian warnings.
* debian/gbp.conf: Update config to fit current status.
* debian/rules: Modernize packaging and use "dh_missing --fail-missing".
2016-11-08 - NIIBE Yutaka <gniibe@fsij.org>
libopkele (2.0.4+git20140305.9651b55-3) unstable; urgency=medium
* debian/control (Build-Depends): Require xsltproc.
2016-11-08 - NIIBE Yutaka <gniibe@fsij.org>
libopkele (2.0.4+git20140305.9651b55-2) unstable; urgency=medium
* debian/control (Build-Depends): Require newer libssl-dev of 1.1.0b.
Also assume newer debhelper >= 10 for autoreconf.  Don't require quilt
any more.
(Standards-Version): Conforms 3.9.8.
(Multi-Arch): Add for libopkele-dev.
* debian/rules: No quilt, no autoreconf, as it's assumed.
* debian/compat: Assume compatibility level 10.
2016-06-29 - NIIBE Yutaka <gniibe@fsij.org>
libopkele (2.0.4+git20140305.9651b55-1) unstable; urgency=medium
* New upstream from git repo.
* Incorporate NMU (Closes: #795578).
* debian/patches/fix-openssl-1.1.0.diff: New (Closes: #828403).
2015-08-15 - Sebastian Ramacher <sramacher@debian.org>
libopkele (2.0.4-8.1) unstable; urgency=medium
* Non-maintainer upload.
[ Steve Langasek ]
* Rename library packages for g++5 ABI transition.
2014-06-02 - NIIBE Yutaka <gniibe@fsij.org>
libopkele (2.0.4-8) unstable; urgency=medium
* debian/rules: Add autoreconf option.  Thanks to Matthias Klose and
Logan Rosen (Closes: #727428).
* debian/control (Build-Depends): Remove autotools-dev.  Add
dh-autoreconf.
* debian/patches/fix-ftbfs-gcc4.9.diff: New.  Thanks to Matthias Klose
(Closes: #746872).
2014-05-27 - NIIBE Yutaka <gniibe@fsij.org>
libopkele (2.0.4-7) unstable; urgency=medium
* debian/config (Build-Depends): Add pkg-config (Closes: #747783).
Thanks to Hideki and David Suárez.
2013-07-08 - NIIBE Yutaka <gniibe@fsij.org>
libopkele (2.0.4-6) unstable; urgency=low
* Incorporate NMU (Closes: #629324).
* debian/compat: Require 9.
* debian/control (Build-Depends): Require debhelper >= 9.
(Standards-Version): Conforms to 3.9.4.
[libopkele3] (Multi-Arch, Pre-Depends): Add.
* debian/{libopkele-dev.install,libopkele3.install): Multi-arch support.
* debian/patches/fix-ftbfs-gcc4.7.diff: New in 2.0.4-5.3.
2012-04-17 - Matthias Klose <doko@debian.org>
libopkele (2.0.4-5.3) unstable; urgency=low
* Non maintainer upload.
* Fix build failure with GCC 4.7. Closes: #667253.
2011-06-10 - Luk Claes <luk@debian.org>
libopkele (2.0.4-5.2) unstable; urgency=low
* Non-maintainer upload.
* Don't ship symbol files (Closes: #618243).
* Don't depend on a specific libstdc++.

See Also

Package Description
libopsin-java-doc_2.3.1-1_all.deb Chemical name to structure converter (documentation)
libopsin-java_2.3.1-1_all.deb Chemical name to structure converter
liboptcomp-camlp4-dev_1.6-2+b1_i386.deb syntax extension for optional compilation with cpp-like directives (library)
liboptions-java-doc_0.0.20120113-3_all.deb command line option parsing library for Java (documentation)
liboptions-java_0.0.20120113-3_all.deb command line option parsing library for Java
libopts25-dev_5.18.12-4_i386.deb automated option processing library based on autogen
libopts25_5.18.12-4_i386.deb automated option processing library based on autogen
libopus-dev_1.3-1_i386.deb Opus codec library development files
libopus-doc_1.3-1_all.deb libopus API documentation
libopus-ocaml-dev_0.1.2-2_i386.deb OCaml interface to the opus library -- development files
libopus-ocaml_0.1.2-2_i386.deb OCaml interface to the opus library -- runtime files
libopus0_1.3-1_i386.deb Opus codec runtime library
libopusfile-dev_0.9+20170913-1_i386.deb High-level API for basic manipulation of Ogg Opus audio streams
libopusfile-doc_0.9+20170913-1_all.deb libopusfile API documentation
libopusfile0_0.9+20170913-1_i386.deb High-level API for basic manipulation of Ogg Opus audio streams
Advertisement
Advertisement