libofx7_0.9.14-1_i386.deb


Advertisement

Description

libofx7 - library to support the Open Financial Exchange format

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libofx7_0.9.14-1_i386.deb
Package name libofx7
Package version 0.9.14
Package release 1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://github.com/libofx/libofx
License -
Maintainer Dylan Aïssi <daissi@debian.org>
Download size 145.92 KB
Installed size 609.00 KB
Open Financial Exchange is an open standard for exchanging financial
information. Using this library a program can enable support for
common financial transactions such as bill payment, accessing account
information and investment tracking.

Alternatives

Package Version Architecture Repository
libofx7_0.9.14-1_amd64.deb 0.9.14 amd64 Debian Main
libofx7 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libosp5 >= 1.5.2-1
libstdc++6 >= 5.2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libofx7_0.9.14-1_i386.deb
Source Package libofx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libofx7 deb package:
    # sudo apt-get install libofx7

Files

Path
/usr/lib/i386-linux-gnu/libofx.so.7
/usr/lib/i386-linux-gnu/libofx.so.7.0.2
/usr/share/doc/libofx7/AUTHORS
/usr/share/doc/libofx7/NEWS.gz
/usr/share/doc/libofx7/README.gz
/usr/share/doc/libofx7/changelog.Debian.gz
/usr/share/doc/libofx7/changelog.gz
/usr/share/doc/libofx7/copyright
/usr/share/doc/libofx7/totest.txt
/usr/share/libofx7/libofx/dtd/ofc.dtd
/usr/share/libofx7/libofx/dtd/ofx160.dtd
/usr/share/libofx7/libofx/dtd/ofx201.dtd
/usr/share/libofx7/libofx/dtd/opensp.dcl

Changelog

2019-02-13 - Dylan Aïssi <daissi@debian.org>
libofx (1:0.9.14-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
[ Dylan Aïssi ]
* New upstream release.
* Bump Standards-Version: 4.3.0 (no changes needed).
* Bump debhelper compat 12.
2018-05-08 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.13-2) unstable; urgency=medium
* Update autopkgtest to reflect that the sample files
moved in another folder (Closes: #898212).
2018-05-06 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.13-1) unstable; urgency=medium
* New upstream release.
* Drop all patches not needed anymore.
* Update Vcs fields to salsa.debian.org.
* Bump Standards-Version: 4.1.4 (no changes needed).
* Remove useless debian/missing-sources folder.
* Bump debhelper compat 11.
* Documentation is now installed into usr/share/doc/libofx-dev/
* Remove Conflicts with libofx1 which disappeared more than 10 years ago.
* Remove useless Pre-Depends for libofx7.
2017-11-28 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.12-1) unstable; urgency=medium
* New upstream release.
- Switch to cleaner tarball from GitHub.
* Drop patches applied upstream.
* Add doxygen to Build-Dep and update d/rules.
* Remove Depends: libjs-jquery.
- For more information see: /usr/share/doc/doxygen/README.jquery.
* Add upstream patches to fix some crashes (Closes: #716625).
2017-11-01 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.11-5) unstable; urgency=high
* Add an upstream patch to fix CVE-2017-14731 (Closes: #877442).
* cme fix dpkg-control.
* Remove trailing whitespace characters in d/changelog.
* Bump Standards-Version: 4.1.1 (no changes needed).
2017-09-17 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.11-4) unstable; urgency=medium
* Add an upstream patch to fix CVE-2017-2816 (Closes: #875801).
2017-07-23 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.11-3) unstable; urgency=medium
* Fix tests: remove ofxdump for testing libofx.
Many messages are sent to stderr.
2017-07-15 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.11-2) unstable; urgency=medium
* Switch homepage from SourceForge to GitHub. (Closes: #852209)
* Add an autopkgtest test.
* Bump Standards-Version: 4.0.0 (no changes needed).
* Upload to unstable.
2017-01-17 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.11-1) experimental; urgency=medium
* New upstream release.
* Bump SONAME to libofx7.
* Update watch file to target GitHub instead SourceForge.
* Remove the override_dh_strip field, not needed anymore.
2017-01-11 - Dylan Aïssi <bob.dybian@gmail.com>
libofx (1:0.9.10-2) unstable; urgency=medium
* Adopt the package. (Closes: #815259)
* Standards-Version: 3.9.8 (no changes needed).
* Update VCS fields.
* Remove unused lintian override.
* Add "Multi-Arch: foreign" for the libofx-doc package.
* Add a patch to fix spelling error.
* Bump watch file to v4.
* Bump debhelper compat 10.
* Switch to automatic dbgsym package.
* Move the package ofx in the section utils.
* Set all hardening options.

See Also

Package Description
libogdi3.2-dev_3.2.1+ds-4_i386.deb Open Geographic Datastore Interface Library -- development
libogdi3.2_3.2.1+ds-4_i386.deb Open Geographic Datastore Interface Library -- library
libogg-dev_1.3.2-1+b1_i386.deb Ogg bitstream library development files
libogg-ocaml-dev_0.5.2-1_i386.deb OCaml bindings for the Ogg bitstream library
libogg-ocaml_0.5.2-1_i386.deb OCaml bindings for the Ogg bitstream library
libogg-vorbis-decoder-perl_0.9-3+b5_i386.deb module for decoding Ogg Vorbis streams
libogg-vorbis-header-pureperl-perl_1.0-4_all.deb pure Perl interface to Ogg Vorbis information fields
libogg0_1.3.2-1+b1_i386.deb Ogg bitstream library
liboggkate-dev_0.4.1-9_i386.deb Codec for karaoke and text encapsulation for Ogg (dev)
liboggkate1_0.4.1-9_i386.deb Codec for karaoke and text encapsulation for Ogg
liboggplay1-dev_0.2.1~git20091227-5_i386.deb Library for playing OGG multimedia (development files)
liboggplay1_0.2.1~git20091227-5_i386.deb Library for playing OGG multimedia
liboggz2-dev_1.1.1-7_i386.deb convenience interface for Ogg stream I/O (development files)
liboggz2_1.1.1-7_i386.deb convenience interface for Ogg stream I/O
liboglappth-dev_1.0.0-2_i386.deb Oglappth Library (development files)
Advertisement
Advertisement