libnotify-dev_0.7.7-4_i386.deb


Advertisement

Description

libnotify-dev - sends desktop notifications to a notification daemon (Development files)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libnotify-dev_0.7.7-4_i386.deb
Package name libnotify-dev
Package version 0.7.7
Package release 4
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage -
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 31.19 KB
Installed size 116.00 KB
A library that sends desktop notifications to a notification daemon, as
defined in the Desktop Notifications spec. These notifications can be
used to inform the user about an event or display some form of
information without getting in the user's way.
This package contains the include files and static library.

Alternatives

Package Version Architecture Repository
libnotify-dev_0.7.7-4_amd64.deb 0.7.7 amd64 Debian Main
libnotify-dev - - -

Requires

Name Value
gir1.2-notify-0.7 = 0.7.7-4
libgdk-pixbuf2.0-dev -
libglib2.0-dev >= 2.26
libnotify4 = 0.7.7-4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnotify-dev_0.7.7-4_i386.deb
Source Package libnotify

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnotify-dev deb package:
    # sudo apt-get install libnotify-dev

Files

Path
/usr/include/libnotify/notification.h
/usr/include/libnotify/notify-enum-types.h
/usr/include/libnotify/notify-features.h
/usr/include/libnotify/notify.h
/usr/lib/i386-linux-gnu/libnotify.a
/usr/lib/i386-linux-gnu/libnotify.so
/usr/lib/i386-linux-gnu/pkgconfig/libnotify.pc
/usr/share/doc/libnotify-dev/changelog.Debian.gz
/usr/share/doc/libnotify-dev/changelog.gz
/usr/share/doc/libnotify-dev/copyright
/usr/share/gir-1.0/Notify-0.7.gir

Changelog

2018-12-28 - Jeremy Bicha <jbicha@debian.org>
libnotify (0.7.7-4) unstable; urgency=medium
* Update Vcs fields for migration to https://salsa.debian.org/
* Bump Standards-Version to 4.3.0
2017-12-18 - Jeremy Bicha <jbicha@debian.org>
libnotify (0.7.7-3) unstable; urgency=medium
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
* Bump Standards-Version to 4.1.2
* Bump debhelper compat to 11
* Build with all hardening flags
2017-04-20 - Emilio Pozuelo Monfort <pochu@debian.org>
libnotify (0.7.7-2) unstable; urgency=medium
* Enable the gir dh addon so the gir package gets the proper dependencies.
(Closes: #860468)
2016-10-14 - Michael Biebl <biebl@debian.org>
libnotify (0.7.7-1) unstable; urgency=medium
[ Dmitry Shachnev ]
* Add missing xauth dependency for autopkgtest. (Closes: #757713)
[ Sebastien Bacher ]
* debian/notify-end.1: "Makes clear that -t/--expire-time is ignored
by Notify OSD and GNOME Shell", thanks Matthew Paul Thomas (LP: #533631)
[ Michael Biebl ]
* New upstream release.
* Fix typo in notify-send man page. (Closes: #657999)
* Use dbus-run-session to run tests. (Closes: #836028)
* Convert from cdbs to dh.
* Bump debhelper compat level to 10.
* Bump Standards-Version to 3.9.8.
* Install gir files into multiarch paths.
* Mark gir1.2-notify-0.7 and libnotify-dev as Multi-Arch: same and
libnotify-doc as Multi-Arch: foreign.
2014-02-21 - Martin Pitt <mpitt@debian.org>
libnotify (0.7.6-2) unstable; urgency=medium
* Add missing build-essential test dependency.
* Bump Standards-Version to 3.9.5. No changes necessary.
* Use dh-autoreconf to update libtool.m4 for new ports. Thanks Colin Watson!
(Closes: #732303)
2013-09-05 - Michael Biebl <biebl@debian.org>
libnotify (0.7.6-1) unstable; urgency=low
* New upstream release.
* Bump Standards-Version to 3.9.4. No further changes.
* Use canonical Vcs-* URLs.
* Drop explicit Build-Depends on gir1.2-glib-2.0.
2013-02-19 - Martin Pitt <mpitt@debian.org>
libnotify (0.7.5-2) unstable; urgency=low
* Add compile/link/run autopkgtest. Thanks to Vibhav Pant
<vibhavp@ubuntu.com> for this!
2012-03-27 - Michael Biebl <biebl@debian.org>
libnotify (0.7.5-1) unstable; urgency=low
[ Michael Biebl ]
* Change section of gir1.2-notify-0.7 to introspection.
* debian/watch: Track .xz tarballs.
[ Josselin Mouette ]
* Update repository URL.
[ Michael Biebl ]
* New upstream release.
* debian/patches/99_ltmain_as-needed.patch: Removed, no longer necessary.
* debian/rules: Remove clean-la.mk since we don't install any libtool .la
files anymore.
* Drop Depends on libdbus-glib-1-dev from libnotify-dev.
* Add explicit Build-Depends on libgdk-pixbuf2.0-dev.
2011-09-02 - Martin Pitt <mpitt@debian.org>
libnotify (0.7.4-1) unstable; urgency=low
[ Laurent Bigonville ]
* Follow multi-arch specification
* debian/control.in:
- Bump cdbs and debhelper build-dependencies
- Add Multi-Arch and Pre-Depends fields
* debian/rules:
- Pass multi-arch compatible path to libdir
* debian/*.install:
- Adjust for multi-arch paths
- Drop "debian/tmp" from paths
* debian/libnotify-dev.install:
- Drop .la file, no other package is referencing it anymore
[ Martin Pitt ]
* New upstream bug fix release.
2011-07-31 - Laurent Bigonville <bigon@debian.org>
libnotify (0.7.3-2) unstable; urgency=low
* debian/control.in:
- Remove duplicates Section to please lintian
- Fix duplicate Description to please lintian
* debian/rules: Drop include of check-dist.mk
* debian/watch:
- Switch to .bz2 tarballs.

See Also

Package Description
libnotify-doc_0.7.7-4_all.deb sends desktop notifications to a notification daemon (Documentation)
libnotify0.4-cil_0.4.0~r3032-7_all.deb CLI library for desktop notifications
libnotify3.0-cil-dev_3.0.3-3_all.deb CLI library for desktop notifications
libnotify3.0-cil_3.0.3-3_all.deb CLI library for desktop notifications
libnotify4_0.7.7-4_i386.deb sends desktop notifications to a notification daemon
libnotmuch-dev_0.28.4-1_i386.deb thread-based email index, search and tagging (development)
libnotmuch5_0.28.4-1_i386.deb thread-based email index, search and tagging (runtime)
libnova-0.16-0_0.16-4_i386.deb celestial mechanics, astrometry and astrodynamics library
libnova-dev-bin_0.16-4_i386.deb development config tool for libnova astronomical library
libnova-dev_0.16-4_i386.deb development files for libnova astronomical library
libnozzle-dev_1.8-2_i386.deb userland wrapper around kernel tap devices (developer files)
libnozzle1_1.8-2_i386.deb userland wrapper around kernel tap devices
libnproc-ocaml-dev_0.5.1-2+b4_i386.deb process pool implementation for OCaml
libnpth-mingw-w64-dev_1.6-1_all.deb replacement for GNU Pth using system threads (Windows dev)
libnpth0-dev_1.6-1_i386.deb headers for libnpth0
Advertisement
Advertisement