libnm0_1.14.6-2_i386.deb


Advertisement

Description

libnm0 - GObject-based client library for NetworkManager

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libnm0_1.14.6-2_i386.deb
Package name libnm0
Package version 1.14.6
Package release 2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://wiki.gnome.org/Projects/NetworkManager
License -
Maintainer Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>
Download size 374.21 KB
Installed size 1.39 MB
NetworkManager is a system network service that manages your network devices
and connections, attempting to keep active network connectivity when
available. It manages ethernet, WiFi, mobile broadband (WWAN), and PPPoE
devices, and provides VPN integration with a variety of different VPN
services.
This package contains a convenience library to ease the access to
NetworkManager.

Alternatives

Package Version Architecture Repository
libnm0_1.14.6-2_amd64.deb 1.14.6 amd64 Debian Main
libnm0 - - -

Requires

Name Value
libc6 >= 2.28
libglib2.0-0 >= 2.43.2
libgnutls30 >= 3.6.5
libudev1 >= 183
libuuid1 >= 2.16

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnm0_1.14.6-2_i386.deb
Source Package network-manager

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnm0 deb package:
    # sudo apt-get install libnm0

Files

Path
/usr/lib/i386-linux-gnu/libnm.so.0
/usr/lib/i386-linux-gnu/libnm.so.0.1.0
/usr/share/doc/libnm0/changelog.Debian.gz
/usr/share/doc/libnm0/changelog.gz
/usr/share/doc/libnm0/copyright

Changelog

2019-02-26 - Michael Biebl <biebl@debian.org>
network-manager (1.14.6-2) unstable; urgency=medium
* supplicant: fix setting pmf when the supplicant doesn't advertise support
2019-02-26 - Michael Biebl <biebl@debian.org>
network-manager (1.14.6-1) unstable; urgency=medium
* New upstream version 1.14.6
* Use debhelper-compat (= 12) Build-Depends and drop debian/compat
* Rebase patches
* Do not manage Docker bridge interfaces (Closes: #875127)
* Bump Standards-Version to 4.3.0
2018-11-27 - Michael Biebl <biebl@debian.org>
network-manager (1.14.4-4) unstable; urgency=medium
* Move D-Bus policy files to /usr/share/dbus-1/system.d/
* Remove obsolete D-Bus policy conffiles on upgrades
2018-11-05 - Michael Biebl <biebl@debian.org>
network-manager (1.14.4-3) unstable; urgency=medium
* cli: wait for all wifi scans to finish before displaying the result.
Otherwise devices are displayed in an inconsistent order.
Replaces debian/patches/Ignore-client-tests-failures.patch.
2018-10-30 - Michael Biebl <biebl@debian.org>
network-manager (1.14.4-2) unstable; urgency=high
* dhcp6: Make sure we have enough space for the DHCP6 option header.
Fixes out-of-bounds heap write in systemd-networkd dhcpv6 option handling
which also affects the "internal" DHCP plugin of NetworkManager.
(CVE-2018-15688, LP: #1795921)
2018-10-25 - Michael Biebl <biebl@debian.org>
network-manager (1.14.4-1) unstable; urgency=medium
* New upstream version 1.14.4
- Fix a crash in ifupdown (Debian) configuration plugin (Closes: #911621)
* Switch to debhelper compat level 12 and dh_installsystemd
* Update symbols file for libnm0
* Ignore client/tests failures.
check-local-clients-tests-test-client appears to be flaky and prone to
fail on slower architectures. Ignore failures of this test until this
has been properly investigated.
2018-10-21 - Michael Biebl <biebl@debian.org>
network-manager (1.14.2-2) unstable; urgency=medium
* Upload to unstable
2018-10-21 - Michael Biebl <biebl@debian.org>
network-manager (1.14.2-1) experimental; urgency=medium
* New upstream version 1.14.2
* Rebase patches
* Disable obsolete ibft settings plugin.
It has been replaced by an iBFT reader which parses /sys/firmware/ibft
directly instead of iscsiadm output.
* Drop debian/patches/Fix-iscsiadm-path.patch.
No longer needed.
2018-10-08 - Michael Biebl <biebl@debian.org>
network-manager (1.14.0-2) experimental; urgency=medium
* Tighten inter-package dependencies.
Make sure network-manager and libnm0 are always upgraded in lockstep.
(Closes: #818165)
2018-09-15 - Michael Biebl <biebl@debian.org>
network-manager (1.14.0-1) experimental; urgency=medium
* New upstream version 1.14.0
* Rebase patches
* Update symbols file for libnm0.
The nm_connection_get_setting_{6lowpan,sriov,wpan} API had been
introduced during the 1.14 development cycle but as it was duplicating
existing functionality it was removed again.

See Also

Package Description
libnma-dev_1.8.20-1.1_i386.deb library for wireless and mobile dialogs - development files
libnma0_1.8.20-1.1_i386.deb library for wireless and mobile dialogs (libnm version)
libnmap-parser-perl_1.37-1_all.deb module to parse nmap scan results with perl
libnmz7-dev_2.0.21-22_i386.deb full text search engine - header files and static libraries
libnmz7_2.0.21-22_i386.deb full text search engine - shared library
libnode-dev_10.15.2~dfsg-2_i386.deb evented I/O for V8 javascript (development files)
libnode64_10.15.2~dfsg-2_i386.deb evented I/O for V8 javascript - runtime library
libnodelet-dev_1.9.16-1+b1_i386.deb Robot OS nodelet library - service header files
libnodelet-topic-tools-dev_1.9.16-1+b1_i386.deb Robot OS nodelet_topic_tools library - development files
libnodeletlib-dev_1.9.16-1+b1_i386.deb Robot OS nodelet library - development
libnodeletlib-tools_1.9.16-1+b1_i386.deb Robot OS nodelet library
libnodeletlib1d_1.9.16-1+b1_i386.deb Robot OS nodelet library
libnoggit-java_0.7-1_all.deb Fast streaming JSON parser for Java
libnoise-dev_1.0.0+repack-1_i386.deb Portable, coherent noise-generating library for C++
libnoise0_1.0.0+repack-1_i386.deb Portable, coherent noise-generating library for C++
Advertisement
Advertisement