libnini1.1-cil_1.1.0+dfsg.2-5_all.deb


Advertisement

Description

libnini1.1-cil - CLI library for managing configuration files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libnini1.1-cil_1.1.0+dfsg.2-5_all.deb
Package name libnini1.1-cil
Package version 1.1.0+dfsg.2
Package release 5
Package architecture all
Package type deb
Category cli-mono devel::ecma-cli devel::library role::shared-lib
Homepage http://nini.sourceforge.net
License -
Maintainer Debian CLI Libraries Team <pkg-cli-libs-team@lists.alioth.debian.org>
Download size 22.89 KB
Installed size 76.00 KB
Nini is an uncommonly powerful .NET configuration library designed to help
build highly configurable applications quickly.
This package contains the Nini library

Alternatives

Package Version Architecture Repository
libnini1.1-cil_1.1.0+dfsg.2-5_all.deb 1.1.0+dfsg.2 all Debian Main
libnini1.1-cil - - -

Requires

Name Value
cli-common >= 0.5.1
libmono-corlib4.5-cil >= 3.2.8
libmono-system-xml4.0-cil >= 3.2.1
libmono-system4.0-cil >= 3.2.8

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnini1.1-cil_1.1.0+dfsg.2-5_all.deb
Source Package nini

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnini1.1-cil deb package:
    # sudo apt-get install libnini1.1-cil

Files

Path
/usr/lib/cli/Nini-1.1/Nini.dll
/usr/share/cli-common/packages.d/libnini1.1-cil.installcligac
/usr/share/doc/libnini1.1-cil/README.Debian
/usr/share/doc/libnini1.1-cil/changelog.Debian.gz
/usr/share/doc/libnini1.1-cil/changelog.gz
/usr/share/doc/libnini1.1-cil/copyright

Changelog

2015-09-09 - Jo Shields <directhex@apebox.org>
nini (1.1.0+dfsg.2-5) unstable; urgency=medium
* [8d534c0] Stop build-depending on dpatch, we don't use it
* [8166994] Fix debhelper version
* [ca034bd] Update to vaguely modern DH7 rules file idioms
2012-01-22 - Jo Shields <directhex@apebox.org>
nini (1.1.0+dfsg.2-4) unstable; urgency=low
* Rebuild with Mono 2.10 for CLR 4.0 transition
2009-11-07 - Jo Shields <directhex@apebox.org>
nini (1.1.0+dfsg.2-3) unstable; urgency=low
* debian/control,
debian/Makefile:
+ Use mono-csc from mono-devel 2.4.2.3
* debian/control:
+ No-change bump to Standards 3.8.3
* debian/control,
debian/libnini-cil-dev.install:
+ Create unversioned -dev package containing pkg-config file
* debian/rules,
debian/nini-1.1.pc,
debian/libnini1.1-cil.installcligac:
+ CLI Policy 0.7-compliant install dir
2009-03-02 - Jo Shields <directhex@apebox.org>
nini (1.1.0+dfsg.2-2) unstable; urgency=low
* Update for Mono 2.0 transition
2008-08-10 - Mirco Bauer <meebey@debian.org>
nini (1.1.0+dfsg.2-1) unstable; urgency=medium
[ Mirco Bauer ]
* Second DFSG version of nini 1.1.0, as some binary files were left in the
source tarball. (Closes: #494295)
(deleted all pre-compiled binaries from the tarball)
+ For the record here a list of the deleted files:
Bin/*
Examples/VbExamples/BasicApp/bin/*
Examples/CsExamples/BasicApp/bin/*
Examples/NiniEdit/Bin/*
* debian/control:
+ Added myself to Uploaders.
+ Changed Maintainer to Debian CLI Libraries Team.
+ Added Homepage, Vcs-Browser and Vcs-Svn fields.
+ Bumped Standards-Version to 3.8.0, no changes needed.
+ Updated cli-common-dev build-dependency to >= 0.5.7
(needed for cli.make)
+ Updated debhelper build-dependency to >= 7.
* debian/watch:
+ Mangled dfsg version.
* debian/rules:
+ Include /usr/share/cli-common/cli.make
+ Migrated to debhelper v7 minimalistic style.
* debian/compat:
+ Bumped to 7.
[ Sebastian Dröge ]
* debian/control:
+ Updated to use my debian.org mail address
2006-10-25 - Debian Mono Group <pkg-mono-group@lists.alioth.debian.org>
nini (1.1.0+dfsg-2) unstable; urgency=low
* Sebastian 'slomo' Dröge:
+ debian/rules:
- Run dh_install before dh_installcligac to fix FTBFS (Closes: #395043)
+ debian/control:
- Raise Build-Depends on cli-common-dev to (>= 0.4.4) to remove warnings
at build time
- Update Standards-Version to 3.7.2
2006-05-01 - Sebastian Dröge <slomo@ubuntu.com>
nini (1.1.0+dfsg-1) unstable; urgency=low
* Initial Revision (Closes: #355926)

See Also

Package Description
libnitrokey-common_3.4.1-4_all.deb architecture independent files for libnitrokey
libnitrokey-dev_3.4.1-4_i386.deb library to communicate with Nitrokey stick devices (development)
libnitrokey3_3.4.1-4_i386.deb library to communicate with Nitrokey stick devices
libnjb-dev_2.2.7~dfsg0-4+b3_i386.deb Creative Labs Nomad Jukebox library development files
libnjb-doc_2.2.7~dfsg0-4_all.deb Creative Labs Nomad Jukebox library documentation
libnjb-tools_2.2.7~dfsg0-4+b3_i386.deb Creative Labs Nomad Jukebox library tools
libnjb5_2.2.7~dfsg0-4+b3_i386.deb Creative Labs Nomad Jukebox library
libnkf-perl_2.1.5-1_i386.deb Network Kanji code conversion Filter for Perl
libnl-3-200_3.4.0-1_i386.deb library for dealing with netlink sockets
libnl-3-dev_3.4.0-1_i386.deb development library and headers for libnl-3
libnl-cli-3-200_3.4.0-1_i386.deb library for dealing with netlink sockets - cli helpers
libnl-cli-3-dev_3.4.0-1_i386.deb development library and headers for libnl-cli-3
libnl-genl-3-200_3.4.0-1_i386.deb library for dealing with netlink sockets - generic netlink
libnl-genl-3-dev_3.4.0-1_i386.deb development library and headers for libnl-genl-3
libnl-idiag-3-200_3.4.0-1_i386.deb library for dealing with netlink sockets - inetdiag interface
Advertisement
Advertisement