libnetsds-util-perl_1.045-1_all.deb


Advertisement

Description

libnetsds-util-perl - Service Delivery Suite framework - supplementary packages

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libnetsds-util-perl_1.045-1_all.deb
Package name libnetsds-util-perl
Package version 1.045
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/NetSDS-Util
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 41.95 KB
Installed size 105.00 KB
NetSDS::Util modules contains functions useful for everyday tasks.
* NetSDS::Util::Convert - data format conversions
* NetSDS::Util::DateTime - processing date and time
* NetSDS::Util::File - work with files and catalogs
* NetSDS::Util::Spreadsheet - processing spreadsheet files
* NetSDS::Util::Misc - miscellaneous routines
* NetSDS::Util::String - text and binary strings processing
* NetSDS::Util::Struct - data structures conversion
* NetSDS::Util::Translit - transliteration
* NetSDS::Util::Types - work with data types

Alternatives

Package Version Architecture Repository
libnetsds-util-perl_1.045-1_all.deb 1.045 all Debian Main
libnetsds-util-perl - - -

Requires

Name Value
libfile-mmagic-perl -
libossp-uuid-perl -
libspreadsheet-read-perl -
liburi-perl -
libwww-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnetsds-util-perl_1.045-1_all.deb
Source Package libnetsds-util-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnetsds-util-perl deb package:
    # sudo apt-get install libnetsds-util-perl

Files

Path
/usr/share/doc/libnetsds-util-perl/changelog.Debian.gz
/usr/share/doc/libnetsds-util-perl/changelog.gz
/usr/share/doc/libnetsds-util-perl/copyright
/usr/share/man/man3/NetSDS::Util.3pm.gz
/usr/share/man/man3/NetSDS::Util::Convert.3pm.gz
/usr/share/man/man3/NetSDS::Util::DateTime.3pm.gz
/usr/share/man/man3/NetSDS::Util::File.3pm.gz
/usr/share/man/man3/NetSDS::Util::FileImport.3pm.gz
/usr/share/man/man3/NetSDS::Util::Misc.3pm.gz
/usr/share/man/man3/NetSDS::Util::String.3pm.gz
/usr/share/man/man3/NetSDS::Util::Struct.3pm.gz
/usr/share/man/man3/NetSDS::Util::Translit.3pm.gz
/usr/share/man/man3/NetSDS::Util::Types.3pm.gz
/usr/share/perl5/NetSDS/Util.pm
/usr/share/perl5/NetSDS/Util/Convert.pm
/usr/share/perl5/NetSDS/Util/DateTime.pm
/usr/share/perl5/NetSDS/Util/File.pm
/usr/share/perl5/NetSDS/Util/FileImport.pm
/usr/share/perl5/NetSDS/Util/Misc.pm
/usr/share/perl5/NetSDS/Util/String.pm
/usr/share/perl5/NetSDS/Util/Struct.pm
/usr/share/perl5/NetSDS/Util/Translit.pm
/usr/share/perl5/NetSDS/Util/Types.pm

Changelog

2019-02-22 - Jonas Smedegaard <dr@jones.dk>
libnetsds-util-perl (1.045-1) unstable; urgency=medium
[ upstream ]
* New release.
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org.
[ gregor herrmann ]
* Update URLs from {search,www}.cpan.org to MetaCPAN.
[ Laurent Baillet ]
* Fix lintian spelling-error-in-description warning.
[ Jonas Smedegaard ]
* Simplify rules.
Stop build-depend on devscripts cdbs.
* Mark build-dependencies needed only for testsuite as such.
* Stop build-depend on dh-buildinfo.
* Bump debhelper compatibility level to 9.
* Relax to (build-)depend unversioned on debhelper:
Needed version satisfied even in oldstable.
* Declare compliance with Debian Policy 4.3.0.
* Set Rules-Requires-Root: no.
* Update git-buildpackage config: Filter any .git* file.
* Update watch file:
+ Bump to file format 4.
+ Rewrite usage comment.
+ Use substitution strings.
* Update copyright info:
+ Fix update main upstream author.
+ Use License-Grant and License-Reference fields.
Thanks to Ben Finney.
+ Extend coverage of packaging.
+ Change packaging license to GPL-3+.
+ Use https protocol in Format URL.
* Add lintian overrides regarding License-Reference.
* Drop pod-fix patch: Adopted upstream.
* Unfuzz pod-spelling patch, and extend dep3 header.
2015-06-09 - Damyan Ivanov <dmn@debian.org>
libnetsds-util-perl (1.044-4) unstable; urgency=low
* Team upload
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ Damyan Ivanov ]
* Mark package as autopkgtestable
* Declare compliance with Debian Policy 3.9.6
* use canonical Vcs-* URLs
* Add explicit build dependency on libmodule-build-perl
* patch POD spelling (Paramters -> Parameters)
* bump debhelper compatibility level to 8
2013-06-04 - gregor herrmann <gregoa@debian.org>
libnetsds-util-perl (1.044-3) unstable; urgency=low
* Team upload.
[ Jonas Smedegaard ]
* Fix (build-)depend on libossp-uuid-perl (not virtual
libdata-uuid-perl).
* Update package relations:
+ Drop (build-)dependencies on libmodule-build-perl,
libfile-path-perl, libfile-spec-perl or libtime-local-perl:
Provided by perl(-modules) even in oldstable.
+ Relax to (build-)depend unversioned on cdbs, debhelper and
devscripts: Needed version satisfied in stable, and oldstable no
longer supported.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
[ Xavier Guimard ]
* Add "Files: *" to remove missing-license-text-in-dep5-copyright
warning
[ Jonas Smedegaard ]
* Add README.source emphasizing control.in file as *not* a show-stopper
for contributions, referring to wiki page for details.
[ gregor herrmann ]
* Add patch to fix a POD error, which causes a test failure in Perl
5.18. (Closes: #710958)
2011-08-27 - Jonas Smedegaard <dr@jones.dk>
libnetsds-util-perl (1.044-2) unstable; urgency=low
* Update copyright file: new owner (still GPL-2+).
* Improve package relations:
+ Favor (build-)depending on recent perl providing same packages:
- libfile-path-perl
- libfile-spec-perl
- libtime-local-perl
* Improve package relations:
+ Stop declaring package part of core Perl (even in oldstable):
- libfile-temp-perl
* Update copyright file:
+ Adjust to draft 174 of DEP-5 format.
+ Rewrap at 72 chars.
+ Fix refer to versioned GPL license.
+ Rephrase GPL comment slightly.
* Update control file:
+ Bump policy compliance to standards-version 3.9.2.
+ Shorten Vcs-* fields.
2010-04-28 - Jonas Smedegaard <dr@jones.dk>
libnetsds-util-perl (1.044-1) unstable; urgency=low
* Initial release. Closes: bug#579477.

See Also

Package Description
libnetsvcs-6.4.5_6.4.5+dfsg-1+b12_i386.deb ACE network service implementations - libraries
libnetsvcs-dev_6.4.5+dfsg-1+b12_i386.deb ACE network service implementations - development files
libnettle6_3.4.1-1_i386.deb low level cryptographic library (symmetric and one-way cryptos)
libnetty-java_4.1.33-1_all.deb Java NIO client/server socket framework
libnetty-reactive-streams-java_2.0.1-1_all.deb Netty Reactive Streams
libnetty-tcnative-java_2.0.20-1_all.deb Tomcat native fork for Netty
libnetty-tcnative-jni_2.0.20-1_i386.deb Tomcat native fork for Netty (JNI library)
libnetwork-ipv4addr-perl_0.10.ds-3_all.deb Perl extension for manipulating IPv4 addresses
libnetx-java_0.5-4_all.deb An open-source JNLP client
libnetxx-dev_0.3.2-2+b1_i386.deb C++ library for network programming (development headers)
libnetxx1_0.3.2-2+b1_i386.deb C++ library for network programming
libnewlib-arm-none-eabi_3.1.0.20181231-1_all.deb C library and math library compiled for bare metal using Cortex A/R/M
libnewlib-dev_3.1.0.20181231-1_all.deb C library and math library intended for use on embedded systems
libnewlib-doc_3.1.0.20181231-1_all.deb C library and math library intended for use on embedded systems (doc)
libnewlib-nano-arm-none-eabi_2.11.2-1_all.deb Smaller embedded C library for arm development
Advertisement
Advertisement