libnet-interface-perl_1.016-1+b3_i386.deb


Advertisement

Description

libnet-interface-perl - Perl module for manipulating host network interfaces

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libnet-interface-perl_1.016-1+b3_i386.deb
Package name libnet-interface-perl
Package version 1.016
Package release 1+b3
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib
Homepage https://metacpan.org/release/Net-Interface
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 65.23 KB
Installed size 173.00 KB
Net::Interface is a module that allows access to the host network interfaces
in a manner similar to ifconfig(8). Version 1.00 is a complete re-write and
includes support for IPV6 as well as the traditional IPV4.
Both read and write access to network device attributes including the
creation of new logical and physical interfaces is available where supported
by the OS and this module.
NOTE: Many of the operations of Net::Interface, particularly those that set
interface values require privileged access to OS resources. Wherever possible,
Net::Interface will simply fail softly when there are not adequateprivileges
to perform the requested operation or where the operation is not supported.

Alternatives

Package Version Architecture Repository
libnet-interface-perl_1.016-1+b3_amd64.deb 1.016 amd64 Debian Main
libnet-interface-perl - - -

Requires

Name Value
libc6 >= 2.4
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnet-interface-perl_1.016-1+b3_i386.deb
Source Package libnet-interface-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnet-interface-perl deb package:
    # sudo apt-get install libnet-interface-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/Net/Interface.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Net/Interface/Developer.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Net/Interface/NetSymbols.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/Net/Interface/Interface.so
/usr/share/doc/libnet-interface-perl/changelog.Debian.gz
/usr/share/doc/libnet-interface-perl/changelog.Debian.i386.gz
/usr/share/doc/libnet-interface-perl/changelog.gz
/usr/share/doc/libnet-interface-perl/copyright
/usr/share/man/man3/Net::Interface.3pm.gz
/usr/share/man/man3/Net::Interface::Developer.3pm.gz
/usr/share/man/man3/Net::Interface::NetSymbols.3pm.gz

Changelog

2016-10-01 - Christopher Hoskin <christopher.hoskin@gmail.com>
libnet-interface-perl (1.016-1) unstable; urgency=medium
* New upstream release (1.016)
2016-09-24 - Christopher Hoskin <christopher.hoskin@gmail.com>
libnet-interface-perl (1.015-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Christopher Hoskin ]
* New upstream release (1.015)
* Refresh reproducible-build.patch
* Enable hardening
* Fix man page spellings
* Update Standards-Version to 3.9.8 (no changes required)
* Update socket_h.patch
* Update upstream author's copyright to 2008-2016
* Adjust reproducible-build.patch header to comply with cme check dpkg
[ gregor herrmann ]
* Drop autotools-dev and {dh-,}autoreconf from debian/{control,rules}.
Let debhelper 10 do the job for us instead.
2015-11-28 - gregor herrmann <gregoa@debian.org>
libnet-interface-perl (1.012-3) unstable; urgency=medium
* Team upload.
* Update reproducible-build.patch: remove embedded current year.
Thanks to Reiner Herrmann for the bug report and the patch.
(Closes: #806250)
2015-07-08 - gregor herrmann <gregoa@debian.org>
libnet-interface-perl (1.012-2) unstable; urgency=medium
* Team upload.
* Add patch to make build reproducible.
Thanks to Chris Lamb for the bug report and the patch.
(Closes: #790503)
* Refresh debian/patches/manpage.patch (offset).
2015-05-02 - Christopher Hoskin <christopher.hoskin@gmail.com>
libnet-interface-perl (1.012-1) unstable; urgency=low
* Initial Release. Closes: #778888

See Also

Package Description
libnet-ip-minimal-perl_0.06-1_all.deb module to check if an IP address is version 4 or 6
libnet-ip-perl_1.26-2_all.deb Perl extension for manipulating IPv4/IPv6 addresses
libnet-ip-xs-perl_0.21-1+b1_i386.deb Perl extension for manipulating IPv4/IPv6 addresses (XS)
libnet-ipaddress-perl_1.10-3_all.deb Functions used to manipulate IP addresses, masks and FQDN's
libnet-iptrie-perl_0.7-2_all.deb Perl module for building IPv4 and IPv6 address space hierarchies
libnet-ipv6addr-perl_0.96-1_all.deb module to validate/manipulate IPv6 addresses
libnet-irc-perl_0.79-2_all.deb IRC (Internet Relay Chat) interface module for Perl
libnet-irr-perl_0.08-1_all.deb perl interface to the Internet Route Registry daemon
libnet-jabber-bot-perl_2.1.5-1_all.deb automated Bot creation with safeties
libnet-jabber-loudmouth-perl_0.07-3+b5_i386.deb Perl interface for the loudmouth jabber library
libnet-jabber-perl_2.0-8_all.deb Perl modules for accessing the Jabber protocol
libnet-ldap-filterbuilder-perl_1.200000-1_all.deb module to build LDAP filter statements
libnet-ldap-perl_0.6500+dfsg-1_all.deb client interface to LDAP servers
libnet-ldap-server-perl_0.43-1_all.deb LDAP server-side protocol handling in Perl
libnet-ldap-server-test-perl_0.22-1_all.deb provides a test LDAP server for Net::LDAP testing
Advertisement
Advertisement