libneon27_0.30.2-3_i386.deb


Advertisement

Description

libneon27 - HTTP and WebDAV client library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libneon27_0.30.2-3_i386.deb
Package name libneon27
Package version 0.30.2
Package release 3
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.webdav.org/neon/
License -
Maintainer Laszlo Boszormenyi (GCS) <gcs@debian.org>
Download size 166.87 KB
Installed size 292.00 KB
neon is an HTTP and WebDAV client library, with a C language API.
WARNING: THE NEON API IS NOT YET STABLE.
Provides lower-level interfaces to directly implement new HTTP
methods, and higher-level interfaces so that you don't have to
worry about the lower-level stuff.
Current features:
* High-level interface to HTTP and WebDAV methods (PUT, GET, HEAD, etc.)
* Low-level interface to HTTP request handling, to allow implementing
new methods easily.
* persistent connections
* RFC2617 basic and digest authentication (including auth-int, md5-sess)
* Proxy support (including basic/digest authentication)
* SSL/TLS support using OpenSSL (including client certificate and thread
safety support)
* Generic WebDAV 207 XML response handling mechanism
* XML parsing using the expat or libxml parsers
* Easy generation of error messages from 207 error responses
* WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL.
* WebDAV metadata support: set and remove properties, query any set ofi
properties (PROPPATCH/PROPFIND).
* autoconf macros supplied for easily embedding neon directly inside an
application source tree.

Alternatives

Package Version Architecture Repository
libneon27_0.30.2-3_amd64.deb 0.30.2 amd64 Debian Main
libneon27 - - -

Requires

Name Value
libc6 >= 2.28
libcom-err2 >= 1.43.9
libgssapi-krb5-2 >= 1.17
libk5crypto3 >= 1.6.dfsg.2
libkrb5-3 >= 1.6.dfsg.2
libssl1.1 >= 1.1.1
libxml2 >= 2.7.4
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libneon27_0.30.2-3_i386.deb
Source Package neon27

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libneon27 deb package:
    # sudo apt-get install libneon27

Files

Path
/usr/lib/i386-linux-gnu/libneon.so.27
/usr/lib/i386-linux-gnu/libneon.so.27.3.2
/usr/share/doc/libneon27/AUTHORS
/usr/share/doc/libneon27/BUGS
/usr/share/doc/libneon27/NEWS.gz
/usr/share/doc/libneon27/README
/usr/share/doc/libneon27/THANKS
/usr/share/doc/libneon27/TODO
/usr/share/doc/libneon27/changelog.Debian.gz
/usr/share/doc/libneon27/changelog.gz
/usr/share/doc/libneon27/copyright

Changelog

2019-03-02 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.2-3) unstable; urgency=medium
* Run OpenSSL checks but don't fail on them (closes: #907009).
* Backport OpenSSL 1.1 fixes:
- don't set OpenSSL locking/thread callbacks,
- return NE_SOCK_RETRY for SSL_ERROR_WANT_READ.
* Fix HAVE_SYS_UIO_H typo.
2016-11-28 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.2-2) unstable; urgency=low
* Remove Multi-Arch field from libneon27-dev and libneon27-gnutls-dev
packages (closes: #846024).
2016-10-06 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.2-1) unstable; urgency=low
* New upstream release.
* Fix compilation with OpenSSL 1.1.0 (closes: #828446).
* Patch to make out of source directory testing possible.
* Drop fix-gnutls-3.4-compilation.patch , this release contains it.
* Mark libneon27-dev and libneon27-gnutls-dev as Multi-Arch: foreign
(closes: #813304).
* Update debhelper level to 10 .
[ Helmut Grohne <helmut@subdivi.de> ]
* Fix FTCBFS (closes: #841697):
+ Drop versioned binutils from Build-Depends: satisfied in Wheezy.
+ Let dh_auto_configure pass --host as necessary.
+ Support DEB_BUILD_OPTIONS=nocheck.
+ Force triplet-prefixed pkg-config.
2016-08-11 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.1-5) unstable; urgency=low
* Skip racy test instead of ignore the whole testsuite result, patch by
James Clarke.
2016-08-10 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.1-4) unstable; urgency=low
* Make self tests non-fatal on kFreeBSD architectures (closes: #774534).
* Enable GnuTLS self tests (closes: #547203).
* Update Standards-Version to 3.9.8 .
2016-01-30 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.1-3) unstable; urgency=low
* Sync with Ubuntu (closes: #812936).
[ Matthias Klose <doko@ubuntu.com> ]
* Multiarchify the package.
* Build using dpkg-buildflags.
2015-10-03 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.1-2) unstable; urgency=low
* Use upstream fix for building with GnuTLS 3.4 (closes: #782832).
* Add lintian overrides for known false positives.
* Update Standards-Version to 3.9.6 .
2014-09-29 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.1-1) unstable; urgency=low
* New upstream release.
* Drop GnuTLS memory leak fix, merged upstream.
2014-08-01 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.0-4) unstable; urgency=low
[ Patrick Ohly <patrick.ohly@intel.com> ]
* Fix memory leak when using gnutls >= 1.3.1 (closes: #756608).
2014-06-21 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
neon27 (0.30.0-3) unstable; urgency=low
* Swich to gnutls28 (closes: #752238).
* Enable OpenSSL testsuite.

See Also

Package Description
libnet-abuse-utils-perl_0.27-1_all.deb Routines useful for processing network abuse
libnet-address-ip-local-perl_0.1.2-3_all.deb Perl module for discovering the local system's IP address
libnet-akamai-perl_0.15-1_all.deb Perl module to interact with Akamai
libnet-akismet-perl_0.05-3_all.deb Perl interface to Akismet - comment and trackback spam fighter
libnet-amazon-ec2-perl_0.36-1_all.deb Perl interface to the Amazon Elastic Compute Cloud (EC2)
libnet-amazon-perl_0.62-2_all.deb Perl framework for accessing amazon.com via SOAP and XML/HTTP
libnet-amazon-s3-perl_0.85-1_all.deb Amazon S3 Perl API - Simple Storage Service
libnet-amazon-s3-tools-perl_0.08-2_all.deb Command line tools for Amazon AWS S3
libnet-amqp-perl_0.06~dfsg-2_all.deb AMQP (de)serialization and representation
libnet-appliance-session-perl_4.300001-1_all.deb module for running command-line sessions to network appliances
libnet-arp-perl_1.0.9-1+b1_i386.deb module to create ARP packets and lookup for ARP information
libnet-async-fastcgi-perl_0.25-1_all.deb FastCGI engine using IO::Async
libnet-async-irc-perl_0.11-1_all.deb IRC client for use with IO::Async
libnet-async-tangence-perl_0.14-1_all.deb use Tangence with IO::Async
libnet-bluetooth-perl_0.41-2+b1_i386.deb Perl interface to Bluetooth libraries
Advertisement
Advertisement