libndpi-dev_2.6-3_i386.deb


Advertisement

Description

libndpi-dev - extensible deep packet inspection library - development files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libndpi-dev_2.6-3_i386.deb
Package name libndpi-dev
Package version 2.6
Package release 3
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://www.ntop.org/products/ndpi/
License -
Maintainer Ludovico Cavedon <cavedon@debian.org>
Download size 220.82 KB
Installed size 944.00 KB
nDPI is a ntop-maintained superset of the popular OpenDPI library. Released
under the LGPL license, its goal is to extend the original library by adding
new protocols that are otherwise available only on the paid version of
OpenDPI.
nDPI has also been modified to be suitable for traffic monitoring
applications, by disabling specific features that slow down the DPI engine
while being them un-necessary for network traffic monitoring.
With nDPI, it is possible to both detect known protocols on non-standard ports
(e.g. detect http non ports other than 80), and also the opposite.
This package contains the static library and compilation headers.

Alternatives

Package Version Architecture Repository
libndpi-dev_2.6-3_amd64.deb 2.6 amd64 Debian Main
libndpi-dev - - -

Requires

Name Value
libndpi2.6 = 2.6-3

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libndpi-dev_2.6-3_i386.deb
Source Package ndpi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libndpi-dev deb package:
    # sudo apt-get install libndpi-dev

Files

Path
/usr/include/ndpi/ndpi_api.h
/usr/include/ndpi/ndpi_config.h
/usr/include/ndpi/ndpi_define.h
/usr/include/ndpi/ndpi_includes.h
/usr/include/ndpi/ndpi_main.h
/usr/include/ndpi/ndpi_protocol_ids.h
/usr/include/ndpi/ndpi_protocols.h
/usr/include/ndpi/ndpi_typedefs.h
/usr/include/ndpi/ndpi_unix.h
/usr/include/ndpi/ndpi_win32.h
/usr/lib/i386-linux-gnu/libndpi.a
/usr/lib/i386-linux-gnu/libndpi.so
/usr/lib/i386-linux-gnu/pkgconfig/libndpi.pc
/usr/share/doc/libndpi-dev/README.Debian
/usr/share/doc/libndpi-dev/changelog.Debian.gz
/usr/share/doc/libndpi-dev/changelog.gz
/usr/share/doc/libndpi-dev/copyright
/usr/share/doc/libndpi-dev/ndpiReader.c.gz
/usr/share/doc/libndpi-dev/protos.txt

Changelog

2019-01-16 - Ludovico Cavedon <cavedon@debian.org>
ndpi (2.6-3) unstable; urgency=medium
* Add packet-direction.patch and quic.patch to fix big-endian-related bugs.
* Disable tests that have inconsistent behavior across architecture due to
broken sorting in the test code.
2019-01-15 - Ludovico Cavedon <cavedon@debian.org>
ndpi (2.6-2) unstable; urgency=medium
* Remove no longer needed build-dep on xdelta.
* Fix reference-after-free in ndpiReader and optimistically re-enable all
tests succeeding on amd64 and i386.
2019-01-14 - Ludovico Cavedon <cavedon@debian.org>
ndpi (2.6-1) unstable; urgency=medium
[ Bernd Zeimetz ]
* [e941738] Update upstream source from tag 'upstream/2.6'
Update to upstream version '2.6'
with Debian dir ebb088f5b1a1a88743e71021b4a9c252b397527e
This will also hopefully fix all test issues.
Closes: #886133
* [a7ca26d] Removing patches as they don't apply anymore.
* [52af6ea] Disable binary patches for tests
* [61b7054] Install into /usr
* [9a430fe] Add patch to fix prefix in Makefile.
* [647cd1a] Fix and activate tests.
* [65e0c54] Updating git info
* [e54c89d] Updating symbols file.
* [f0451ce] Add gitlab CI file.
* [9a4a0f1] Disable tests which are broken on big endian.
* [d58ddad] Disabling another test.
[ Ludovico Cavedon ]
* Change SONAME and lib package name to include minory library version.
* Use libwireshark-dev to determine wireshak plugin path.
* Add define-have-json-c.patch to ensure ndpiReader is compiled with JSON
support.
* Link ndpiReader dynamically against libndpi and avoid lnking against
unnecessary C++ libraries.
* Stop adding libcache.h to -dev package.
* Add DEP3 header to patches/fix-makefile-prefix.
* Check DEB_BUILD_OPTIONS before running tests.
* Update Standards-Version to 4.3.0.
* Update debian/copyright for new upstream code.
2017-12-26 - Ludovico Cavedon <cavedon@debian.org>
ndpi (2.2-1) unstable; urgency=medium
* Imported Upstream version 2.2 (Closes: #878128, #878124).
* Update watch file to fetch new versions from github.
* Update copyright file.
* Add Multi-Arch flags in control file.
* Add libndpi-wireshark with wireshark dissector.
* Bump Standards-Version to 4.1.2.
* Update and refresh patches.
* Stop using dh-autoreconf (automatically called by autogen.sh).
* Add no-configure-after-autogen.patch to prevent autogen.sh from
automatically invoking configure.
* Update export-additional-symbols.patch, adding new required exported
symbols in libndpi.sym.
* Bump libndpi SONAME to 5.
* Use pkg-info.mk for parsing changelog.
* Patch nintendo.pcap and skype-conference-call.pcap to make sure libpcap is
able to open them during tests, based on
https://github.com/ntop/nDPI/issues/462#issuecomment-332552609.
* Embded libcache.h into libndpi includes, as it is included by
ndpi_typedefs.h.
2016-12-10 - Ludovico Cavedon <cavedon@debian.org>
ndpi (1.8-1) unstable; urgency=medium
* Imported Upstream version 1.8
* Update copyright.
* Refresh and update pacthes.
* Remove export-additional-symbols.patch (merged upstream).
* Update Standards-Version to 3.9.8.
* Update symbols file for libndpi3.
* Bump SONAME to libndpi4.
* Enable all build hardening.
* Migrate to libndpi-dbgsym.
2015-12-25 - Ludovico Cavedon <cavedon@debian.org>
ndpi (1.7.1~git20151130.6f3d5a7-1) unstable; urgency=medium
* Imported Upstream version 1.7.1~git20151130.6f3d5a7
* Support fetching a specific version from upstream git.
* Refresh patches.
* Update copyright.
* Update symbols list.
* Add add-missing-headers.patch to include ndpi_includes.h.

See Also

Package Description
libndpi-wireshark_2.6-3_i386.deb extensible deep packet inspection library - wireshark dissector
libndpi2.6_2.6-3_i386.deb extensible deep packet inspection library - shared library
libneko2_2.2.0-2+b12_i386.deb Lightweight virtual machine - shared library
libnekohtml-java-doc_1.9.22-1_all.deb NekoHTML - HTML parser for Java (Documentation)
libnekohtml-java_1.9.22-1_all.deb NekoHTML - HTML parser for Java
libnemesis3_6.02.dfsg.1-8+b1_i386.deb Parallel extension to the EXODUSII datamodel
libnemo-extension-dev_3.8.5-1+b1_i386.deb Nemo component system facilities (development files)
libnemo-extension1_3.8.5-1+b1_i386.deb Nemo component system facilities
libneo4j-client-dev_2.2.0-1+b1_i386.deb Development files for libneo4j-client, a client library for Neo4j
libneo4j-client-doc_2.2.0-1_all.deb Documentation for libneo4j-client, a client library for Neo4j
libneo4j-client11_2.2.0-1+b1_i386.deb Client library for the Neo4j graph database
libneon27-dev_0.30.2-3_i386.deb Header and static library files for libneon27
libneon27-gnutls-dev_0.30.2-3_i386.deb Header and static library files for libneon27 (GnuTLS enabled)
libneon27-gnutls_0.30.2-3_i386.deb HTTP and WebDAV client library (GnuTLS enabled)
libneon27_0.30.2-3_i386.deb HTTP and WebDAV client library
Advertisement
Advertisement