libnbcompat-dev_20180822-5_i386.deb


Advertisement

Description

libnbcompat-dev - NetBSD pkgsrc compatibility library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libnbcompat-dev_20180822-5_i386.deb
Package name libnbcompat-dev
Package version 20180822
Package release 5
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://cdn.netbsd.org/pub/pkgsrc/current/pkgsrc/pkgtools/libnbcompat/README.html
License -
Maintainer John Goerzen <jgoerzen@complete.org>
Download size 86.48 KB
Installed size 401.00 KB
libnbcompat is designed to let non-NetBSD operating systems execute
code that is part of the NetBSD pkgsrc repository.  It is, in
particular, required for building the NetBSD (package mtree-netbsd).
This package installs the header and static library files.  libnbcompat
is not provided as a shared library.

Alternatives

Package Version Architecture Repository
libnbcompat-dev_20180822-5_amd64.deb 20180822 amd64 Debian Main
libnbcompat-dev - - -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnbcompat-dev_20180822-5_i386.deb
Source Package libnbcompat

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnbcompat-dev deb package:
    # sudo apt-get install libnbcompat-dev

Files

Path
/usr/include/nbcompat.h
/usr/include/nbcompat/assert.h
/usr/include/nbcompat/cdefs.h
/usr/include/nbcompat/ctype.h
/usr/include/nbcompat/db.h
/usr/include/nbcompat/dirent.h
/usr/include/nbcompat/endian.h
/usr/include/nbcompat/err.h
/usr/include/nbcompat/fnmatch.h
/usr/include/nbcompat/fts.h
/usr/include/nbcompat/getopt.h
/usr/include/nbcompat/glob.h
/usr/include/nbcompat/grp.h
/usr/include/nbcompat/limits.h
/usr/include/nbcompat/md5.h
/usr/include/nbcompat/nbconfig.h
/usr/include/nbcompat/netdb.h
/usr/include/nbcompat/param.h
/usr/include/nbcompat/paths.h
/usr/include/nbcompat/poll.h
/usr/include/nbcompat/pwd.h
/usr/include/nbcompat/queue.h
/usr/include/nbcompat/regex.h
/usr/include/nbcompat/rmd160.h
/usr/include/nbcompat/sha1.h
/usr/include/nbcompat/sha2.h
/usr/include/nbcompat/stat.h
/usr/include/nbcompat/statvfs.h
/usr/include/nbcompat/stdbool.h
/usr/include/nbcompat/stdio.h
/usr/include/nbcompat/stdlib.h
/usr/include/nbcompat/string.h
/usr/include/nbcompat/termcap.h
/usr/include/nbcompat/time.h
/usr/include/nbcompat/types.h
/usr/include/nbcompat/tzfile.h
/usr/include/nbcompat/unistd.h
/usr/include/nbcompat/util.h
/usr/include/nbcompat/vis.h
/usr/lib/libnbcompat.a
/usr/share/doc/libnbcompat-dev/changelog.Debian.gz
/usr/share/doc/libnbcompat-dev/copyright

Changelog

2018-10-05 - John Goerzen <jgoerzen@complete.org>
libnbcompat (20180822-5) unstable; urgency=low
* Do not link -lbsd; causes segfault
2018-10-05 - John Goerzen <jgoerzen@complete.org>
libnbcompat (20180822-4) unstable; urgency=low
* More build-deps, to reduce size of this package.
2018-10-05 - John Goerzen <jgoerzen@complete.org>
libnbcompat (20180822-3) unstable; urgency=low
* Add additional build-deps
2018-10-04 - John Goerzen <jgoerzen@complete.org>
libnbcompat (20180822-2) unstable; urgency=low
* Analyze licenses and note additional info in debian/copyright.
Closes: #910331.
2018-10-03 - John Goerzen <jgoerzen@complete.org>
libnbcompat (20180822-1) unstable; urgency=medium
* Initial release (Closes: #910252)

See Also

Package Description
libncap-dev_1.9.2-3_i386.deb static library and header files for libncap
libncap44_1.9.2-3_i386.deb network capture library
libncarg-bin_6.5.0-2_i386.deb NCAR command-language library - development tools
libncarg-data_6.5.0-2_all.deb NCAR command-language library - Data
libncarg-dev_6.5.0-2_i386.deb Development files for the NCAR command language library
libncarg0_6.5.0-2_i386.deb NCAR command-language library
libncbi-vdb-dev_2.9.3+dfsg-2_i386.deb libraries for using data in the INSDC Sequence Read Archives (devel)
libncbi-vdb2_2.9.3+dfsg-2_i386.deb libraries for using data in the INSDC Sequence Read Archives
libncbi-wvdb-dev_2.9.3+dfsg-2_i386.deb virtual layer update modul of ncbi-vdb library (devel)
libncbi-wvdb2_2.9.3+dfsg-2_i386.deb virtual layer update modul of ncbi-vdb library
libncbi6-dev_6.1.20170106+dfsg1-0+deb10u2_i386.deb NCBI libraries for biology applications (development files)
libncbi6_6.1.20170106+dfsg1-0+deb10u2_i386.deb NCBI libraries for biology applications
libncl-dev_2.1.21+git20180827.c71b264-2_i386.deb NEXUS Class Library (static lib and header files)
libncl2_2.1.21+git20180827.c71b264-2_i386.deb NEXUS Class Library
libncurses-dev_6.1+20181013-2+deb10u1_i386.deb developer's libraries for ncurses
Advertisement
Advertisement