libmxml1_2.12-2_i386.deb


Advertisement

Description

libmxml1 - small XML parsing library (runtime)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmxml1_2.12-2_i386.deb
Package name libmxml1
Package version 2.12
Package release 2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.msweet.org/mxml/
License -
Maintainer Alastair McKinstry <mckinstry@debian.org>
Download size 28.45 KB
Installed size 71.00 KB
Mini-XML is a small XML parsing library that you can use to read XML and
XML-like data files in your application without requiring large non-standard
libraries.
Mini-XML provides the following functionality:
* Reading of UTF-8 and UTF-16 and writing of UTF-8 encoded XML files and
strings.
* Data is stored in a linked-list tree structure, preserving the XML data
hierarchy.
* Supports arbitrary element names, attributes, and attribute values with
no preset limits, just available memory.
* Supports integer, real, opaque ("cdata"), and text data types in "leaf"
nodes.
* Functions for creating, indexing, and managing trees of data.
* "Find" and "walk" functions for easily locating and navigating trees of
data.
Mini-XML doesn't do validation or other types of processing on the data based
upon schema files or other sources of definition information, nor does it
support character entities other than those required by the XML specification.
This package contains the files necessary for running applications that
use the Mini-XML library.

Alternatives

Package Version Architecture Repository
libmxml1_2.12-2_amd64.deb 2.12 amd64 Debian Main
libmxml1 - - -

Requires

Name Value
libc6 >= 2.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmxml1_2.12-2_i386.deb
Source Package mxml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmxml1 deb package:
    # sudo apt-get install libmxml1

Files

Path
/usr/lib/i386-linux-gnu/libmxml.so.1
/usr/lib/i386-linux-gnu/libmxml.so.1.6
/usr/share/doc/libmxml1/changelog.Debian.gz
/usr/share/doc/libmxml1/changelog.gz
/usr/share/doc/libmxml1/copyright

Changelog

2019-01-02 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.12-2) unstable; urgency=medium
* CVE-2018-20004: patch from upstream. Closes: #918007
* Standards-Version: 4.3.0.
2018-10-06 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.12-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.2.1
* Remove Luis Uribe from the Uploaders list.
Thanks for all the work, Luis!. Closes: #894007
* Addpatch from Helmut Grohne for cross-building. Closes: #909354
* Enable use of autoheader (disable check in configure) as we have a 
patch for its problems.
2018-07-09 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.11-2) unstable; urgency=medium
* Add VCS for mxml: salsa.d.o
* Change homepage to HTTPS version
* Standards-Version: 4.1.5
* change README->README.md, add CHANGES.md to docs. Closes: #903335
2018-03-02 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.11-1) unstable; urgency=medium
* New upstream release
* 06_autoheader.patch now needed for autoreconf
* 07_compile_fixes.patch needed to compile
* Obsolete patch removed: 05_stack_recursion_fix.diff
* Standards-Version: 4.1.3; no changes required
* Cleanup rules - no dh_auto_configure clause now needed 
2017-06-27 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.10-2) unstable; urgency=medium
* Fix watch file; project moved to github
* Standards-Version: 4.0.0; no changes required
* DH_COMPAT now 10
2016-09-14 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.10-1) unstable; urgency=medium
* New upstream release
* Add Breaks/Replaces for mxmldoc breakage. Closes: #836847
2016-08-29 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.9-3) unstable; urgency=medium
* Update watch file
* Patch from doko to:
- Multiarchify the library packages.
-  Enable parallel builds
- Let the tests fail on error.
Closes: #835300
2016-06-11 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.9-2) unstable; urgency=medium
* Missing second patch for recursion fix. Closes: #825855.
2016-06-10 - Alastair McKinstry <mckinstry@debian.org>
mxml (2.9-1) unstable; urgency=medium
* New maintainer. Mark Luis Uribe as Uploader. Closes: #784865 
* New upstream release
- refreshed patches.
- 04_minor_version.diff: correct minor version 8->9
* Patch to fix security issues due to recursion in mxmlDelete. Closes: #825855.
CVE-2016-4570
CVE-2016-4571
* Include updated debian/watch file
* New Standards-Version: 3.9.8. No changes required
2012-08-16 - Luis Uribe <acme@eviled.org>
mxml (2.7-1) experimental; urgency=low
* New upstream release (Closes: #684783)
* debian/control
- Bump Standards-Version: 3.9.3 (No changes)
* debian/compat
- Update debhelper compat level to 9, needed to using dpkg-buildflags
* debian/rules
- Use dh tiny rules
* patches/series
- Add 03_link_ldflags.diff to add missing $(LDFLAGS) to Makefile
* debian/copyright
- Migrate to DEP-5 format

See Also

Package Description
libmygpo-qt-dev_1.1.0-3_i386.deb Development headers for the mygpo-qt library
libmygpo-qt5-1_1.1.0-3_i386.deb mygpo-qt library package
libmygui-dev_3.2.2+dfsg-2+b2_i386.deb Fast, simple and flexible GUI for OpenMW - development files
libmygui.ogreplatform0debian1v5_3.2.2+dfsg-2+b2_i386.deb Fast, simple and flexible GUI - Ogre interface
libmygui.openglplatform0debian1v5_3.2.2+dfsg-2+b2_i386.deb Fast, simple and flexible GUI - OpenGL interface
libmyguiengine3debian1v5_3.2.2+dfsg-2+b2_i386.deb Fast, simple and flexible GUI - shared library
libmypaint-1.3-0_1.3.0-2.1_i386.deb brush library for mypaint
libmypaint-common_1.3.0-2.1_all.deb brush library for mypaint - common files
libmypaint-dev_1.3.0-2.1_i386.deb brush library for mypaint - development files
libmypaint-doc_1.3.0-2.1_all.deb brush library for mypaint - documentation
libmyproxy-dev_6.2.4-1_i386.deb Credential Management Service Development
libmyproxy-doc_6.2.4-1_all.deb Credential Management Service Documentation
libmyproxy-voms_6.2.4-1_i386.deb Credential Management Service VOMS Library
libmyproxy6_6.2.4-1_i386.deb Credential Management Service Library
libmysofa-dev_0.6~dfsg0-3_i386.deb library to read HRTFs stored in the AES69-2015 SOFA format - development files
Advertisement
Advertisement