libmtp-common_1.1.16-2_all.deb


Advertisement

Description

libmtp-common - Media Transfer Protocol (MTP) common files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmtp-common_1.1.16-2_all.deb
Package name libmtp-common
Package version 1.1.16
Package release 2
Package architecture all
Package type deb
Category libs role::shared-lib
Homepage http://libmtp.sourceforge.net/
License -
Maintainer Alessio Treglia <alessio@debian.org>
Download size 64.59 KB
Installed size 371.00 KB
libmtp is a library for communicating with MTP aware devices in POSIX
compliant operating systems.  It implements MTP Basic, the subset
proposed for standardization.
The Media Transfer Protocol (commonly referred to as MTP) is a devised
set of custom extensions to support the transfer of music files on
USB digital audio players and movie files on USB portable media players.
This package provides the udev rules file.

Alternatives

Package Version Architecture Repository
libmtp-common_1.1.16-2_all.deb 1.1.16 all Debian Main
libmtp-common - - -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmtp-common_1.1.16-2_all.deb
Source Package libmtp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmtp-common deb package:
    # sudo apt-get install libmtp-common

Files

Path
/lib/udev/hwdb.d/69-libmtp.hwdb
/lib/udev/rules.d/69-libmtp.rules
/usr/share/apport/package-hooks/source_libmtp.py
/usr/share/doc/libmtp-common/changelog.Debian.gz
/usr/share/doc/libmtp-common/changelog.gz
/usr/share/doc/libmtp-common/copyright
/usr/share/lintian/overrides/libmtp-common

Changelog

2019-02-09 - Dylan Aïssi <daissi@debian.org>
libmtp (1.1.16-2) unstable; urgency=medium
* Add devices patches:
- Add Onyx Boox Max 2. (Closes: #917259)
- Blacklist DUALi NFC readers. (LP: #1560452)
* Remove ' characters in d/rules to fix xsltproc call without
Internet connection.
* Add a lintian override for udev-rule-missing-subsystem tag:
SUBSYSTEM is tested at the beginning of the rules file.
* Remove libmtp.postinst and libmtp.preinst to manage all previous udev
libmtp.rules with different names. Not needed anymore since the
oldest supported versions of Debian 7 and Ubuntu 12.04 (libmtp 1.1.3)
provide a udev rule with the correct name (69-libmtp.rules).
* Remove 'Breaks+Replaces: libmtp8' fields, libmtp8 is gone since a long time.
* Remove outdated dpkg(-dev) Build-Dep and Pre-Dep.
* Restyle d/control with cme fix dpkg-control.
* Add d/gitlab-ci.yml to run the CI Salsa-Pipeline.
2019-01-21 - Dylan Aïssi <daissi@debian.org>
libmtp (1.1.16-1) unstable; urgency=medium
* New upstream release. (Closes: #889582)
- Fix udev rules for newer Linux Kernels. (Closes: #901311)
- Add new devices. (Closes: #872005, #905533)
* Update VCS fields: point to salsa.
* Add myself to Uploaders.
* Remove trailing whitespace in d/changelog.
* Do not install files in /usr/share/hal folder. (Closes: #913283)
* Add a missing space in preinst. (Closes: #900506)
* Update symbols file.
* Use secure URI in d/copyright.
* Bump Standards-Version to 4.3.0.
- Switch priority extra to optional.
* Bump debhelper compat to 12~.
* Migrate to automatic dbgsym package.
* libmtp documentation is now at /usr/share/doc/libmtp-dev.
* Remove dh-autoreconf from Build-Deps, useless since debhelper 10.
* Mark libmtp-doc as Multi-Arch: foreign.
2018-10-27 - Andreas Metzler <ametzler@debian.org>
libmtp (1.1.13-1.1) unstable; urgency=low
* Non-maintainer upload.
* B-d on libgcrypt20-dev instead of (dummy transition package)
libgcrypt11-dev. Closes: #864116
2017-04-16 - Alessio Treglia <alessio@debian.org>
libmtp (1.1.13-1) unstable; urgency=medium
* Imported Upstream version 1.1.13
2016-08-28 - Alessio Treglia <alessio@debian.org>
libmtp (1.1.12-1) unstable; urgency=medium
* Imported Upstream version 1.1.12
* Update symbols file.
* Fix FTBFS on arch-indep builds.
Thanks to Santiago Vila for the patch. (Closes: #806059)
* Bump Standards.
2016-05-25 - Alessio Treglia <alessio@debian.org>
libmtp (1.1.11-1) unstable; urgency=medium
[ Alessio Treglia ]
* Imported Upstream version 1.1.11
* Drop debian/patches/0001-players.patch, applied upstream
[ Martin Pitt ]
* debian/apport/source_libmtp.py: Stop attaching /var/log/udev (which is
only created under Upstart). Use apport's attach_hardware() instead.
(Closes: #812729)
2015-10-28 - Alessio Treglia <alessio@debian.org>
libmtp (1.1.10-2) unstable; urgency=medium
* debian/apport/source_libmtp.py:
- updated apport hook to work, import what we need, mention the
current soname version and don't include hal info. Thanks to
Sebastien Bacher for the patch. (Closes: #802601) (LP: #1172123)
* Add Noka C5-00's alternative ID (Closes: #728088)
2015-10-20 - Alessio Treglia <alessio@debian.org>
libmtp (1.1.10-1) unstable; urgency=medium
* New upstream bugfix release.
* Drop 2001-adding-bq-device-id.patch:
- 'Been adopted upstream.
* Drop 2002-adding-arale-device-id.patch:
- Adopted upstream, the device is now recognized as Meizu.
* Refresh debian/patches/series
2015-06-12 - Alessio Treglia <alessio@debian.org>
libmtp (1.1.9-3) unstable; urgency=medium
* Escape '&' to avoid generate malformed .fdi files. (Closes: #671923)
* Be honest in mtp-tools's manpage (Closes: #658367):
- Not all commands support -h, update manpage accordingly.

See Also

Package Description
libmtp-dev_1.1.16-2_i386.deb Media Transfer Protocol (MTP) development files
libmtp-doc_1.1.16-2_all.deb Media Transfer Protocol (MTP) library documentation
libmtp-runtime_1.1.16-2_i386.deb Media Transfer Protocol (MTP) runtime tools
libmtp9_1.1.16-2_i386.deb Media Transfer Protocol (MTP) library
libmuffin-dev_3.8.2-1_i386.deb lightweight window and compositing manager (development files)
libmuffin0_3.8.2-1_i386.deb lightweight window and compositing manager (shared library)
libmulticobex1-dev_0.24-5+b5_i386.deb multi-protocol cable OBEX library - development files
libmulticobex1_0.24-5+b5_i386.deb multi-protocol cable OBEX library
libmultidimensional-perl_0.014-1+b1_i386.deb Perl pragma to disable multidimensional array emulation
libmultiverse-core-java-doc_0.7.0-4_all.deb Documentation for libmultiverse-core-java
libmultiverse-core-java_0.7.0-4_all.deb Java library implementing Software Transactional Memory (STM)
libmumps-5.1.2_5.1.2-4+b2_i386.deb Direct linear systems solver - parallel shared libraries
libmumps-dev_5.1.2-4+b2_i386.deb Direct linear systems solver - parallel development files
libmumps-ptscotch-5.1.2_5.1.2-4+b2_i386.deb Direct linear systems solver - PTScotch-version shared libraries
libmumps-ptscotch-dev_5.1.2-4+b2_i386.deb Direct linear systems solver - PTScotch-version development files
Advertisement
Advertisement