libmono-corlib4.5-cil_5.18.0.240+dfsg-3_all.deb


Advertisement

Description

libmono-corlib4.5-cil - Mono core library (for CLI 4.5)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmono-corlib4.5-cil_5.18.0.240+dfsg-3_all.deb
Package name libmono-corlib4.5-cil
Package version 5.18.0.240+dfsg
Package release 3
Package architecture all
Package type deb
Category cli-mono devel::ecma-cli devel::library role::devel-lib
Homepage http://www.mono-project.com/
License -
Maintainer Debian Mono Group <pkg-mono-group@lists.alioth.debian.org>
Download size 1.19 MB
Installed size 4.58 MB
Mono is a platform for running and developing applications based on the
ECMA/ISO Standards. Mono is an open source effort led by Xamarin.
Mono provides a complete CLR (Common Language Runtime) including compiler and
runtime, which can produce and execute CIL (Common Intermediate Language)
bytecode (aka assemblies), and a class library.
This package contains the Core Library (mscorlib.dll) of Mono for CLI 4.5,
which is the glue between the BCL (Base Class Libraries) and the JIT.
You should install libmono-i18n-west4.0-cil if you are using
ISO 8859-15 (Latin 9) or other common Western European code pages.
US-ASCII, ISO 8859-1 (Latin 1) and UTF-8 users don't need any extra I18N
packages.

Alternatives

Package Version Architecture Repository
libmono-corlib4.5-cil_5.18.0.240+dfsg-3_all.deb 5.18.0.240+dfsg all Debian Main
libmono-corlib4.5-cil - - -

Requires

Name Value
mono-runtime >= 5.18.0.240
mono-runtime << 5.18.0.241
tzdata -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmono-corlib4.5-cil_5.18.0.240+dfsg-3_all.deb
Source Package mono

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmono-corlib4.5-cil deb package:
    # sudo apt-get install libmono-corlib4.5-cil

Files

Path
/usr/lib/mono/4.5/mscorlib.dll
/usr/share/doc/libmono-corlib4.5-cil/changelog.Debian.gz
/usr/share/doc/libmono-corlib4.5-cil/copyright

Changelog

2019-04-16 - Jo Shields <joshield@microsoft.com>
mono (5.18.0.240+dfsg-3) unstable; urgency=high
[ Jo Shields ]
* [20a7dd0] Don't build docs on s390x, to work around a dumb issue
[ Neale Ferguson ]
* [3713407] Fix s390x Outarg_VT (#10632)
* Fix outarg_vt processing. Fixes #10549
* Cleanup unused bits and pieces
* Correct the handling of structures being retuned from a call
* Restore vtcopy code etc.
(Closes: #921232)
2019-01-26 - Jo Shields <directhex@apebox.org>
mono (5.18.0.240+dfsg-2) unstable; urgency=medium
* [fcb8084] Add missing libmono-system-native (Closes: #920531)
* [8b705cf] Don't call cert-sync if it doesn't exist (Closes: #902663)
* [0514d12] Try fixing kFreeBSD building
2019-01-18 - Jo Shields <joshield@microsoft.com>
mono (5.18.0.240+dfsg-1) unstable; urgency=medium
[ Jo Shields ]
* [c67387f] New upstream version 5.18.0.240+dfsg
* [7a3d16f] Add reference-assemblies-with-csc patch for v4.7.2
* [5d42c62] Reorder rules so it's possible to override CFLAGS/CXXFLAGS 
per-arch
* [c1147ec] Let's not worry about LLVM for now
* [d6ff03e] Don't override GCC to 5.5 on s390x
* [e0fb8de] Enable BTLS on ppc64el
* [c842d23] Use provided mono-api-diff.exe
* [f262b7e] Install v4.7.2 API
* [871c1b3] Refreshed symbols
* [89d55c3] Use langversion 7.2 for tests (7.3 needs Roslyn)
* [ae548db] Disallow directory traversal (Closes: CVE-2018-1002208)
* [de5aae0] Switch internal dh_clideps to use ikdasm
* [b518c84] Add v4.7.2 API to dh_clideps excludes
* [be0afd7] -fstack-protector-strong breaks s390x on PIC-default gcc. 
Remove it there. (Closes: #919371)
* [73b4472] Refreshed clilibs
[ Neale Ferguson ]
* [753ee8c] Fix s390x build broken by incorrect specification of the 
msgfi instuc… (#10026)
Fix s390x build broken by incorrect specification of the msgfi
instruction used in MUL_IMM type operations. The instruction had 
been encoded as its 32-bit counterpart (msfi).
In addition, the s390x microcode makes the 
mono_strength_reduction_division unnecessary so this can be bypassed.
The change to basic.make is just to avoid error messages when 
basic-profile-check.exe hasn't been built yet.
* [cb37e0b] Simplify retrieving TLS offset
* [fecfbf8] Cater for later glibc use of ucontext
* [cc78fc2] Missing include
2019-01-12 - Jo Shields <directhex@apebox.org>
mono (5.16.0.220+dfsg3-2) unstable; urgency=medium
* No-change rebuild (Closes: #919031)

See Also

Package Description
libmono-cscompmgd0.0-cil_5.18.0.240+dfsg-3_all.deb Mono cscompmgd library (for CLI 4.0)
libmono-csharp4.0c-cil_5.18.0.240+dfsg-3_all.deb Mono.CSharp library (for CLI 4.0)
libmono-custommarshalers4.0-cil_5.18.0.240+dfsg-3_all.deb Mono CustomMarshalers library (for CLI 4.0)
libmono-data-tds4.0-cil_5.18.0.240+dfsg-3_all.deb Mono Data Library (for CLI 4.0)
libmono-db2-1.0-cil_5.18.0.240+dfsg-3_all.deb Mono DB2 library
libmono-debugger-libs-cil-dev_0+20131201.3459502-1_all.deb Mono soft debugger interface libraries - development headers
libmono-debugger-soft-cil_0+20131201.3459502-1_all.deb Mono soft debugger interface libraries - low level API
libmono-debugger-soft4.0a-cil_5.18.0.240+dfsg-3_all.deb Mono Soft Debugger library (for CLI 4.0)
libmono-debugging-cil_0+20131201.3459502-1_all.deb Mono soft debugger interface libraries - API abstraction
libmono-debugging-soft-cil_0+20131201.3459502-1_all.deb Mono soft debugger interface libraries - Mono.Debugging backend
libmono-fuse-cil_0.4.2+dfsg-4_i386.deb CLI binding for FUSE
libmono-http4.0-cil_5.18.0.240+dfsg-3_all.deb Mono.Http library (for CLI 4.0)
libmono-i18n-cjk4.0-cil_5.18.0.240+dfsg-3_all.deb Mono I18N.CJK library (for CLI 4.0)
libmono-i18n-mideast4.0-cil_5.18.0.240+dfsg-3_all.deb Mono I18N.MidEast library (for CLI 4.0)
libmono-i18n-other4.0-cil_5.18.0.240+dfsg-3_all.deb Mono I18N.Other library (for CLI 4.0)
Advertisement
Advertisement