libmodule-scandeps-perl_1.27-1_all.deb


Advertisement

Description

libmodule-scandeps-perl - module to recursively scan Perl code for dependencies

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmodule-scandeps-perl_1.27-1_all.deb
Package name libmodule-scandeps-perl
Package version 1.27
Package release 1
Package architecture all
Package type deb
Category perl role::shared-lib
Homepage https://metacpan.org/release/Module-ScanDeps
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 43.01 KB
Installed size 105.00 KB
Module::ScanDeps is a Perl module that scans potential modules used by perl
programs to determine information about modules they depend on. It performs
static analysis as well as more aggressive scanning (by running files in
compile-only or normal mode).

Alternatives

Package Version Architecture Repository
libmodule-scandeps-perl_1.27-1_all.deb 1.27 all Debian Main
libmodule-scandeps-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmodule-scandeps-perl_1.27-1_all.deb
Source Package libmodule-scandeps-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-scandeps-perl deb package:
    # sudo apt-get install libmodule-scandeps-perl

Files

Path
/usr/bin/scandeps
/usr/share/doc/libmodule-scandeps-perl/changelog.Debian.gz
/usr/share/doc/libmodule-scandeps-perl/changelog.gz
/usr/share/doc/libmodule-scandeps-perl/copyright
/usr/share/man/man1/scandeps.1p.gz
/usr/share/man/man3/Module::ScanDeps.3pm.gz
/usr/share/perl5/Module/ScanDeps.pm
/usr/share/perl5/Module/ScanDeps/Cache.pm

Changelog

2019-01-17 - gregor herrmann <gregoa@debian.org>
libmodule-scandeps-perl (1.27-1) unstable; urgency=medium
* Import upstream version 1.27.
* Refresh patch fix_references_to_renamed_executable (offset).
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.3.0.
* Bump debhelper compatibility level to 11.
* Remove trailing whitespace from debian/*.
2018-12-20 - Florian Schlichting <fsfs@debian.org>
libmodule-scandeps-perl (1.26-1) unstable; urgency=medium
* Team upload
* Import upstream version 1.26
* Refresh patch (offset)
2018-09-21 - gregor herrmann <gregoa@debian.org>
libmodule-scandeps-perl (1.25-1) unstable; urgency=medium
[ Alex Muntada ]
* Remove inactive pkg-perl members from Uploaders.
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* Import upstream version 1.25.
* Update debian/upstream/metadata.
* Refresh debian/patches/fix_references_to_renamed_executable (offset).
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.2.1.
* Bump debhelper compatibility level to 10.
2017-09-29 - Nuno Carvalho <smash@cpan.org>
libmodule-scandeps-perl (1.24-1) unstable; urgency=medium
* Team upload.
* Import upstream version 1.24.
* Refresh patch fix_references_to_renamed_executable (offset).
* debian/control:
+ Declare compliance with Debian Policy 4.1.0.
+ Update dual life libmodule-pluggable-perl required perl version
in D-B-I per cme suggestion.
2016-12-26 - gregor herrmann <gregoa@debian.org>
libmodule-scandeps-perl (1.23-1) unstable; urgency=medium
* Import upstream version 1.23.
* Refresh patch fix_references_to_renamed_executable (offset).
* debian/copyright: drop stanza about removed third-party files.
* Update debian/upstream/metadata.
2016-10-30 - gregor herrmann <gregoa@debian.org>
libmodule-scandeps-perl (1.22-1) unstable; urgency=medium
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* Remove Jonathan Yu from Uploaders. Thanks for your work!
* Remove Ryan Niebur from Uploaders. Thanks for your work!
* New upstream release.
* Add debian/upstream/metadata.
* Refresh patch fix_references_to_renamed_executable (offset).
2016-04-17 - gregor herrmann <gregoa@debian.org>
libmodule-scandeps-perl (1.21-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* New upstream release.
* Refresh patch fix_references_to_renamed_executable (offset).
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.8.
* Drop (build) dependency on Module::Metadata. The perl version in
oldstable is new enough.
2015-10-18 - gregor herrmann <gregoa@debian.org>
libmodule-scandeps-perl (1.20-1) unstable; urgency=medium
* New upstream release.
* Refresh fix_references_to_renamed_executable patch (offset).
* debian/copyright: remove stanza referring to dropped file.
* Bump debhelper compatibility level to 9.
2015-06-02 - gregor herrmann <gregoa@debian.org>
libmodule-scandeps-perl (1.19-1) unstable; urgency=medium
* New upstream release.
* Refresh debian/patches/fix_references_to_renamed_executable (offset).
* Update Upstream-Contact in debian/copyright.
* Update years of packaging copyright.
2014-10-13 - gregor herrmann <gregoa@debian.org>
libmodule-scandeps-perl (1.16-1) unstable; urgency=medium
* New upstream release.
* Refresh patch fix_references_to_renamed_executable (offset).
* Mark package as autopkgtest-able.
* Declare compliance with Debian Policy 3.9.6.

See Also

Package Description
libmodule-signature-perl_0.83-1_all.deb module to manipulate CPAN SIGNATURE files
libmodule-starter-pbp-perl_0.0.3-2_all.deb Perl module to create new perl modules following best practices
libmodule-starter-perl_1.750+dfsg-1_all.deb simple starter kit for Perl modules
libmodule-starter-plugin-cgiapp-perl_0.44-1_all.deb template based module starter for CGI apps
libmodule-starter-plugin-simplestore-perl_0.144-1_all.deb template storage methods for Module::Starter
libmodule-starter-plugin-tt2-perl_0.125-2_all.deb module providing Template toolkit support for Module::Starter
libmodule-starter-smart-perl_0.0.9-1_all.deb Module::Starter plugin to add new modules into existing distributions
libmodule-used-perl_1.3.0-2_all.deb library to detect modules loaded by Perl code without running it
libmodule-util-perl_1.09-3_all.deb Perl module to manipulate Perl module names
libmodule-versions-report-perl_1.06-2_all.deb Report versions of all modules in memory
libmodule-want-perl_0.6-2_all.deb module to check @INC only once for wanted modules
libmoe-dev_1.5.8-5_i386.deb library to handle multiple octets character encoding scheme (devel files)
libmoe1.5_1.5.8-5_i386.deb library to handle multiple octets character encoding scheme
libmojo-executor-java_2.3.0-1_all.deb Maven Mojo Executor
libmojo-ioloop-readwriteprocess-perl_0.23-1_all.deb Execute external programs or internal code blocks as separate process
Advertisement
Advertisement