libmodule-extractuse-perl_0.343-1_all.deb


Advertisement

Description

libmodule-extractuse-perl - Perl module to find out modules used by the specified Perl source

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmodule-extractuse-perl_0.343-1_all.deb
Package name libmodule-extractuse-perl
Package version 0.343
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/Module-ExtractUse
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 33.64 KB
Installed size 681.00 KB
Module::ExtractUse is basically a Parse::RecDescent grammar to parse Perl
code. It tries very hard to find all modules (whether pragmas, Core, or from
CPAN) used by the parsed code.
"Usage" is defined by either calling use or require.

Alternatives

Package Version Architecture Repository
libmodule-extractuse-perl_0.343-1_all.deb 0.343 all Debian Main
libmodule-extractuse-perl - - -

Requires

Name Value
libparse-recdescent-perl -
libpod-strip-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmodule-extractuse-perl_0.343-1_all.deb
Source Package libmodule-extractuse-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-extractuse-perl deb package:
    # sudo apt-get install libmodule-extractuse-perl

Files

Path
/usr/share/doc/libmodule-extractuse-perl/changelog.Debian.gz
/usr/share/doc/libmodule-extractuse-perl/changelog.gz
/usr/share/doc/libmodule-extractuse-perl/copyright
/usr/share/doc/libmodule-extractuse-perl/examples/cpan.pl
/usr/share/doc/libmodule-extractuse-perl/examples/extractuse.pl
/usr/share/man/man3/Module::ExtractUse.3pm.gz
/usr/share/perl5/Module/ExtractUse.pm
/usr/share/perl5/Module/ExtractUse/Grammar.pm

Changelog

2018-11-17 - gregor herrmann <gregoa@debian.org>
libmodule-extractuse-perl (0.343-1) unstable; urgency=medium
* Import upstream version 0.343.
* Declare compliance with Debian Policy 4.2.1.
2018-03-17 - gregor herrmann <gregoa@debian.org>
libmodule-extractuse-perl (0.342-1) unstable; urgency=medium
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* Import upstream version 0.342.
* debian/watch: back to only one URL, and use MetaCPAN.
* debian/rules: remove --verbose, which is the default in
debhelper nowadays.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.1.3.
* Drop unneeded version constraint from libparse-recdescent-perl
(build) dependency.
* Bump debhelper compatibility level to 10.
2016-02-21 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libmodule-extractuse-perl (0.341-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ Lucas Kanashiro ]
* Import upstream version 0.341
* d/u/metadata: update contact and repo url
* Refresh autopkgtest.patch
* d/copyright: update Upstream-Contact field
* Update email of Thomas Klausner, use CPAN email
* Update Debian packaging copyright
* Declare compliance with Debian policy 3.9.7
[ gregor herrmann ]
* Add copyright/license information for new example script.
2015-09-21 - gregor herrmann <gregoa@debian.org>
libmodule-extractuse-perl (0.33-2) unstable; urgency=medium
* Fix (hopefully) a reproducible build issue.
debian/rules: make sure that the recreated grammar file gets installed and
not the shipped one.
This also makes it possible to build the package twice in a row.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.6.
* Bump debhelper compatibility level to 9.
2014-10-17 - gregor herrmann <gregoa@debian.org>
libmodule-extractuse-perl (0.33-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* debian/watch: add second URL.
* Import upstream version 0.33
* Update upstream copyright years.
* Update libmodule-build-perl build dependency.
* Mark package as autopkgtest-able.
Add a patch to find the installed module in the tests.
* Declare compliance with Debian Policy 3.9.6.
2014-06-08 - gregor herrmann <gregoa@debian.org>
libmodule-extractuse-perl (0.32-1) unstable; urgency=medium
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Daniel Lintott ]
* Convert debian/watch back to search.cpan.org for newer releases
[ gregor herrmann ]
* New upstream release.
* Update years of packaging copyright.
* Don't install invalid and almost empty
Module::ExtractUse::Grammar(3pm).
* Declare compliance with Debian Policy 3.9.5.
2013-08-07 - Florian Schlichting <fsfs@debian.org>
libmodule-extractuse-perl (0.31-1) unstable; urgency=low
* Imported Upstream version 0.31.
* Email change: Florian Schlichting -> fsfs@debian.org.
* Update years of packaging copyright.
2013-03-02 - gregor herrmann <gregoa@debian.org>
libmodule-extractuse-perl (0.29-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Update years of packaging copyright.
* Set Standards-Version to 3.9.4 (no changes).
2012-08-26 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
libmodule-extractuse-perl (0.28-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Florian Schlichting ]
* Imported Upstream version 0.28.

See Also

Package Description
libmodule-faker-perl_0.020-1_all.deb module to build fake dists for testing CPAN tools
libmodule-find-perl_0.13-1_all.deb module to find and use installed Perl modules
libmodule-implementation-perl_0.09-1_all.deb module for loading one of several alternate implementations of a module
libmodule-info-perl_0.37-1_all.deb Perl module providing information about Perl modules
libmodule-inspector-perl_1.05-2_all.deb integrated API for inspecting Perl distributions
libmodule-install-authorrequires-perl_0.02-1_all.deb declare author-only dependencies
libmodule-install-authortests-perl_0.002-2_all.deb designate tests only run by module authors
libmodule-install-autolicense-perl_0.10-1_all.deb automagically generate LICENSE files
libmodule-install-automanifest-perl_0.003-4_all.deb generate MANIFEST automatically
libmodule-install-contributors-perl_0.001-1_all.deb add an "x_contributors" section to your META.yml
libmodule-install-copyright-perl_0.009-1_all.deb package a COPYRIGHT file with a distribution
libmodule-install-doap-perl_0.006-1_all.deb generate META.yml data from DOAP
libmodule-install-doapchangesets-perl_0.206-1_all.deb write your distribution change log in RDF
libmodule-install-extratests-perl_0.008-2_all.deb contextual tests that the harness can ignore
libmodule-install-manifestskip-perl_0.24-1_all.deb generate a MANIFEST.SKIP file
Advertisement
Advertisement