libmodule-build-perl_0.422400-1_all.deb


Advertisement

Description

libmodule-build-perl - framework for building and installing Perl modules

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmodule-build-perl_0.422400-1_all.deb
Package name libmodule-build-perl
Package version 0.422400
Package release 1
Package architecture all
Package type deb
Category devel::buildtools devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Module-Build
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 253.17 KB
Installed size 577.00 KB
Module::Build is a framework for easily building, testing and installing Perl
packages. It is meant as a next-generation replacement for ExtUtils::MakeMaker
and offers many additional features characteristic of a more modern install
system, including simple subclassing for custom build actions.
Because it is written in Pure Perl, it has very few external dependencies. In
particular, it allows for installation of packages on systems without 'make'
and will even work without a shell. Its only prerequisites are modules that
are included with perl 5.6.0 and it is core as of perl 5.10.

Alternatives

Package Version Architecture Repository
libmodule-build-perl_0.422400-1_all.deb 0.422400 all Debian Main
libmodule-build-perl - - -

Requires

Name Value
libcpan-meta-perl >= 2.142060
libtest-harness-perl >= 3.29
perl >= 5.19.5
perl >= 5.21.3
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmodule-build-perl_0.422400-1_all.deb
Source Package libmodule-build-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-build-perl deb package:
    # sudo apt-get install libmodule-build-perl

Files

Path
/usr/bin/config_data
/usr/share/doc/libmodule-build-perl/NEWS.Debian.gz
/usr/share/doc/libmodule-build-perl/changelog.Debian.gz
/usr/share/doc/libmodule-build-perl/changelog.gz
/usr/share/doc/libmodule-build-perl/copyright
/usr/share/doc/libmodule-build-perl/examples/bash_completion.module-build
/usr/share/man/man1/config_data.1p.gz
/usr/share/man/man3/Module::Build.3pm.gz
/usr/share/man/man3/Module::Build::API.3pm.gz
/usr/share/man/man3/Module::Build::Authoring.3pm.gz
/usr/share/man/man3/Module::Build::Base.3pm.gz
/usr/share/man/man3/Module::Build::Bundling.3pm.gz
/usr/share/man/man3/Module::Build::Compat.3pm.gz
/usr/share/man/man3/Module::Build::ConfigData.3pm.gz
/usr/share/man/man3/Module::Build::Cookbook.3pm.gz
/usr/share/man/man3/Module::Build::Notes.3pm.gz
/usr/share/man/man3/Module::Build::PPMMaker.3pm.gz
/usr/share/man/man3/Module::Build::Platform::Default.3pm.gz
/usr/share/man/man3/Module::Build::Platform::MacOS.3pm.gz
/usr/share/man/man3/Module::Build::Platform::Unix.3pm.gz
/usr/share/man/man3/Module::Build::Platform::VMS.3pm.gz
/usr/share/man/man3/Module::Build::Platform::VOS.3pm.gz
/usr/share/man/man3/Module::Build::Platform::Windows.3pm.gz
/usr/share/man/man3/Module::Build::Platform::aix.3pm.gz
/usr/share/man/man3/Module::Build::Platform::cygwin.3pm.gz
/usr/share/man/man3/Module::Build::Platform::darwin.3pm.gz
/usr/share/man/man3/Module::Build::Platform::os2.3pm.gz
/usr/share/perl5/Module/Build.pm
/usr/share/perl5/Module/Build/API.pod
/usr/share/perl5/Module/Build/Authoring.pod
/usr/share/perl5/Module/Build/Base.pm
/usr/share/perl5/Module/Build/Bundling.pod
/usr/share/perl5/Module/Build/Compat.pm
/usr/share/perl5/Module/Build/Config.pm
/usr/share/perl5/Module/Build/ConfigData.pm
/usr/share/perl5/Module/Build/Cookbook.pm
/usr/share/perl5/Module/Build/Dumper.pm
/usr/share/perl5/Module/Build/Notes.pm
/usr/share/perl5/Module/Build/PPMMaker.pm
/usr/share/perl5/Module/Build/PodParser.pm
/usr/share/perl5/Module/Build/Platform/Default.pm
/usr/share/perl5/Module/Build/Platform/MacOS.pm
/usr/share/perl5/Module/Build/Platform/Unix.pm
/usr/share/perl5/Module/Build/Platform/VMS.pm
/usr/share/perl5/Module/Build/Platform/VOS.pm
/usr/share/perl5/Module/Build/Platform/Windows.pm
/usr/share/perl5/Module/Build/Platform/aix.pm
/usr/share/perl5/Module/Build/Platform/cygwin.pm
/usr/share/perl5/Module/Build/Platform/darwin.pm
/usr/share/perl5/Module/Build/Platform/os2.pm

Changelog

2017-06-19 - gregor herrmann <gregoa@debian.org>
libmodule-build-perl (0.422400-1) unstable; urgency=medium
* Add debian/gbp.conf to tell gbp import-orig to merge the upstream
branch instead of replacing it, which is the new default. This is
needed as we use git-debcherry in this package.
* Import upstream version 0.422400.
* Update years of packaging copyright.
* Update patches with git-debcherry.
- Remove 0003-Make-Module-Build-set-PERL_UNSAFE_INC.patch (fixed upstream)
- Refresh patch man-ext (offset)
* Declare compliance with Debian Policy 4.0.0.
2016-10-11 - Florian Schlichting <fsfs@debian.org>
libmodule-build-perl (0.422000-1) unstable; urgency=medium
[ gregor herrmann ]
* Remove Antonio Radici from Uploaders. Thanks for your work!
* Remove Jay Bonci from Uploaders. Thanks for your work!
* Remove Jonathan Yu from Uploaders. Thanks for your work!
* Remove Ryan Niebur from Uploaders. Thanks for your work!
[ Florian Schlichting ]
* Import upstream version 0.422000
* Refresh patches (run-debcherry)
* Update copyright years
2016-07-25 - gregor herrmann <gregoa@debian.org>
libmodule-build-perl (0.421800-2) unstable; urgency=medium
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Niko Tyni ]
* Make Module::Build set PERL_UNSAFE_INC.
Cf. CVE-2016-1238.
[ gregor herrmann ]
* debian/upstream/metadata: add Bug-Database.
2016-04-29 - gregor herrmann <gregoa@debian.org>
libmodule-build-perl (0.421800-1) unstable; urgency=medium
* Import upstream version 0.421800.
* Drop all old alternative (build) dependencies where perl-core in
oldstable has new enough versions.
* Declare compliance with Debian Policy 3.9.8.
2016-02-02 - gregor herrmann <gregoa@debian.org>
libmodule-build-perl (0.421600-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* Import upstream version 0.421600.
* Refresh patches with git-debcherry (offset).
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.7.
* Change order of alternative (build) dependencies.
* Add (build) dependency on TAP::Harness 3.29.
* Bump debhelper compatibility level to 9.
2015-09-14 - Niko Tyni <ntyni@debian.org>
libmodule-build-perl (0.421400-3) unstable; urgency=medium
* Refine the rscan_dir() result sorting to ensure that regular files
get listed before directories. (Closes: #798882)
2015-09-10 - Florian Schlichting <fsfs@debian.org>
libmodule-build-perl (0.421400-2) unstable; urgency=medium
* Add patch from Niko Tyni to sort file linking order so that reproducible
binaries are being produced (closes: #797709)
* Convert patch management to git-debcherry
2015-07-07 - gregor herrmann <gregoa@debian.org>
libmodule-build-perl (0.421400-1) unstable; urgency=medium
* Import upstream version 0.421400.
* Drop output-data-in-stable-order.patch, merged upstream.
2015-05-20 - Dominique Dumont <dod@debian.org>
libmodule-build-perl (0.421100-2) unstable; urgency=low
[ Jérémy Bobbio ]
* Add a patch to output data in stable order to make builds reproducible.
(Closes: #774869)
[ Dominique Dumont ]
* control: added dod to uploaders
* control: removed obsolete packages from dependencies
* control: refreshed with cme
2015-05-02 - gregor herrmann <gregoa@debian.org>
libmodule-build-perl (0.421100-1) unstable; urgency=medium
* Import upstream version 0.421100.
Splits out inc::latest to a separate CPAN distribution.
* Update years of packaging copyright.
Remove stanza about dropped files.
* Declare compliance with Debian Policy 3.9.6.

See Also

Package Description
libmodule-build-pluggable-perl_0.10-1_all.deb plugins for the perl module Module::Build
libmodule-build-pluggable-ppport-perl_0.04-1_all.deb module to generate a ppport.h file automatically
libmodule-build-tiny-perl_0.039-1_all.deb tiny replacement for Module::Build
libmodule-build-withxspp-perl_0.14-3_all.deb XS++ enhanced flavour of Module::Build
libmodule-build-xsutil-perl_0.19-1_all.deb Module::Build class for building XS modules
libmodule-bundled-files-perl_0.03-1_all.deb perl module to access files bundled with your module
libmodule-compile-perl_0.37-1_all.deb Perl module providing a system to compile Perl modules
libmodule-corelist-perl_5.20190220-1_all.deb module to determine modules shipped with perl
libmodule-cpanfile-perl_1.1004-1_all.deb format for describing CPAN dependencies of Perl applications
libmodule-cpants-analyse-perl_0.99-1_all.deb Perl module to generate Kwalitee ratings for a distribution
libmodule-depends-perl_0.16-3_all.deb Perl module to identify the dependencies of a distribution
libmodule-extract-perl_0.01-2_all.deb base class for working with Perl distributions
libmodule-extract-use-perl_1.043-1_all.deb Perl module to extract which modules some code uses
libmodule-extractuse-perl_0.343-1_all.deb Perl module to find out modules used by the specified Perl source
libmodule-faker-perl_0.020-1_all.deb module to build fake dists for testing CPAN tools
Advertisement
Advertisement