libmodglue1v5_1.17-3_i386.deb


Advertisement

Description

libmodglue1v5 - C++ library for handling of multiple co-processes

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmodglue1v5_1.17-3_i386.deb
Package name libmodglue1v5
Package version 1.17
Package release 3
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.aei.mpg.de/~peekas/modglue/
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 65.38 KB
Installed size 288.00 KB
Modglue is a C++ library with classes for forking external
processes and asynchronous reading from streams. It takes
away the burden of all subtleties involving the Unix fork
call. The asynchronous read facility enables one to read on
multiple input streams at the same time, without losing any
of the standard C++ stream facilities.

Alternatives

Package Version Architecture Repository
libmodglue1v5_1.17-3_amd64.deb 1.17 amd64 Debian Main
libmodglue1v5 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libsigc++-2.0-0v5 >= 2.8.0
libstdc++6 >= 5.2

Replaces

Name Value
libmodglue1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmodglue1v5_1.17-3_i386.deb
Source Package modglue

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodglue1v5 deb package:
    # sudo apt-get install libmodglue1v5

Files

Path
/usr/bin/prompt
/usr/bin/ptywrap
/usr/lib/i386-linux-gnu/libmodglue.a
/usr/lib/i386-linux-gnu/libmodglue.so.1
/usr/lib/i386-linux-gnu/libmodglue.so.1.0.17
/usr/lib/i386-linux-gnu/pkgconfig/modglue.pc
/usr/share/doc/libmodglue1v5/changelog.Debian.gz
/usr/share/doc/libmodglue1v5/changelog.gz
/usr/share/doc/libmodglue1v5/copyright
/usr/share/man/man1/prompt.1.gz
/usr/share/man/man1/ptywrap.1.gz

Changelog

2017-01-10 - Andreas Beckmann <anbe@debian.org>
modglue (1.17-3) unstable; urgency=medium
* QA upload.
* Set Maintainer to Debian QA Group.  (See: #834847)
* Acknowledge NMU.  (Closes: #815337)
* Update watch file.  (Closes: #731571)
* Make the build reproducible, thanks to Reiner Herrmann.  (Closes: #829762)
* Switch to debhelper compat level 10 and minimal dh rules.
* Update debian/copyright to copyright-format 1.0.
* Bump Standards-Version to 3.9.8, no changes needed.
2015-09-12 - Andreas Beckmann <anbe@debian.org>
modglue (1.17-2.4) unstable; urgency=medium
* Non-maintainer upload.
* libmodglue1v5: Add Breaks+Replaces: libmodglue1.  (Closes: #796864)
* Drop obsolete DMUA flag.
2015-08-14 - Jonathan Wiltshire <jmw@debian.org>
modglue (1.17-2.3) unstable; urgency=medium
* Non-maintainer upload.
* Rename library packages for g++ 5 transition (see #791204)
* Make libmodglue1-dev arch:any so that it can have a tight
dependency on the library package, and add that dependency
2014-10-09 - Matthias Klose <doko@debian.org>
modglue (1.17-2.2) unstable; urgency=medium
* Non-maintainer upload.
* Build-depend on libtool-bin. Closes: #761777.
2011-06-26 - Luk Claes <luk@debian.org>
modglue (1.17-2.1) unstable; urgency=low
* Non-maintainer upload.
* Don't ship .la files (Closes: #622533).
* Add sigc++ libs for linking (Closes: #555662).
* Make sure the package is binNMUable.
2010-05-31 - Iulian Udrea <iulian@ubuntu.com>
modglue (1.17-2) unstable; urgency=low
* Replace ${binary:Version} with libmodglue1 (= ${binary:Version}).
libmodglue1-dev became uninstallable in Sid as it depended on the
package "1.17-1" which obviously didn't exist.  Closes: #583816.
2010-05-28 - Iulian Udrea <iulian@ubuntu.com>
modglue (1.17-1) unstable; urgency=low
* New upstream release.
+ Fix FTBFS.  Closes: #582996.
+ Remove RPATH from prompt.
+ Fix 'incorrect-libdir-in-la-file usr/lib/libmodglue.la /usr//lib !=
/usr/lib' lintian error.
* Add chrpath to Build-Depends.
* Add ${binary:Version} to fix 'weak-library-dev-dependency' lintian
error.
2010-05-25 - Iulian Udrea <iulian@ubuntu.com>
modglue (1.16-1) unstable; urgency=low
* New upstream release.
+ Fixed problem with gcc-4.4.
* New maintainer.
* debian/control:
- Add DM-Upload-Allowed field.
- Bump Standards-Version to 3.8.4 (no changes required).
- Add ${misc:Depends} to both libmodglue1 and libmodglue1-dev
* Use DEP-5: Machine-readable debian/copyright.
* Add myself to copyright.
* Drop debian/patches/01-gcc44_ftbfs.dpatch
* Remove dpatch from debian/rules and debian/control.
* Switch to 3.0 (quilt) source format.
* Bump debhelper version to 7.0.50.
2009-08-19 - Gürkan Sengün <gurkan@phys.ethz.ch>
modglue (1.13-1) unstable; urgency=low
* Initial release.

See Also

Package Description
libmodhmm-dev_1.0+dfsg-3_i386.deb library for constructing, training and scoring hidden Markov models (dev)
libmodhmm0_1.0+dfsg-3_i386.deb library for constructing, training and scoring hidden Markov models
libmodpbase64-0_3.10.3+git20160924-3_i386.deb collection of high performance c-string transformations
libmodpbase64-dev_3.10.3+git20160924-3_i386.deb collection of high performance c-string transformations (development files)
libmodplug-dev_0.8.9.0-2_i386.deb development files for mod music based on ModPlug
libmodplug1_0.8.9.0-2_i386.deb shared libraries for mod music based on ModPlug
libmods-record-perl_0.13-1_all.deb module for handling MODS records
libmodsecurity-dev_3.0.3-1_i386.deb ModSecurity v3 library component (development files)
libmodsecurity3_3.0.3-1_i386.deb ModSecurity v3 library component
libmodulator-java_1.0-3_all.deb Java small shim library that wraps Java 9 APIs and exposes them to recent JDKs
libmodule-build-cleaninstall-perl_0.5-3_all.deb module for removing the old module before installing the new one
libmodule-build-perl_0.422400-1_all.deb framework for building and installing Perl modules
libmodule-build-pluggable-perl_0.10-1_all.deb plugins for the perl module Module::Build
libmodule-build-pluggable-ppport-perl_0.04-1_all.deb module to generate a ppport.h file automatically
libmodule-build-tiny-perl_0.039-1_all.deb tiny replacement for Module::Build
Advertisement
Advertisement