libmodern-perl-perl_1.20180901-1_all.deb


Advertisement

Description

libmodern-perl-perl - module for enabling all of the features of Modern Perl

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmodern-perl-perl_1.20180901-1_all.deb
Package name libmodern-perl-perl
Package version 1.20180901
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/Modern-Perl
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 10.90 KB
Installed size 26.00 KB
Modern Perl programs use several modules to enable additional features of
Perl and of the CPAN. Instead of copying and pasting all of these 'use'
lines, instead write only one:
use Modern::Perl;
This enables the strict and warnings pragmas, as well as all of the features
available since Perl 5.10.
For enabling features of newer Perl releases, a year can be specified as an
import tag, e.g.:
use Modern::Perl '2017';
enables 5.24 features. Cf. Modern::Perl(3pm) for details.
See http://www.modernperlbooks.com/mt/2009/01/toward-a-modernperl.html for
more information, http://www.modernperlbooks.com/ for further discussion of
Modern Perl and its implications, and
http://onyxneon.com/books/modern_perl/index.html for a freely-downloadable
Modern Perl tutorial.

Alternatives

Package Version Architecture Repository
libmodern-perl-perl_1.20180901-1_all.deb 1.20180901 all Debian Main
libmodern-perl-perl - - -

Requires

Name Value
libautodie-perl >= 2.22
perl >= 5.19.5
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmodern-perl-perl_1.20180901-1_all.deb
Source Package libmodern-perl-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodern-perl-perl deb package:
    # sudo apt-get install libmodern-perl-perl

Files

Path
/usr/share/doc/libmodern-perl-perl/changelog.Debian.gz
/usr/share/doc/libmodern-perl-perl/changelog.gz
/usr/share/doc/libmodern-perl-perl/copyright
/usr/share/man/man3/Modern::Perl.3pm.gz
/usr/share/perl5/Modern/Perl.pm

Changelog

2018-09-07 - gregor herrmann <gregoa@debian.org>
libmodern-perl-perl (1.20180901-1) unstable; urgency=medium
[ Xavier Guimard ]
* Email change: Xavier Guimard -> yadd@debian.org
* Set an email to upstream contact in debian/copyright
* Declare compliance with policy 4.2.1
[ gregor herrmann ]
* Import upstream version 1.20180901.
* Update years of packaging copyright.
2018-07-05 - Xavier Guimard <x.guimard@free.fr>
libmodern-perl-perl (1.20180701-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ Xavier Guimard ]
* Import upstream version 1.20180701
* Update copyright years
* Declare compliance with policy 4.1.5
* Update debhelper compatibility level to 10
2017-01-21 - gregor herrmann <gregoa@debian.org>
libmodern-perl-perl (1.20170117-1) unstable; urgency=medium
* Import upstream version 1.20170117.
* Update years of upstream and packaging copyright.
* Drop Breaks/Replaces libmodern-perl.
libmodern-perl is not in any suite going back to oldstable.
* Update long description to mention newest features.
2017-01-05 - Nick Morrott <knowledgejunkie@gmail.com>
libmodern-perl-perl (1.20161229-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Nick Morrott ]
* Import upstream version 1.20161229
* debian/copyright: update copyright years
* debian/upstream/metadata: add/update metadata
* Update debhelper compatibility level to 9
* debian/control: declare compliance with Debian Policy 3.9.8
2015-06-06 - Salvatore Bonaccorso <carnil@debian.org>
libmodern-perl-perl (1.20150127-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Add debian/upstream/metadata
* Import upstream version 1.20150127
* Update copyright years for upstream files
* Drop alternative Build-Depends-Indep for Test::More.
Test::More in the required version is already in Perl in wheezy.
* Declare the package autopkgtestable
* Declare compliance with Debian policy 3.9.6
* Add explicit Build-Depends on libmodule-build-perl
* Remove perl from Build-Depends
2014-01-11 - gregor herrmann <gregoa@debian.org>
libmodern-perl-perl (1.20140107-1) unstable; urgency=medium
* New upstream release.
* Update years of copyright.
* Update (build) dependencies.
* Update long description. (Closes: #708239)
* Declare compliance with Debian Policy 3.9.5.
2013-03-31 - Xavier Guimard <x.guimard@free.fr>
libmodern-perl-perl (1.20121103-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Xavier Guimard ]
* Imported Upstream version 1.20121103
* Bump Standards-Version to 3.9.4
* Update debian/copyright (years and format)
2012-05-27 - Salvatore Bonaccorso <carnil@debian.org>
libmodern-perl-perl (1.20120521-1) unstable; urgency=low
* Team upload.
[ gregor herrmann ]
* New upstream release (1.20120130).
[ Salvatore Bonaccorso ]
* Imported Upstream version 1.20120521
* Update format for debian/copyright file.
Update format to copyright-format 1.0 as released together with Debian
policy 3.9.3.
* Bump Standards-Version to 3.9.3
2012-01-28 - gregor herrmann <gregoa@debian.org>
libmodern-perl-perl (1.20120126-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
libmodglue1-dev_1.17-3_i386.deb development files for a C++ library for handling of multiple co-processes
libmodglue1v5_1.17-3_i386.deb C++ library for handling of multiple co-processes
libmodhmm-dev_1.0+dfsg-3_i386.deb library for constructing, training and scoring hidden Markov models (dev)
libmodhmm0_1.0+dfsg-3_i386.deb library for constructing, training and scoring hidden Markov models
libmodpbase64-0_3.10.3+git20160924-3_i386.deb collection of high performance c-string transformations
libmodpbase64-dev_3.10.3+git20160924-3_i386.deb collection of high performance c-string transformations (development files)
libmodplug-dev_0.8.9.0-2_i386.deb development files for mod music based on ModPlug
libmodplug1_0.8.9.0-2_i386.deb shared libraries for mod music based on ModPlug
libmods-record-perl_0.13-1_all.deb module for handling MODS records
libmodsecurity-dev_3.0.3-1_i386.deb ModSecurity v3 library component (development files)
libmodsecurity3_3.0.3-1_i386.deb ModSecurity v3 library component
libmodulator-java_1.0-3_all.deb Java small shim library that wraps Java 9 APIs and exposes them to recent JDKs
libmodule-build-cleaninstall-perl_0.5-3_all.deb module for removing the old module before installing the new one
libmodule-build-perl_0.422400-1_all.deb framework for building and installing Perl modules
libmodule-build-pluggable-perl_0.10-1_all.deb plugins for the perl module Module::Build
Advertisement
Advertisement