libmediawiki-api-perl_0.41-1_all.deb


Advertisement

Description

libmediawiki-api-perl - Perl interface to the MediaWiki API

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmediawiki-api-perl_0.41-1_all.deb
Package name libmediawiki-api-perl
Package version 0.41
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/MediaWiki-API
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 27.41 KB
Installed size 67.00 KB
MediaWiki::API is a Perl module that provides an interface to the MediaWiki
API (see <URL:http://www.mediawiki.org/wiki/API>), which allows the creation
of scripts to automate editing and extraction of data from MediaWiki-driven
sites like Wikipedia.

Alternatives

Package Version Architecture Repository
libmediawiki-api-perl_0.41-1_all.deb 0.41 all Debian Main
libmediawiki-api-perl - - -

Requires

Name Value
libjson-perl -
libwww-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmediawiki-api-perl_0.41-1_all.deb
Source Package libmediawiki-api-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmediawiki-api-perl deb package:
    # sudo apt-get install libmediawiki-api-perl

Files

Path
/usr/share/doc/libmediawiki-api-perl/changelog.Debian.gz
/usr/share/doc/libmediawiki-api-perl/changelog.gz
/usr/share/doc/libmediawiki-api-perl/copyright
/usr/share/man/man3/MediaWiki::API.3pm.gz
/usr/share/perl5/MediaWiki/API.pm

Changelog

2015-11-22 - gregor herrmann <gregoa@debian.org>
libmediawiki-api-perl (0.41-1) unstable; urgency=medium
* Import upstream version 0.41.
* Update years of packaging copyright.
* Bump debhelper compatibility level to 9.
2014-10-17 - gregor herrmann <gregoa@debian.org>
libmediawiki-api-perl (0.40-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Update Vcs-Browser URL to cgit web frontend
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Update years of upstream and packaging copyright.
* Update DEP3 headers of patch disable-network-test.diff.
* Add debian/upstream/metadata
* Mark package as autopkgtest-able.
* Declare compliance with Debian Policy 3.9.6.
2012-06-08 - gregor herrmann <gregoa@debian.org>
libmediawiki-api-perl (0.39-1) unstable; urgency=low
* New upstream release.
* debian/copyright: update to Copyright-Format 1.0.
* Update years of upstream copyright.
* Bump Standards-Version to 3.9.3 (no changes).
* Set debhelper compatibility level to 8.
* Build depend on Test::More 0.98.
* Add /me to Uploaders.
2011-08-10 - Ansgar Burchardt <ansgar@debian.org>
libmediawiki-api-perl (0.37-1) unstable; urgency=low
* New upstream release.
2011-08-08 - Ansgar Burchardt <ansgar@debian.org>
libmediawiki-api-perl (0.36-1) unstable; urgency=low
[ Ansgar Burchardt ]
* New upstream release.
* Disable tests that rely on a working network connection.
+ new patch: disable-network-test.diff
* debian/copyright: Update years of copyright.
* Update my email address.
* debian/control: Convert Vcs-* fields to Git.
* Bump Standards-Version to 3.9.2 (no changes).
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
2010-09-01 - Ansgar Burchardt <ansgar@43-1.org>
libmediawiki-api-perl (0.35-1) unstable; urgency=low
* New upstream release
* debian/copyright: Refer to /usr/share/common-licenses/GPL-1; refer to
"Debian systems" instead of "Debian GNU/Linux systems".
* Bump Standards-Version to 3.9.1.
2010-07-26 - Ansgar Burchardt <ansgar@43-1.org>
libmediawiki-api-perl (0.34-1) unstable; urgency=low
* New upstream release.
* Bump Standards-Version to 3.9.0 (no changes).
2010-06-11 - Ansgar Burchardt <ansgar@43-1.org>
libmediawiki-api-perl (0.33-1) unstable; urgency=low
* New upstream release.
2010-06-06 - Ansgar Burchardt <ansgar@43-1.org>
libmediawiki-api-perl (0.32-1) unstable; urgency=low
* New upstream release.
2010-04-10 - Ansgar Burchardt <ansgar@43-1.org>
libmediawiki-api-perl (0.30-1) unstable; urgency=low
* New upstream release.
* Use source format 3.0 (quilt).
* Bump Standards-Version to 3.8.4 (no changes).
* Add myself to Uploaders.

See Also

Package Description
libmediawiki-bot-perl_5.006003-1_all.deb high-level bot framework for interacting with MediaWiki wikis
libmediawiki-dumpfile-perl_0.2.2-1_all.deb Perl module to parse MediaWiki dump files
libmedimport-dev_4.0.0+repack-7_i386.deb Development files for libmedimport0
libmedimport0v5_4.0.0+repack-7_i386.deb Library to import old version files
libmedley-clojure_1.0.0-1_all.deb Clojure/ClojureScript utility library
libmeep-dev_1.7.0-3_i386.deb development library for using meep
libmeep-lam4-12_1.7.0-3_i386.deb library for using parallel (OpenMPI) version of meep
libmeep-lam4-dev_1.7.0-3_i386.deb development library for using parallel (OpenMPI) version of meep
libmeep-mpi-default-dev_1.7.0-3_i386.deb development library for using parallel (OpenMPI) version of meep
libmeep-mpi-default12_1.7.0-3_i386.deb library for using parallel (OpenMPI) version of meep
libmeep-mpich2-12_1.7.0-3_i386.deb library for using parallel (OpenMPI) version of meep
libmeep-mpich2-dev_1.7.0-3_i386.deb development library for using parallel (OpenMPI) version of meep
libmeep-openmpi-dev_1.7.0-3_i386.deb development library for using parallel (OpenMPI) version of meep
libmeep-openmpi12_1.7.0-3_i386.deb library for using parallel (OpenMPI) version of meep
libmeep12_1.7.0-3_i386.deb library for using meep
Advertisement
Advertisement