libmediastreamer-voip10_2.16.1-4+b1_i386.deb


Advertisement

Description

libmediastreamer-voip10 - Voice and video streaming engine for telephony (voip)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libmediastreamer-voip10_2.16.1-4+b1_i386.deb
Package name libmediastreamer-voip10
Package version 2.16.1
Package release 4+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.linphone.org/technical-corner/mediastreamer2/overview
License -
Maintainer Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>
Download size 240.02 KB
Installed size 710.00 KB
Mediastreamer2 is a powerful and lightweight streaming engine
specially designed for voice/video telephony applications.
This open source library is responsible for all receiving and
sending of multimedia streams in Linphone, including voice/video
capture, encoding, decoding, and rendering.
This package contains the voip library.

Alternatives

Package Version Architecture Repository
libmediastreamer-voip10_2.16.1-4+b1_amd64.deb 2.16.1 amd64 Debian Main
libmediastreamer-voip10 - - -

Requires

Name Value
libasound2 >= 1.0.16
libavcodec58 >= 7:4.0
libavutil56 >= 7:4.0
libbctoolbox1 >= 0.6.0
libbctoolbox1 << 0.7.0
libbzrtp0 >= 1.0.6
libc6 >= 2.27
libgcc1 >= 1:4.2
libgl1 -
libglew2.1 >= 1.12.0
libgsm1 >= 1.0.13
libmediastreamer-base10 >= 1:2.16.1
libopus0 >= 1.1
libortp13 >= 1:1.0.2
libpulse0 >= 0.99.1
libspeex1 >= 1.2~beta3-1
libspeexdsp1 >= 1.2~beta3.2-1
libsrtp2-1 >= 2.0.0
libswscale5 >= 7:4.0
libtheora0 >= 0.0.0.alpha7.dfsg
libturbojpeg0 >= 1.4.0
libvpx5 >= 1.6.0
libx11-6 -
libxv1 -

Replaces

Name Value
libmediastreamer-base4 << 1:2.16.1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmediastreamer-voip10_2.16.1-4+b1_i386.deb
Source Package mediastreamer2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmediastreamer-voip10 deb package:
    # sudo apt-get install libmediastreamer-voip10

Files

Path
/usr/lib/i386-linux-gnu/libmediastreamer_voip.so.10
/usr/share/doc/libmediastreamer-voip10/changelog.Debian.gz
/usr/share/doc/libmediastreamer-voip10/changelog.Debian.i386.gz
/usr/share/doc/libmediastreamer-voip10/changelog.gz
/usr/share/doc/libmediastreamer-voip10/copyright

Changelog

2018-10-10 - Bernhard Schmidt <berni@debian.org>
mediastreamer2 (1:2.16.1-4) unstable; urgency=medium
* Team upload.
* Release to unstable
2018-10-03 - Bernhard Schmidt <berni@debian.org>
mediastreamer2 (1:2.16.1-3) experimental; urgency=medium
* Team upload.
[ Dr. Tobias Quathamer ]
* Switch Vcs-URLs to salsa.d.o
* Add patch to fix possible breakage with FFmpeg 4.0.
Thanks to James Cowgill <jcowgill@debian.org> (Closes: #901735)
* Use debhelper v11
* Update Standards-Version to 4.1.4, no changes needed
[ Bernhard Schmidt ]
* Switch to libsrtp2, cherry-picking an upstream commit
* Fix FTBFS with GCC-8 (cherry-pick two upstream commits) (Closes: #905481)
* remove superfluous libmediastreamer-dev.docs
2017-11-18 - Dr. Tobias Quathamer <toddy@debian.org>
mediastreamer2 (1:2.16.1-2) experimental; urgency=medium
* Team upload.
* Use DEB_LDFLAGS_MAINT_APPEND instead of DEB_LDFLAGS_APPEND
2017-11-16 - Dr. Tobias Quathamer <toddy@debian.org>
mediastreamer2 (1:2.16.1-1) experimental; urgency=medium
* Team upload.
[ Felix Lechner ]
* Initial release separate from linphone (Closes: #787150)
[ Johannes 'josch' Schauer ]
* New upstream version 2.15.1
- Update build dependencies
- Switch from autotools to CMake (upstream deprecated autotools)
- debian/patches/fix-spelling-errors.patch: fix more spelling mistakes
* debian/control: drop *-dbg packages in favour of automatically
generated *-dbgsym packages
* debian/compat: Bump debhelper compatibility level to 10
* debian/control: bump Standards-Version (no changes required)
* debian/rules: Use hardening=+all
* Remove debian/libmediastreamer-voip9.lintian-overrides because
there is no embedded library anymore
* Unify libmediastreamer-base-dev and libmediastreamer-voip-dev into
libmediastreamer-dev. linphone is the only user of the package and
there is no reason to split them.
[ Dr. Tobias Quathamer ]
* New upstream version 2.16.1
- Refresh patches
- Add libxml2-dev to Build-Depends
- Create the needed gitversion.h file
* Use HTTPS URLs
* Bump library .so name from 9 to 10
* Remove unneeded script mkdeb.sh
* Update Standards-Version to 4.1.1
* Remove unneeded lintian override for source package
* Add new library symbols
* Add -Wl,--as-needed to DEB_LDFLAGS_APPEND

See Also

Package Description
libmediawiki-api-perl_0.41-1_all.deb Perl interface to the MediaWiki API
libmediawiki-bot-perl_5.006003-1_all.deb high-level bot framework for interacting with MediaWiki wikis
libmediawiki-dumpfile-perl_0.2.2-1_all.deb Perl module to parse MediaWiki dump files
libmedimport-dev_4.0.0+repack-7_i386.deb Development files for libmedimport0
libmedimport0v5_4.0.0+repack-7_i386.deb Library to import old version files
libmedley-clojure_1.0.0-1_all.deb Clojure/ClojureScript utility library
libmeep-dev_1.7.0-3_i386.deb development library for using meep
libmeep-lam4-12_1.7.0-3_i386.deb library for using parallel (OpenMPI) version of meep
libmeep-lam4-dev_1.7.0-3_i386.deb development library for using parallel (OpenMPI) version of meep
libmeep-mpi-default-dev_1.7.0-3_i386.deb development library for using parallel (OpenMPI) version of meep
libmeep-mpi-default12_1.7.0-3_i386.deb library for using parallel (OpenMPI) version of meep
libmeep-mpich2-12_1.7.0-3_i386.deb library for using parallel (OpenMPI) version of meep
libmeep-mpich2-dev_1.7.0-3_i386.deb development library for using parallel (OpenMPI) version of meep
libmeep-openmpi-dev_1.7.0-3_i386.deb development library for using parallel (OpenMPI) version of meep
libmeep-openmpi12_1.7.0-3_i386.deb library for using parallel (OpenMPI) version of meep
Advertisement
Advertisement