libm17n-0_1.8.0-2_i386.deb


Advertisement

Description

libm17n-0 - multilingual text processing library - runtime

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libm17n-0_1.8.0-2_i386.deb
Package name libm17n-0
Package version 1.8.0
Package release 2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://www.nongnu.org/m17n/
License -
Maintainer Harshula Jayasuriya <harshula@debian.org>
Download size 258.90 KB
Installed size 686.00 KB
The m17n library is a multilingual text processing library for the C
language.  This library has following features:
- The m17n library is an open source software.
- The m17n library for any Linux/Unix applications.
- The m17n library realizes multilingualization of many aspects of
applications.
- The m17n library represents multilingual text as an object named
M-text.  M-text is a string with attributes called text properties,
and designed to substitute for string in C.  Text properties carry any
information required to input, display and edit the text.
- The m17n library  supports functions to handle M-texts.
m17n is an abbreviation of Multilingualization.
This package contains the runtime part of m17n-lib.

Alternatives

Package Version Architecture Repository
libm17n-0_1.8.0-2_amd64.deb 1.8.0 amd64 Debian Main
libm17n-0 - - -

Requires

Name Value
libc6 >= 2.27
libfontconfig1 >= 2.12.6
libfreetype6 >= 2.2.1
libfribidi0 >= 0.19.2
libgd3 >= 2.1.0~alpha~
libice6 >= 1:1.0.0
libotf0 >= 0.9.11
libsm6 -
libthai0 >= 0.1.12
libx11-6 -
libxft2 >> 2.1.1
libxml2 >= 2.7.4
libxt6 -
m17n-db >= 1.6.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libm17n-0_1.8.0-2_i386.deb
Source Package m17n-lib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libm17n-0 deb package:
    # sudo apt-get install libm17n-0

Files

Path
/usr/lib/i386-linux-gnu/libm17n-core.so.0
/usr/lib/i386-linux-gnu/libm17n-core.so.0.4.2
/usr/lib/i386-linux-gnu/libm17n-flt.so.0
/usr/lib/i386-linux-gnu/libm17n-flt.so.0.4.2
/usr/lib/i386-linux-gnu/libm17n-gui.so.0
/usr/lib/i386-linux-gnu/libm17n-gui.so.0.4.2
/usr/lib/i386-linux-gnu/libm17n.so.0
/usr/lib/i386-linux-gnu/libm17n.so.0.4.2
/usr/lib/i386-linux-gnu/m17n/1.0/libm17n-X.so
/usr/lib/i386-linux-gnu/m17n/1.0/libm17n-gd.so
/usr/share/doc/libm17n-0/AUTHORS
/usr/share/doc/libm17n-0/NEWS.gz
/usr/share/doc/libm17n-0/README.gz
/usr/share/doc/libm17n-0/TODO
/usr/share/doc/libm17n-0/changelog.Debian.gz
/usr/share/doc/libm17n-0/changelog.gz
/usr/share/doc/libm17n-0/copyright

Changelog

2018-10-20 - Boyuan Yang <byang@debian.org>
m17n-lib (1.8.0-2) unstable; urgency=medium
* Team upload.
* debian/patches: Add patch to fix compatibility with libfreetype2
2.9+. (Closes: #892350).
2018-10-19 - Boyuan Yang <byang@debian.org>
m17n-lib (1.8.0-1) unstable; urgency=medium
* Team upload.
* New upstream release 1.8.0.
* debian/control:
+ Bump Standards-Version to 4.2.1.
+ Update Vcs-* fields and use git repo in Salsa input-method-team group
(Closes: #908794).
+ Add Input Method Team onto uploaders.
+ Bump debhelper compat to v11.
+ Drop unnecessary build-dependency dh-autoreconf, libtool, automake, etc.
* debian/watch:
+ Update to v4 format and use https protocol.
+ Add gpgmode=auto
* debian: Apply "wrap-and-sort -abst".
* debian/patches: Refresh patches.
* debian/rules:
+ Modernize packaging.
+ Disable parallel build to circumvent FTBFS.
* debian: Drop -dbg package for automatic debug package migration.
* debian/install:
+ Do not install nonexistent /usr/bin/m17n-config into libm17n-dev.
+ Install .a files into -dev package.
* debian/symbols: Refreshed.
2017-11-15 - Harshula Jayasuriya <harshula@debian.org>
m17n-lib (1.7.0-4) unstable; urgency=low
* debian/control: libm17n-0-dbg: Priority changed to "optional".
2016-01-11 - Harshula Jayasuriya <harshula@debian.org>
m17n-lib (1.7.0-3) unstable; urgency=low
* debian/control: libm17n-dev depends on dpkg-dev
2016-01-09 - Harshula Jayasuriya <harshula@debian.org>
m17n-lib (1.7.0-2) unstable; urgency=low
* debian/control: update multi-arch metadata. All binary packages covered.
* m17n-config: add 0001-m17n-config-remove-libtool-user-switches.patch
* m17n-config: add 0002-m17n-config-modify-to-support-multi-arch.patch
Thanks to Jakub Wilk <jwilk@debian.org> (Closes: #796770).
2015-08-22 - Harshula Jayasuriya <harshula@debian.org>
m17n-lib (1.7.0-1) unstable; urgency=low
* New upstream release 1.7.0.
* Update Standards-Version to Debian Policy 3.9.6. (No changes)
* debian/patches/0001-mconv-fix-checking-of-command-line-arguments.patch
not required.
* debian/libm17n-0.symbols: added new symbol minput_parse_im_names.
* debian/copyright: updated
* Create libm17n-dev.lintian-overrides and m17n-lib-bin.lintian-overrides
* Enable Multi-arch support
2014-09-09 - Harshula Jayasuriya <harshula@debian.org>
m17n-lib (1.6.4-3) unstable; urgency=low
* debian/control:
- Build-Depends: s/libgd2-noxpm-dev/libgd-dev/
- Add Vcs-Git & Vcs-Browser
- Depends: remove m17n-contrib. (Closes: #746928)
- Update Standards-Version to Debian Policy 3.9.5. (No changes)
* Fix debian-changelog-has-wrong-weekday
* Use dh-autoreconf (Closes: #750672).
2013-07-07 - Harshula Jayasuriya <harshula@debian.org>
m17n-lib (1.6.4-2) unstable; urgency=low
* The Mayhem Team reported the following bug:
http://www.forallsecure.com/bug-reports/69409d6ddf6f28f4f8f8f0c26b7c9c61d70d879e/
- Upstream patch: 0001-mconv-fix-checking-of-command-line-arguments.patch
* debian/control: DM-Upload-Allowed removed
2012-12-12 - Harshula Jayasuriya <harshula@debian.org>
m17n-lib (1.6.4-1) unstable; urgency=low
* New upstream release 1.6.4.
* Upstream has moved to https://savannah.nongnu.org/projects/m17n.
* Updated to debhelper 9.
* debian/copyright: update tarball location, homepage, copyright dates.
* debian/rules: use dpkg-buildflags
2012-05-27 - Harshula Jayasuriya <harshula@debian.org>
m17n-lib (1.6.3-2) unstable; urgency=low
* Update maintainer email address.
* Update Standards-Version to Debian Policy 3.9.3. (No changes)
* Fix debian-rules-missing-recommended-target.

See Also

Package Description
libm17n-dev_1.8.0-2_i386.deb multilingual text processing library - development
libm17n-im-config-dev_0.9.0-5_i386.deb input method configuration library for m17n-lib - development
libm17n-im-config0_0.9.0-5_i386.deb input method configuration library for m17n-lib - runtime
libm4ri-0.0.20140914_20140914-2+b1_i386.deb Method of the Four Russians Inversion library, shared library
libm4ri-dev_20140914-2+b1_i386.deb Method of the Four Russians Inversion library, development files
libm4rie-0.0.20150908_20150908-2_i386.deb extended Method of the Four Russians Inversion library, shared library
libm4rie-dev_20150908-2_i386.deb extended Method of the Four Russians Inversion library, development files
libmaa-dev_1.4.2-1_i386.deb maa programming library, development files
libmaa4_1.4.2-1_i386.deb maa programming library
libmac-widgets-doc_0.10.0+svn416-dfsg1-3_all.deb documentation for libmac-widgets-java
libmac-widgets-java_0.10.0+svn416-dfsg1-3_all.deb collection of Mac style widgets written in Java
libmad-ocaml-dev_0.4.4-2+b1_i386.deb OCaml bindings for the MAD library (Development package)
libmad-ocaml_0.4.4-2+b1_i386.deb OCaml bindings for the MAD library (Runtime library)
libmad0-dev_0.15.1b-10_i386.deb MPEG audio decoder development library
libmad0_0.15.1b-10_i386.deb MPEG audio decoder library
Advertisement
Advertisement