liblrs-dev_0.70-3_i386.deb


Advertisement

Description

liblrs-dev - package to enumerate vertices and extreme rays (development file)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename liblrs-dev_0.70-3_i386.deb
Package name liblrs-dev
Package version 0.70
Package release 3
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://cgm.cs.mcgill.ca/~avis/C/lrs.html
License -
Maintainer David Bremner <bremner@debian.org>
Download size 13.90 KB
Installed size 75.00 KB
A convex polyhedron is the set of points satisfying a finite family
of linear inequalities.  The study of the vertices and extreme rays
of such systems is important and useful in e.g. mathematics and
optimization.  In a dual interpretation, finding the vertices of a
(bounded) polyhedron is equivalent to finding the convex hull
(bounding inequalities) of an (arbitrary dimensional) set of points.
Lrs (lexicographic reverse search) has two important features that
can be very important for certain applications: it works in exact
arithmetic, and it consumes memory proportional to the input, no
matter how large the output is.
This package contains the optional headers, and a unversioned symlink
to the library, useful for developers.

Alternatives

Package Version Architecture Repository
liblrs-dev_0.70-3_amd64.deb 0.70 amd64 Debian Main
liblrs-dev - - -

Requires

Name Value
liblrs0 = 0.70-3

Replaces

Name Value
liblrsgmp-dev << 0.70

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblrs-dev_0.70-3_i386.deb
Source Package lrslib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblrs-dev deb package:
    # sudo apt-get install liblrs-dev

Files

Path
/usr/include/lrslib/lrsdriver.h
/usr/include/lrslib/lrsgmp.h
/usr/include/lrslib/lrslib.h
/usr/include/lrslib/lrslong.h
/usr/include/lrslib/lrsmp.h
/usr/lib/liblrs.so
/usr/share/doc/liblrs-dev/changelog.Debian.gz
/usr/share/doc/liblrs-dev/copyright

Changelog

2019-01-13 - David Bremner <bremner@debian.org>
lrslib (0.70-3) unstable; urgency=medium
* upload to unstable
* pass CFLAGS from dpkg-buildflags to make (fix generation of dbgsym
packages)
2019-01-13 - David Bremner <bremner@debian.org>
lrslib (0.70-2) experimental; urgency=medium
* Drop build of 128 bit arithmetic on 32 bit arches.  (Closes: #919086).
2019-01-07 - David Bremner <bremner@debian.org>
lrslib (0.70-1) experimental; urgency=medium
* Major new upstream release.
* Replace arithmetic specific libraries liblrsgmp{1,-dev} with
liblrs{0,-dev}. This is a severe ABI break, all clients will need to
be recompiled.
* New adaptive arithmetic feature restarts with wider arithmetic when
there is potential overflow
2017-07-04 - David Bremner <bremner@debian.org>
lrslib (0.62-2) unstable; urgency=medium
* rebuild for unstable
* fix watchfile
* update versioned depends on debhelper to >=10
2017-02-21 - David Bremner <bremner@debian.org>
lrslib (0.62-1) experimental; urgency=low
* New upstream release
2015-07-23 - David Bremner <bremner@debian.org>
lrslib (0.51-2) unstable; urgency=medium
* upload to unstable
2015-02-03 - David Bremner <bremner@debian.org>
lrslib (0.51-1) experimental; urgency=low
* new upstream release
* rename shared library to include arithmetic type
* drop static library, see if anyone complains.
2013-08-11 - David Bremner <bremner@debian.org>
lrslib (0.43-1) unstable; urgency=low
* New upstream release
* Enable hardening flags
* Update Standards-version to 3.9.4 (no mandatory changes,
debian/copyright syntax tidied.)
2009-10-16 - David Bremner <bremner@unb.ca>
lrslib (0.42c-1) unstable; urgency=low
* Initial release (Closes: #454469)

See Also

Package Description
liblrs0_0.70-3_i386.deb package to enumerate vertices and extreme rays (shared libraries)
liblsan0-amd64-cross_8.3.0-2cross1_all.deb LeakSanitizer -- a memory leak detector (runtime)
liblsan0-arm64-cross_8.3.0-2cross1_all.deb LeakSanitizer -- a memory leak detector (runtime)
liblsan0-ppc64-cross_8.3.0-2cross2_all.deb LeakSanitizer -- a memory leak detector (runtime)
liblsan0-ppc64el-cross_8.3.0-2cross1_all.deb LeakSanitizer -- a memory leak detector (runtime)
liblscp-dev_0.6.0-1_i386.deb Development files for LinuxSampler Control Protocol library
liblscp-doc_0.6.0-1_all.deb Documentation for LinuxSampler Control Protocol library
liblscp6_0.6.0-1_i386.deb LinuxSampler Control Protocol wrapper library
liblsofui7_5.14.5-1_i386.deb library for monitoring your system - shared library
libltc-dev_1.3.0-1_i386.deb Development files for libltc
libltc-doc_1.3.0-1_all.deb Documentation for libltc
libltc11_1.3.0-1_i386.deb linear timecode library
libltcsmpte-dev_0.4.4-1+b1_i386.deb Development files for libltcsmpte
libltcsmpte-doc_0.4.4-1_all.deb Documentation for libltcsmpte
libltcsmpte1_0.4.4-1+b1_i386.deb linear timecode and framerate conversion library
Advertisement
Advertisement