liblinux-prctl-perl_1.6.0-3+b4_i386.deb


Advertisement

Description

liblinux-prctl-perl - Perl extension for controlling process characteristics

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename liblinux-prctl-perl_1.6.0-3+b4_i386.deb
Package name liblinux-prctl-perl
Package version 1.6.0
Package release 3+b4
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib
Homepage https://metacpan.org/release/Linux-Prctl
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 30.64 KB
Installed size 103.00 KB
Linux::Prctl provides a nice interface to the Linux prctl function. The
Linux prctl function allows you to control specific characteristics of
a process' behaviour.
Besides prctl, this library also wraps libcap for complete
capability handling.

Alternatives

Package Version Architecture Repository
liblinux-prctl-perl_1.6.0-3+b4_amd64.deb 1.6.0 amd64 Debian Main
liblinux-prctl-perl - - -

Requires

Name Value
libc6 >= 2.4
libcap2 >= 1:2.10
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblinux-prctl-perl_1.6.0-3+b4_i386.deb
Source Package liblinux-prctl-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblinux-prctl-perl deb package:
    # sudo apt-get install liblinux-prctl-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/Linux/Prctl.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Linux/Prctl/CapabilityBoundingSet.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Linux/Prctl/CapabilitySet.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Linux/Prctl/Securebits.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/Linux/Prctl/Prctl.so
/usr/share/doc/liblinux-prctl-perl/changelog.Debian.gz
/usr/share/doc/liblinux-prctl-perl/changelog.Debian.i386.gz
/usr/share/doc/liblinux-prctl-perl/copyright
/usr/share/man/man3/Linux::Prctl.3pm.gz

Changelog

2016-05-20 - Salvatore Bonaccorso <carnil@debian.org>
liblinux-prctl-perl (1.6.0-3) unstable; urgency=low
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
* Skrip t/{capbset,seccomp}.t tests for now (Cf. #806542)
* Declare compliance with Debian policy 3.9.8
2015-05-17 - Salvatore Bonaccorso <carnil@debian.org>
liblinux-prctl-perl (1.6.0-2) unstable; urgency=low
* Add Remove-stray-use-Linux-Prctl.patch.
Remove stray "use Linux::Prctl" from the
Linux::Prctl::CapabilityBoundingSet, Linux::Prctl::CapabilitySet and
Linux::Prctl::Securebits modules. (Closes: #784829)
2015-04-27 - Salvatore Bonaccorso <carnil@debian.org>
liblinux-prctl-perl (1.6.0-1) unstable; urgency=low
* Update Vcs-Browser URL to cgit web frontend
* Imported Upstream version 1.6.0
* Update copyright for upstream files
* Update copyright years for debian/ packaging files
* Add Testsuite: autopkgtest-pkg-perl field in debian/control
* Declare compliance with Debian policy 3.9.6
2014-06-19 - Salvatore Bonaccorso <carnil@debian.org>
liblinux-prctl-perl (1.5.0-2) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Correct versioned Build-Depends on debhelper to get all hardening flags.
Adjust versioned Build-Depends on debhelper to debhelper (>=
9.20120312~) to quarantee we get all hardening build flags.
* Declare compliance with Debian Policy 3.9.5
2012-12-05 - Salvatore Bonaccorso <carnil@debian.org>
liblinux-prctl-perl (1.5.0-1) unstable; urgency=low
* Initial Release. (Closes: #694978)

See Also

Package Description
liblinux-usermod-perl_0.69-2_all.deb module to modify user and group accounts
liblip-dev_2.0.0-1.2_i386.deb reliable interpolation of multivariate scattered data
liblip2_2.0.0-1.2_i386.deb reliable interpolation of multivariate scattered data
libliquid-dev_1.3.1-1_i386.deb signal processing library for software defined radio (development files)
libliquid1d_1.3.1-1_i386.deb signal processing library for software defined radio
liblirc-client0_0.10.1-5.2_i386.deb infra-red remote control support - client library
liblirc-dev_0.10.1-5.2_i386.deb Infra-red remote control support - development files
liblirc0_0.10.1-5.2_i386.deb Infra-red remote control support - Run-time libraries
liblircclient-dev_0.10.1-5.2_i386.deb Transitional placeholder for obsoleted liblircclient-dev
liblircclient0_0.10.1-5.2_i386.deb Transitional placeholder for obsoleted liblircclient0
liblist-allutils-perl_0.15-1_all.deb Perl wrapper for modules List::Util and List::MoreUtils
liblist-compare-perl_0.53-1_all.deb Perl module for comparing elements of two or more lists
liblist-maker-perl_0.005-2_all.deb Perl module to generate more sophisticated lists than just $a..$b
liblist-moreutils-perl_0.416-1+b4_i386.deb Perl module with additional list functions not found in List::Util
liblist-objects-withutils-perl_2.028003-1_all.deb list objects, kitchen sink included
Advertisement
Advertisement