liblinux-epoll-perl_0.016-1+b1_i386.deb


Advertisement

Description

liblinux-epoll-perl - perl epoll module for O(1) multiplexing

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename liblinux-epoll-perl_0.016-1+b1_i386.deb
Package name liblinux-epoll-perl
Package version 0.016
Package release 1+b1
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib
Homepage https://metacpan.org/release/Linux-Epoll
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 16.76 KB
Installed size 51.00 KB
Epoll is a multiplexing mechanism that scales up O(1) with number of watched
files. Linux::Epoll is a callback style epoll module, unlike other epoll
modules available on CPAN.

Alternatives

Package Version Architecture Repository
liblinux-epoll-perl_0.016-1+b1_amd64.deb 0.016 amd64 Debian Main
liblinux-epoll-perl - - -

Requires

Name Value
libc6 >= 2.9
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblinux-epoll-perl_0.016-1+b1_i386.deb
Source Package liblinux-epoll-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblinux-epoll-perl deb package:
    # sudo apt-get install liblinux-epoll-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/Linux/Epoll.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/Linux/Epoll/Epoll.bs
/usr/lib/i386-linux-gnu/perl5/5.28/auto/Linux/Epoll/Epoll.so
/usr/share/doc/liblinux-epoll-perl/changelog.Debian.gz
/usr/share/doc/liblinux-epoll-perl/changelog.Debian.i386.gz
/usr/share/doc/liblinux-epoll-perl/changelog.gz
/usr/share/doc/liblinux-epoll-perl/copyright
/usr/share/man/man3/Linux::Epoll.3pm.gz

Changelog

2018-10-21 - gregor herrmann <gregoa@debian.org>
liblinux-epoll-perl (0.016-1) unstable; urgency=medium
* Import upstream version 0.016.
* Declare compliance with Debian Policy 4.2.1.
2018-07-26 - Lucas Kanashiro <kanashiro@debian.org>
liblinux-epoll-perl (0.015-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.015
* Bump debhelper compatibility level to 11
* Declare compliance with Debian Policy 4.1.5
* Create patch to fix spelling errors in manpage
2018-03-31 - gregor herrmann <gregoa@debian.org>
liblinux-epoll-perl (0.013-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* Import upstream version 0.013.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.1.3.
* Bump debhelper compatibility level to 10.
* Set bindnow linker flag in debian/rules.
2015-06-11 - gregor herrmann <gregoa@debian.org>
liblinux-epoll-perl (0.012-1) unstable; urgency=medium
* Add debian/upstream/metadata
* Import upstream version 0.012
* Update years of packaging copyright.
* Drop version from libmodule-build-perl build dependency.
* Declare compliance with Debian Policy 3.9.6.
* Mark package as autopkgtest-able.
* Fix email address in debian/upstream/metadata. Thanks to duck.
2014-09-15 - gregor herrmann <gregoa@debian.org>
liblinux-epoll-perl (0.011-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* debian/control: update Module::Build dependency.
* New upstream release.
2014-05-07 - gregor herrmann <gregoa@debian.org>
liblinux-epoll-perl (0.010-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
* New upstream release.
* Update years of copyright.
* Declare compliance with Debian Policy 3.9.5.
2012-12-15 - gregor herrmann <gregoa@debian.org>
liblinux-epoll-perl (0.7-1) unstable; urgency=low
* Initial release (closes: #696027).

See Also

Package Description
liblinux-fd-perl_0.011-2+b1_i386.deb Linux specific special filehandles
liblinux-inotify2-perl_2.1-1_i386.deb scalable directory and file change notification
liblinux-io-prio-perl_0.03-2_all.deb interface to Linux ioprio_set(2) and ioprio_get(2)
liblinux-kernelsort-perl_0.01-3_all.deb Perl module for sorting Linux Kernel version strings
liblinux-lvm-perl_0.17-2_all.deb Perl module to access LVM status information
liblinux-pid-perl_0.04-1+b6_i386.deb wrapper around the getpid() and getppid() C functions
liblinux-prctl-perl_1.6.0-3+b4_i386.deb Perl extension for controlling process characteristics
liblinux-usermod-perl_0.69-2_all.deb module to modify user and group accounts
liblip-dev_2.0.0-1.2_i386.deb reliable interpolation of multivariate scattered data
liblip2_2.0.0-1.2_i386.deb reliable interpolation of multivariate scattered data
libliquid-dev_1.3.1-1_i386.deb signal processing library for software defined radio (development files)
libliquid1d_1.3.1-1_i386.deb signal processing library for software defined radio
liblirc-client0_0.10.1-5.2_i386.deb infra-red remote control support - client library
liblirc-dev_0.10.1-5.2_i386.deb Infra-red remote control support - development files
liblirc0_0.10.1-5.2_i386.deb Infra-red remote control support - Run-time libraries
Advertisement
Advertisement