liblash-compat-dev_1+dfsg0-5.1_all.deb


Advertisement

Description

liblash-compat-dev - LASH compatibility library (development files)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename liblash-compat-dev_1+dfsg0-5.1_all.deb
Package name liblash-compat-dev
Package version 1+dfsg0
Package release 5.1
Package architecture all
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://ladish.org/
License -
Maintainer Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Download size 10.99 KB
Installed size 43.00 KB
liblash-compat is a library and associated header files, that aims
to provide lash environment for apps that can use it. Currently it
does not interact with ladish daemon yet. In its current state, it
enables building lash-aware apps but they will fail to contact the
lash server.
In its current state, it enables building lash-aware apps but they
will fail to contact the lash server.
This package provides the development files.

Alternatives

Package Version Architecture Repository
liblash-compat-dev_1+dfsg0-5.1_all.deb 1+dfsg0 all Debian Main
liblash-compat-dev - - -

Requires

Name Value
libdbus-1-dev -
liblash-compat-1debian0 >= 1+dfsg0-5.1
liblash-compat-1debian0 << 1+dfsg0+1~
uuid-dev -

Replaces

Name Value
liblash-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblash-compat-dev_1+dfsg0-5.1_all.deb
Source Package ladish

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblash-compat-dev deb package:
    # sudo apt-get install liblash-compat-dev

Files

Path
/usr/include/lash/client_interface.h
/usr/include/lash/config.h
/usr/include/lash/event.h
/usr/include/lash/lash.h
/usr/include/lash/protocol.h
/usr/include/lash/types.h
/usr/lib/liblash.so
/usr/lib/pkgconfig/lash-1.0.pc
/usr/share/doc/liblash-compat-dev/changelog.Debian.gz
/usr/share/doc/liblash-compat-dev/changelog.gz
/usr/share/doc/liblash-compat-dev/copyright

Changelog

2017-03-20 - Adrian Bunk <bunk@debian.org>
ladish (1+dfsg0-5.1) unstable; urgency=medium
* Non-maintainer upload.
* Add arm64, hppa and sparc64 to the architectures where stacktraces
are disabled, thanks to Helge Deller. (Closes: #762016)
2014-09-17 - Alessio Treglia <alessio@debian.org>
ladish (1+dfsg0-5) unstable; urgency=medium
* Add patch to avoid gladish crash when DBus connection has failed.
* Bump Standards.
2013-06-03 - Sebastian Ramacher <sramacher@debian.org>
ladish (1+dfsg0-4) unstable; urgency=low
* Team upload.
* debian/patches/eglibc-2.17.patch: Fix FTBFS with eglibc 2.17. (Closes:
#701440)
2012-05-16 - Alessio Treglia <alessio@debian.org>
ladish (1+dfsg0-3) unstable; urgency=low
* Use ladi-control-center by default instead of the obsolete
ladiconf (Closes: #671360).
* Update debian/copyright to machine readable format.
* Bump Standards.
2012-01-31 - Alessio Treglia <alessio@debian.org>
ladish (1+dfsg0-2) unstable; urgency=low
* Revert "Drop lash compatibility library, it's not needed anymore."
After a brief discussion with upstream's author, I've decided to
reintroduce the dummy lash support to provide the L2 level of
interaction until libladish is released.
* Properly bump the SONAME due to the ABI breakage introduced by
the latest ladish release.
* Update debian/copyright.
* Fix small misspellings.
2012-01-09 - Alessio Treglia <alessio@debian.org>
ladish (1+dfsg0-1) unstable; urgency=low
* Add unpack_waf.sh shell script to get rid of the 'waf' blob file.
* Repack upstream tarball to get rid of the waf blob (Closes: #654481).
* debian/watch: Mangle Debian versioning.
* Call 'waf clean' instead of 'distclean', skip errors, prune *.pyc files.
2012-01-03 - Alessio Treglia <alessio@debian.org>
ladish (1-1) unstable; urgency=low
* First upstream stable release -> yeah!
* Drop unnecessary patches:
- 0001-disable_stacktrace.patch
- 0002-desktop_file.patch
- 0003-save_as_dialog_avoid_multiplied_emits.patch
- 0004-dont_activate_disabled_widgets.patch
- 1004-in_terminal_execution.patch
- 1005-kfreebsd.patch
- 1006-gladish_dependencies.patch
* Refresh 2001-xterminal_emulator_instead_of_xterm.patch.
* Drop lash compatibility library, it's not needed anymore since we
don't want applications use something deprecated.
* mv debian/REDME.source to debian/README.source.
* Remove --enable-liblash from configure's command line options.
2011-09-14 - Alessio Treglia <alessio@debian.org>
ladish (0.3-10) unstable; urgency=low
* Symlink libalsapid.so into /usr/lib (Closes: #641452).
2011-08-31 - Alessio Treglia <alessio@debian.org>
ladish (0.3-9) unstable; urgency=medium
* Update kfreebsd's patch (Closes: #639490).
* Prevent SIGSEGV when launching gladish (LP: #835166).
2011-08-27 - Alessio Treglia <alessio@debian.org>
ladish (0.3-8) unstable; urgency=low
* Include <linux/limits.h> only on Linux architectures.
* Add Recommends: a2jmidid.
* Append gtk+-2.0 to gladish's dependencies list to
prevent FTBFS (Closes: #639054 and LP: #831248).

See Also

Package Description
liblasi-dev_1.1.0-2_i386.deb development files and documentation for the LASi library
liblasi0_1.1.0-2_i386.deb creation of PostScript documents containing Unicode symbols
liblasso-perl_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - Perl bindings
liblasso3-dev_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - development kit
liblasso3_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - runtime library
liblastfm-dev_1.0.9-1+b11_i386.deb Last.fm web services library (Qt4 build) - development files
liblastfm-fingerprint1_1.0.9-1+b11_i386.deb Last.fm fingerprinting library (Qt4 build)
liblastfm-fingerprint5-1_1.0.9-1+b11_i386.deb Last.fm fingerprinting library (Qt5 build)
liblastfm-java_0.1.0-2_all.deb last.fm API bindings for Java
liblastfm-ocaml-dev_0.3.0-4+b6_i386.deb OCaml interface to audioscrobbler and lastfm radios
liblastfm1_1.0.9-1+b11_i386.deb Last.fm web services library (Qt4 build)
liblastfm5-1_1.0.9-1+b11_i386.deb Last.fm web services library (Qt5 build)
liblastfm5-dev_1.0.9-1+b11_i386.deb Last.fm web services library (Qt5 build) - development files
liblatex-decode-perl_0.05-1_all.deb Perl module to convert LaTeX input to Unicode
liblatex-driver-perl_0.300.2-2_all.deb driver module that encapsulates the details of formatting a LaTeX document
Advertisement
Advertisement