liblaser-geometry0d_1.6.4-6+b1_i386.deb


Advertisement

Description

liblaser-geometry0d - Robot OS laser geometry package

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename liblaser-geometry0d_1.6.4-6+b1_i386.deb
Package name liblaser-geometry0d
Package version 1.6.4
Package release 6+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://wiki.ros.org/laser_geometry
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 35.04 KB
Installed size 107.00 KB
This package is part of Robot OS (ROS). It contains a class for
converting from a 2D laser scan as defined by sensor_msgs/LaserScan
into a point cloud as defined by sensor_msgs/PointCloud or
sensor_msgs/PointCloud2. In particular, it contains functionality to
account for the skew resulting from moving robots or tilting laser
scanners.
This package contains the library itself.

Alternatives

Package Version Architecture Repository
liblaser-geometry0d_1.6.4-6+b1_amd64.deb 1.6.4 amd64 Debian Main
liblaser-geometry0d - - -

Requires

Name Value
libactionlib0d -
libboost-atomic1.67.0 -
libboost-chrono1.67.0 -
libboost-date-time1.67.0 -
libboost-filesystem1.67.0 -
libboost-regex1.67.0 >= 1.67.0-10
libboost-signals1.67.0 -
libboost-system1.67.0 -
libboost-thread1.67.0 -
libc6 >= 2.4
libconsole-bridge0.4 -
libcpp-common0d -
libgcc1 >= 1:3.0
liblog4cxx10v5 -
libmessage-filters1d -
librosconsole2d -
libroscpp-serialization0d -
libroscpp2d -
librostime0d -
libstdc++6 >= 5.2
libtf1d -
libtf2-1d -
libtf2-ros0d -
libxmlrpcpp2d -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblaser-geometry0d_1.6.4-6+b1_i386.deb
Source Package ros-laser-geometry

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblaser-geometry0d deb package:
    # sudo apt-get install liblaser-geometry0d

Files

Path
/usr/lib/i386-linux-gnu/liblaser_geometry.so.0d
/usr/lib/i386-linux-gnu/liblaser_geometry.so.1.6.4
/usr/share/doc/liblaser-geometry0d/changelog.Debian.gz
/usr/share/doc/liblaser-geometry0d/changelog.Debian.i386.gz
/usr/share/doc/liblaser-geometry0d/changelog.gz
/usr/share/doc/liblaser-geometry0d/copyright

Changelog

2018-11-07 - Jochen Sprickerhof <jspricke@debian.org>
ros-laser-geometry (1.6.4-6) unstable; urgency=medium
* Remove cmake-modules dependency
* Add Python 3 package
* Bump policy version (no changes)
2018-07-31 - Jochen Sprickerhof <jspricke@debian.org>
ros-laser-geometry (1.6.4-5) unstable; urgency=medium
* Add new patch to fix build
* Bump policy version (no changes)
2018-07-29 - Jochen Sprickerhof <jspricke@debian.org>
ros-laser-geometry (1.6.4-4) unstable; urgency=medium
* limit d/watch to ROS1
* Add patch for Eigen dependency
2018-04-18 - Jochen Sprickerhof <jspricke@debian.org>
ros-laser-geometry (1.6.4-3) unstable; urgency=medium
* Bumped Standards-Version to 3.9.8, no changes needed.
* Update Vcs URLs
* Update my email address
* Update watch file
* Remove old catkin version
* Update Vcs URLs to salsa.d.o
* Add R³
* http -> https
* Add missing dependencies
* Update policy and debhelper versions
2016-01-10 - Jochen Sprickerhof <debian@jochen.sprickerhof.de>
ros-laser-geometry (1.6.4-2) unstable; urgency=medium
* Add dependencies
2015-12-26 - Jochen Sprickerhof <debian@jochen.sprickerhof.de>
ros-laser-geometry (1.6.4-1) unstable; urgency=medium
* Initial release (Closes: #805332)

See Also

Package Description
liblash-compat-1debian0_1+dfsg0-5.1_i386.deb LASH compatibility library
liblash-compat-dev_1+dfsg0-5.1_all.deb LASH compatibility library (development files)
liblasi-dev_1.1.0-2_i386.deb development files and documentation for the LASi library
liblasi0_1.1.0-2_i386.deb creation of PostScript documents containing Unicode symbols
liblasso-perl_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - Perl bindings
liblasso3-dev_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - development kit
liblasso3_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - runtime library
liblastfm-dev_1.0.9-1+b11_i386.deb Last.fm web services library (Qt4 build) - development files
liblastfm-fingerprint1_1.0.9-1+b11_i386.deb Last.fm fingerprinting library (Qt4 build)
liblastfm-fingerprint5-1_1.0.9-1+b11_i386.deb Last.fm fingerprinting library (Qt5 build)
liblastfm-java_0.1.0-2_all.deb last.fm API bindings for Java
liblastfm-ocaml-dev_0.3.0-4+b6_i386.deb OCaml interface to audioscrobbler and lastfm radios
liblastfm1_1.0.9-1+b11_i386.deb Last.fm web services library (Qt4 build)
liblastfm5-1_1.0.9-1+b11_i386.deb Last.fm web services library (Qt5 build)
liblastfm5-dev_1.0.9-1+b11_i386.deb Last.fm web services library (Qt5 build) - development files
Advertisement
Advertisement