liblasclasses1_2.6.7.6+ds-1+b1_i386.deb


Advertisement

Description

liblasclasses1 - GDAL add-on tools to perform useful raster processing - liblasClasses

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename liblasclasses1_2.6.7.6+ds-1+b1_i386.deb
Package name liblasclasses1
Package version 2.6.7.6+ds
Package release 1+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://pktools.nongnu.org/
License -
Maintainer Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Download size 23.11 KB
Installed size 67.00 KB
Pktools is a collection of programs to perform operations, mostly on
raster geolocated  images. It  heavily relies  on the  Geospatial Data
Abstraction Library (GDAL) and OGR.  The programs are similar to the
GDAL tools (gdalinfo, gdal_translate,  gdal_merge, ...) and some of the
functionalities provided in pktools already exist in the GDAL tools.
All utilities in pktools use command line options and have a built
in help, and include more than thirty binaries to edit, change, crop,
classify, compare, dump, fill, enhance images and many other
common operations useful in the remote sensing field of image
analysis.
This package contains the liblasClasses shared library.

Alternatives

Package Version Architecture Repository
liblasclasses1_2.6.7.6+ds-1+b1_amd64.deb 2.6.7.6+ds amd64 Debian Main
liblasclasses1 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libstdc++6 >= 5.2

Replaces

Name Value
pktools << 2.5.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblasclasses1_2.6.7.6+ds-1+b1_i386.deb
Source Package pktools

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblasclasses1 deb package:
    # sudo apt-get install liblasclasses1

Files

Path
/usr/lib/i386-linux-gnu/liblasClasses.so.1
/usr/lib/i386-linux-gnu/liblasClasses.so.1.6.1
/usr/share/doc/liblasclasses1/changelog.Debian.gz
/usr/share/doc/liblasclasses1/changelog.Debian.i386.gz
/usr/share/doc/liblasclasses1/changelog.gz
/usr/share/doc/liblasclasses1/copyright

Changelog

2018-11-25 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7.6+ds-1) unstable; urgency=medium
* New upstream release.
* Exclude more automatically removed files from upstream tarball.
* Drop patches, applied upstream.
2018-11-24 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7.5+ds-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 4.2.1, no changes.
* Add Build-Depends-Package field to symbols files.
* Refresh patches.
* Update symbols for amd64.
2018-08-19 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7.4+ds-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 4.2.0, no changes.
* Drop gdal-c++11.patch, applied upstream.
* Update symbols for amd64.
2018-08-01 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7.3+ds-3) unstable; urgency=medium
* Strip trailing whitespace from control & rules files.
* Bump Standards-Version to 4.1.5, no changes.
* Drop autopkgtest to test installability.
* Add lintian override for testsuite-autopkgtest-missing.
* Update symbols for amd64.
2018-04-23 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7.3+ds-2) unstable; urgency=medium
* Update Vcs-* URLs for Salsa.
* Bump Standards-Version to 4.1.4, no changes.
* Add patch to use C++11 for compatibility with GDAL 2.3.0.
* Update symbols for amd64.
2018-02-07 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7.3+ds-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 4.1.3, no changes.
* Update watch file to use HTTPS.
* Update copyright-format URL to use HTTPS.
* Update watch file to check for uppercase releases too.
* Install libraries in Multi-Arch path.
* Update symbols for amd64.
2017-06-29 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7.1+ds-1) unstable; urgency=medium
* New upstream release.
* Exclude build directory and autocleaned files from upstream source.
* Update copyright years for Pieter Kempeneers.
* Drop patches applied upstream.
* Bump Standards-Version to 4.0.0, no changes.
* Add autopkgtest to test installability.
* Use pkg-info.mk variables instead of dpkg-parsechangelog output.
* Install pk{ann,reclass,svm}ogr in pktools package.
* Update spelling-errors2.patch to fix new 'columns' typo.
* Add manpages for new executables.
2016-11-05 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7-3) unstable; urgency=medium
* Update symbols for other architectures.
* Add patch to fix spelling errors.
2016-05-23 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7-2) unstable; urgency=medium
* Update symbols for other architectures.
2016-05-21 - Bas Couwenberg <sebastic@debian.org>
pktools (2.6.7-1) unstable; urgency=medium
* Add upstream patch to fix pklas2img build failure.
* Update symbols for arm64, hppa, hurd-i386, i386, kfreebsd-*,
mips, mips64el, powerpc, ppc64el & s390x.
* Move from experimental to unstable.

See Also

Package Description
liblaser-geometry-dev_1.6.4-6+b1_i386.deb Robot OS laser geometry package - development files
liblaser-geometry0d_1.6.4-6+b1_i386.deb Robot OS laser geometry package
liblash-compat-1debian0_1+dfsg0-5.1_i386.deb LASH compatibility library
liblash-compat-dev_1+dfsg0-5.1_all.deb LASH compatibility library (development files)
liblasi-dev_1.1.0-2_i386.deb development files and documentation for the LASi library
liblasi0_1.1.0-2_i386.deb creation of PostScript documents containing Unicode symbols
liblasso-perl_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - Perl bindings
liblasso3-dev_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - development kit
liblasso3_2.6.0-2+b2_i386.deb Library for Liberty Alliance and SAML protocols - runtime library
liblastfm-dev_1.0.9-1+b11_i386.deb Last.fm web services library (Qt4 build) - development files
liblastfm-fingerprint1_1.0.9-1+b11_i386.deb Last.fm fingerprinting library (Qt4 build)
liblastfm-fingerprint5-1_1.0.9-1+b11_i386.deb Last.fm fingerprinting library (Qt5 build)
liblastfm-java_0.1.0-2_all.deb last.fm API bindings for Java
liblastfm-ocaml-dev_0.3.0-4+b6_i386.deb OCaml interface to audioscrobbler and lastfm radios
liblastfm1_1.0.9-1+b11_i386.deb Last.fm web services library (Qt4 build)
Advertisement
Advertisement